aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs-devel-mule
diff options
context:
space:
mode:
authorDejan Lesjak <lesi@FreeBSD.org>2005-07-24 02:24:22 +0000
committerDejan Lesjak <lesi@FreeBSD.org>2005-07-24 02:24:22 +0000
commitcd7c6b6c11a29d6d57a526979851ff9f6b634b32 (patch)
tree4cc01cfb5706207279926308c4bae89a31be9c97 /editors/xemacs-devel-mule
parent5fb94664a881f416315b8cec522038e8ff3387ea (diff)
downloadports-cd7c6b6c11a29d6d57a526979851ff9f6b634b32.tar.gz
ports-cd7c6b6c11a29d6d57a526979851ff9f6b634b32.zip
Extend an ifdef from __amd64__ to other _LP64 archs and unbreak for sparc64
and ia64. (Not actually tested on ia64, but same fix does make xemacs-devel build there according to pointyhat.) Approved by: Andrey Slusar (maintainer)
Notes
Notes: svn path=/head/; revision=139993
Diffstat (limited to 'editors/xemacs-devel-mule')
-rw-r--r--editors/xemacs-devel-mule/Makefile4
-rw-r--r--editors/xemacs-devel-mule/files/patch-unexelf.c11
2 files changed, 11 insertions, 4 deletions
diff --git a/editors/xemacs-devel-mule/Makefile b/editors/xemacs-devel-mule/Makefile
index 6e1bcafd1242..acaa23e7133d 100644
--- a/editors/xemacs-devel-mule/Makefile
+++ b/editors/xemacs-devel-mule/Makefile
@@ -105,10 +105,6 @@ PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
-BROKEN= "Does not build on ${ARCH}"
-.endif
-
pre-fetch:
.if defined(WITHOUT_X11)
@${ECHO_MSG} ""
diff --git a/editors/xemacs-devel-mule/files/patch-unexelf.c b/editors/xemacs-devel-mule/files/patch-unexelf.c
new file mode 100644
index 000000000000..4def66b623ac
--- /dev/null
+++ b/editors/xemacs-devel-mule/files/patch-unexelf.c
@@ -0,0 +1,11 @@
+--- src/unexelf.c.orig Fri Jul 22 23:34:12 2005
++++ src/unexelf.c Fri Jul 22 23:34:42 2005
+@@ -477,7 +477,7 @@
+ # include <sys/exec_elf.h>
+ #endif
+
+-#if defined(__FreeBSD__) && (defined(__alpha__) || defined(__amd64__))
++#if defined(__FreeBSD__) && (defined(__alpha__) || defined(_LP64))
+ # ifdef __STDC__
+ # define ElfW(type) Elf64_##type
+ # else