aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs-devel-mule
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /editors/xemacs-devel-mule
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'editors/xemacs-devel-mule')
-rw-r--r--editors/xemacs-devel-mule/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/editors/xemacs-devel-mule/Makefile b/editors/xemacs-devel-mule/Makefile
index 15c90685f1b5..fb7df634fa0c 100644
--- a/editors/xemacs-devel-mule/Makefile
+++ b/editors/xemacs-devel-mule/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xemacs-devel-mule
PORTVERSION= ${XEMACS_VER:S/-/./}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES+= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
MASTER_SITE_SUBDIR= xemacs-${XEMACS_REL}
@@ -43,7 +43,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
compface.1:${PORTSDIR}/mail/faces
-USE_XORG= x11 xpm
+USE_XORG+= x11 xpm
CONFIGURE_ARGS= --with-xpm
.endif
@@ -57,14 +57,12 @@ USE_AUTOTOOLS= autoconf:261
CONFIGURE_TARGET=--build=${XEMACS_ARCH}
CONFIGURE_ARGS+= --enable-mule \
- --x-includes=${X11BASE}/include \
- --x-libraries=${X11BASE}/lib \
--with-site-libraries='${SITE_LIBRARIES}' \
--with-site-includes='${SITE_INCLUDES}' \
--enable-sound=native \
--with-site-lisp \
--with-pop \
- --with-infopath=${LOCALBASE}/lib/xemacs/info:${LOCALBASE}/info:${X11BASE}/info:/usr/info:${LOCALBASE}/lib/texmf/doc/info:/usr/lib/texmf/doc:/usr/share/info \
+ --with-infopath=${LOCALBASE}/lib/xemacs/info:${LOCALBASE}/info:/usr/info:${LOCALBASE}/lib/texmf/doc/info:/usr/lib/texmf/doc:/usr/share/info \
--enable-clash-detection \
--enable-database=berkdb \
${WITH_XIM} \
@@ -110,7 +108,7 @@ CONFIGURE_ARGS+=--disable-kkcc --disable-mc-alloc --disable-newgc
.if defined(WITH_XFT)
BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
-USE_XORG= x11 xft xpm
+USE_XORG+= x11 xft xpm
CONFIGURE_ARGS+=--with-xft=all
.elif defined(WITH_GTK)
CONFIGURE_ARGS+=--with-gtk