aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs-devel
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-03-16 20:24:35 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-03-16 20:24:35 +0000
commit5446e7d9be92ff04d6ad5f8fcf5a73363ab44c3a (patch)
tree2e9b99ae2186fd13b4342f2069456f07c8b4479e /editors/xemacs-devel
parent442ce6cf96e4ca037bc94302d3b0bd73f16ec88a (diff)
downloadports-5446e7d9be92ff04d6ad5f8fcf5a73363ab44c3a.tar.gz
ports-5446e7d9be92ff04d6ad5f8fcf5a73363ab44c3a.zip
- Update to 21.5-b25 "eggplant".
- Disable debug options and experimental features for more stabilty and improve perfomance.
Notes
Notes: svn path=/head/; revision=157456
Diffstat (limited to 'editors/xemacs-devel')
-rw-r--r--editors/xemacs-devel/Makefile8
-rw-r--r--editors/xemacs-devel/distinfo6
-rw-r--r--editors/xemacs-devel/files/patch-cmdloop.el28
-rw-r--r--editors/xemacs-devel/files/patch-diagnose.el17
-rw-r--r--editors/xemacs-devel/files/patch-dynarr.c57
-rw-r--r--editors/xemacs-devel/files/patch-objects-gtk.c28
-rw-r--r--editors/xemacs-devel/files/patch-objects-x.c49
-rw-r--r--editors/xemacs-devel/files/patch-profile.h16
-rw-r--r--editors/xemacs-devel/files/patch-syntax.c37
-rw-r--r--editors/xemacs-devel/files/patch-x-win-xfree86.el46
-rw-r--r--editors/xemacs-devel/files/patch-xgccache.c17
-rw-r--r--editors/xemacs-devel/files/patch-xlwmenu.c18
12 files changed, 42 insertions, 285 deletions
diff --git a/editors/xemacs-devel/Makefile b/editors/xemacs-devel/Makefile
index 29b7c940cd15..78d5f9ae0eb1 100644
--- a/editors/xemacs-devel/Makefile
+++ b/editors/xemacs-devel/Makefile
@@ -7,7 +7,6 @@
PORTNAME= xemacs-devel
PORTVERSION= ${XEMACS_VER:S/-/./}
-PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES+= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
@@ -35,7 +34,7 @@ USE_XPM= yes
XEMACS_MAJOR_VER?= 21
XEMACS_REL= ${XEMACS_MAJOR_VER}.5
-XEMACS_VER= ${XEMACS_MAJOR_VER}.5-b24
+XEMACS_VER= ${XEMACS_MAJOR_VER}.5-b25
XEMACS_ARCH= ${CONFIGURE_TARGET}
WRKSRC= ${WRKDIR}/xemacs-${XEMACS_VER:S/-b/./}
@@ -51,6 +50,11 @@ CONFIGURE_ARGS?=--enable-clash-detection \
--with-postgresql=no \
--with-site-lisp \
--enable-database=berkdb \
+ --disable-debug \
+ --disable-error-checking \
+ --disable-kkcc \
+ --disable-mc-alloc \
+ --disable-newgc \
${WITH_XFACE} ${WITH_DIALOGS} ${WITH_OFFIX} ${WITH_GTK}
MAKE_ARGS= prefix=${PREFIX}
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
diff --git a/editors/xemacs-devel/distinfo b/editors/xemacs-devel/distinfo
index b84291ce0087..f85ee6ec449a 100644
--- a/editors/xemacs-devel/distinfo
+++ b/editors/xemacs-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (xemacs/xemacs-21.5.24.tar.gz) = ac64d1df6583054999044fa3c1363b5f
-SHA256 (xemacs/xemacs-21.5.24.tar.gz) = 88e2a236c6d608d91fbf399f4a1a7823416cf2236d860c9d8b010f4e2cdd8b01
-SIZE (xemacs/xemacs-21.5.24.tar.gz) = 15103874
+MD5 (xemacs/xemacs-21.5.25.tar.gz) = 8ec2425c25a2642e465710f1c535fc51
+SHA256 (xemacs/xemacs-21.5.25.tar.gz) = aa77a4a3499abd47a10b4d24c5774dc473401705b9cc4de549969d98d2ac02f0
+SIZE (xemacs/xemacs-21.5.25.tar.gz) = 15109551
diff --git a/editors/xemacs-devel/files/patch-cmdloop.el b/editors/xemacs-devel/files/patch-cmdloop.el
deleted file mode 100644
index f14ddb4627f4..000000000000
--- a/editors/xemacs-devel/files/patch-cmdloop.el
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: cmdloop.el
-===================================================================
-RCS file: /pack/xemacscvs/XEmacs/xemacs/lisp/cmdloop.el,v
-retrieving revision 1.18
-retrieving revision 1.19
-diff -u -r1.18 -r1.19
---- lisp/cmdloop.el 2005/06/26 18:04:49 1.18
-+++ lisp/cmdloop.el 2006/01/08 20:00:43 1.19
-@@ -579,7 +579,8 @@
- (setq char (aref translated 0)))))
- (cond ((null char))
- ((not (characterp char))
-- (setq unread-command-events (list char)
-+ ;; XEmacs change; event instead of char.
-+ (setq unread-command-events (list event)
- done t))
- ; ((/= (logand char ?\M-\^@) 0)
- ; ;; Turn a meta-character into a character with the 0200 bit set.
-@@ -598,7 +599,8 @@
- ((and (not first) (eq char ?\C-m))
- (setq done t))
- ((not first)
-- (setq unread-command-events (list char)
-+ ;; XEmacs change; event instead of char.
-+ (setq unread-command-events (list event)
- done t))
- (t (setq code (char-to-int char)
- done t)))
diff --git a/editors/xemacs-devel/files/patch-diagnose.el b/editors/xemacs-devel/files/patch-diagnose.el
new file mode 100644
index 000000000000..7d792952c410
--- /dev/null
+++ b/editors/xemacs-devel/files/patch-diagnose.el
@@ -0,0 +1,17 @@
+Index: lisp/diagnose.el
+===================================================================
+RCS file: /pack/xemacscvs/XEmacs/xemacs/lisp/diagnose.el,v
+retrieving revision 1.7
+retrieving revision 1.8
+diff -u -r1.7 -r1.8
+--- lisp/diagnose.el 2005/11/25 01:41:46 1.7
++++ lisp/diagnose.el 2006/03/12 09:10:39 1.8
+@@ -142,7 +142,7 @@
+ (princ "\n")
+ (map-plist #'(lambda (stat num)
+ (when (string-match
+- "\\(.*\\)-storage\\$"
++ "\\(.*\\)-storage$"
+ (symbol-name stat))
+ (incf total num)
+ (princ (format fmt
diff --git a/editors/xemacs-devel/files/patch-dynarr.c b/editors/xemacs-devel/files/patch-dynarr.c
deleted file mode 100644
index 5957624348d6..000000000000
--- a/editors/xemacs-devel/files/patch-dynarr.c
+++ /dev/null
@@ -1,57 +0,0 @@
-Index: src/dynarr.c
-===================================================================
-RCS file: /pack/xemacscvs/XEmacs/xemacs/src/dynarr.c,v
-retrieving revision 1.13
-retrieving revision 1.14
-diff -u -r1.13 -r1.14
---- src/dynarr.c 2005/11/25 01:41:59 1.13
-+++ src/dynarr.c 2006/01/20 17:59:50 1.14
-@@ -129,16 +129,17 @@
- static int Dynarr_min_size = 8;
-
- static void
--Dynarr_realloc (Dynarr *dy, Bytecount new_size)
-+Dynarr_realloc (Dynarr *dy, int new_size)
- {
- if (DUMPEDP (dy->base))
- {
- void *new_base = malloc (new_size);
-- memcpy (new_base, dy->base, dy->max > new_size ? dy->max : new_size);
-+ memcpy (new_base, dy->base,
-+ (dy->max < new_size ? dy->max : new_size) * dy->elsize);
- dy->base = new_base;
- }
- else
-- dy->base = xrealloc (dy->base, new_size);
-+ dy->base = xrealloc (dy->base, new_size * dy->elsize);
- }
-
- void *
-@@ -158,13 +159,13 @@
- Dynarr);
-
- static void
--Dynarr_lisp_realloc (Dynarr *dy, Elemcount new_size)
-+Dynarr_lisp_realloc (Dynarr *dy, int new_size)
- {
- void *new_base = alloc_lrecord_array (dy->elsize, new_size, dy->lisp_imp);
- void *old_base = dy->base;
- if (dy->base)
- memcpy (new_base, dy->base,
-- (dy->max > new_size ? dy->max : new_size) * dy->elsize);
-+ (dy->max < new_size ? dy->max : new_size) * dy->elsize);
- dy->base = new_base;
- if (old_base)
- mc_free (old_base);
-@@ -205,9 +206,9 @@
- if (dy->lisp_imp)
- Dynarr_lisp_realloc (dy, newsize);
- else
-- Dynarr_realloc (dy, newsize*dy->elsize);
-+ Dynarr_realloc (dy, newsize);
- #else /* not NEW_GC */
-- Dynarr_realloc (dy, newsize*dy->elsize);
-+ Dynarr_realloc (dy, newsize);
- #endif /* not NEW_GC */
- dy->max = newsize;
- }
diff --git a/editors/xemacs-devel/files/patch-objects-gtk.c b/editors/xemacs-devel/files/patch-objects-gtk.c
deleted file mode 100644
index ed9b96938bc4..000000000000
--- a/editors/xemacs-devel/files/patch-objects-gtk.c
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: src/objects-gtk.c
-===================================================================
-RCS file: /pack/xemacscvs/XEmacs/xemacs/src/objects-gtk.c,v
-retrieving revision 1.16
-retrieving revision 1.17
-diff -u -r1.16 -r1.17
---- src/objects-gtk.c 2005/01/28 02:58:51 1.16
-+++ src/objects-gtk.c 2005/12/24 17:33:34 1.17
-@@ -485,8 +485,7 @@
- /* X Specific stuff */
- #include <X11/Xatom.h>
-
--/* Unbounded, for sufficiently small values of infinity... */
--#define MAX_FONT_COUNT 5000
-+#define MAX_FONT_COUNT INT_MAX
-
- #ifdef MULE
- /* find a font spec that matches font spec FONT and also matches
-@@ -536,9 +535,6 @@
- return result;
- }
- #endif /* MULE */
--
--/* Unbounded, for sufficiently small values of infinity... */
--#define MAX_FONT_COUNT 5000
-
- static int
- valid_font_name_p (Display *dpy, char *name)
diff --git a/editors/xemacs-devel/files/patch-objects-x.c b/editors/xemacs-devel/files/patch-objects-x.c
deleted file mode 100644
index 25e5b3b4acd3..000000000000
--- a/editors/xemacs-devel/files/patch-objects-x.c
+++ /dev/null
@@ -1,49 +0,0 @@
-Index: src/objects-x.c
-===================================================================
-RCS file: /pack/xemacscvs/XEmacs/xemacs/src/objects-x.c,v
-retrieving revision 1.30
-retrieving revision 1.36
-diff -u -r1.30 -r1.36
---- src/objects-x.c 2005/11/26 18:25:03 1.30
-+++ src/objects-x.c 2006/01/20 17:50:46 1.36
-@@ -693,8 +693,9 @@
- return result;
- }
-
--/* Unbounded, for sufficiently small values of infinity... */
--#define MAX_FONT_COUNT 5000
-+/* XListFonts doesn't allocate memory unconditionally based on this. (For
-+ XFree86 in 2005, at least. */
-+#define MAX_FONT_COUNT INT_MAX
-
- static Extbyte *
- truename_via_XListFonts (Display *dpy, Extbyte *font_name)
-@@ -807,7 +808,8 @@
- FcChar8 *res = FcNameUnparse (FONT_INSTANCE_X_XFTFONT (f)->pattern);
- if (res)
- {
-- FONT_INSTANCE_TRUENAME (f) = make_string (res, strlen (res));
-+ FONT_INSTANCE_TRUENAME (f) =
-+ build_ext_string (res, Qxft_font_name_encoding);
- free (res);
- return FONT_INSTANCE_TRUENAME (f);
- }
-@@ -1175,7 +1177,7 @@
- Extbyte **names;
- int count = 0;
- const Extbyte *patternext;
-- Lisp_Object result = Qunbound;
-+ Lisp_Object result = Qnil;
- int i;
-
- /* #### with Xft need to handle second stage here -- sjt
-@@ -1441,7 +1443,8 @@
- if (x_font_spec_matches_charset (XDEVICE (device), charset,
- intname, Qnil, 0, -1, 0))
- {
-- result = make_string (intname, intlen);
-+ result = build_ext_string ((const Extbyte *) intname,
-+ Qx_font_name_encoding);
- break;
- }
- }
diff --git a/editors/xemacs-devel/files/patch-profile.h b/editors/xemacs-devel/files/patch-profile.h
new file mode 100644
index 000000000000..da53be335d54
--- /dev/null
+++ b/editors/xemacs-devel/files/patch-profile.h
@@ -0,0 +1,16 @@
+Index: src/profile.h
+===================================================================
+RCS file: /pack/xemacscvs/XEmacs/xemacs/src/profile.h,v
+retrieving revision 1.3
+retrieving revision 1.4
+diff -u -r1.3 -r1.4
+--- src/profile.h 2005/10/25 11:16:27 1.3
++++ src/profile.h 2006/03/14 19:31:43 1.4
+@@ -113,6 +113,7 @@
+ RETURN_EXIT_PROFILING (tag, Lisp_Object, expr)
+
+ #define RETURN_UNGCPRO_EXIT_PROFILING(tag, expr) \
++do \
+ { \
+ Lisp_Object ret_ungc_val = (expr); \
+ UNGCPRO; \
diff --git a/editors/xemacs-devel/files/patch-syntax.c b/editors/xemacs-devel/files/patch-syntax.c
deleted file mode 100644
index 03b48561efbd..000000000000
--- a/editors/xemacs-devel/files/patch-syntax.c
+++ /dev/null
@@ -1,37 +0,0 @@
-Index: syntax.c
-===================================================================
-RCS file: /pack/xemacscvs/XEmacs/xemacs/src/syntax.c,v
-retrieving revision 1.25
-retrieving revision 1.26
-diff -u -r1.25 -r1.26
---- src/syntax.c 2005/11/25 01:42:06 1.25
-+++ src/syntax.c 2005/12/18 22:55:52 1.26
-@@ -613,7 +613,7 @@
- {
- *multi_p_out = 1;
- /* !!#### get this right */
-- return Spunct;
-+ return Sword;
- }
-
- #endif
-@@ -2296,8 +2296,8 @@
- if (!EQ (table, Vstandard_syntax_table) && !NILP (Vstandard_syntax_table))
- map_char_table (Vstandard_syntax_table, &range,
- copy_if_not_already_present, LISP_TO_VOID (mirrortab));
-- /* The resetting made the default be Qnil. Put it back to Spunct. */
-- set_char_table_default (mirrortab, make_int (Spunct));
-+ /* The resetting made the default be Qnil. Put it back to Sword. */
-+ set_char_table_default (mirrortab, make_int (Sword));
- XCHAR_TABLE (mirrortab)->dirty = 0;
- }
-
-@@ -2419,7 +2419,7 @@
- Smax);
- staticpro (&Vsyntax_designator_chars_string);
-
-- set_char_table_default (Vstandard_syntax_table, make_int (Spunct));
-+ set_char_table_default (Vstandard_syntax_table, make_int (Sword));
-
- for (i = 0; i <= 32; i++) /* Control 0 plus SPACE */
- Fput_char_table (make_char (i), make_int (Swhitespace),
diff --git a/editors/xemacs-devel/files/patch-x-win-xfree86.el b/editors/xemacs-devel/files/patch-x-win-xfree86.el
deleted file mode 100644
index 9c40cdd7e33d..000000000000
--- a/editors/xemacs-devel/files/patch-x-win-xfree86.el
+++ /dev/null
@@ -1,46 +0,0 @@
-Index: lisp/x-win-xfree86.el
-===================================================================
-RCS file: /pack/xemacscvs/XEmacs/xemacs/lisp/x-win-xfree86.el,v
-retrieving revision 1.5
-retrieving revision 1.6
-diff -u -r1.5 -r1.6
---- lisp/x-win-xfree86.el 2001/05/04 22:42:19 1.5
-+++ lisp/x-win-xfree86.el 2005/12/24 19:53:53 1.6
-@@ -46,6 +46,37 @@
-
- ;;;###autoload
- (defun x-win-init-xfree86 ()
-+
-+ ;; We know this keyboard is an XFree86 keyboard. As such, we can predict
-+ ;; what key scan codes will correspond to the keys on US keyboard layout,
-+ ;; and we can use that information to fall back to the US layout when
-+ ;; looking up commands that would otherwise fail. (Cf. the hard-coding of
-+ ;; this information in /usr/X11R6/lib/X11/xkb/keycodes/xfree86 )
-+ ;;
-+ ;; These settings for x-us-keymap-first-keycode and
-+ ;; x-us-keymap-description were determined with
-+ ;;
-+ ;; setxkbmap us
-+ ;; xmodmap -pke > keyboard-description.txt
-+ ;;
-+ ;; "8" is the key code of the first line, x-us-keymap-description is
-+ ;; taken from the column describing the bindings.
-+
-+ (setq x-us-keymap-first-keycode 8
-+ x-us-keymap-description
-+ [nil nil [?1 ?!] [?2 ?@] [?3 ?\#] [?4 ?$] [?5 ?%] [?6 ?^] [?7 ?&]
-+ [?8 ?*] [?9 ?\(] [?0 ?\)] [?- ?_] [?= ?+] nil ?\t [?q ?Q]
-+ [?w ?W] [?e ?E] [?r ?R] [?t ?T] [?y ?Y] [?u ?U] [?i ?I] [?o ?O]
-+ [?p ?P] [?\[ ?{] [?\] ?}] nil nil [?a ?A] [?s ?S] [?d ?D]
-+ [?f ?F] [?g ?G] [?h ?H] [?j ?J] [?k ?K] [?l ?L] [?\; ?:]
-+ [?\' ?\"] [?\` ?~] nil [?\\ ?|] [?z ?Z] [?x ?X] [?c ?C]
-+ [?v ?V] [?b ?B] [?n ?N] [?m ?M] [?\, ?<] [?\. ?>] [?/ ?\?]
-+ nil ?* nil ?\ nil nil nil nil nil nil nil nil nil nil nil
-+ nil nil ?7 ?8 ?9 ?- ?4 ?5 ?6 ?+ ?1 ?2 ?3 ?0 ?\. nil nil
-+ [?< ?>] nil nil nil nil nil nil nil nil nil nil nil nil
-+ nil nil nil nil nil ?/ nil nil nil nil nil nil nil nil
-+ nil nil nil nil nil ?=])
-+
- (loop for (key sane-key) in
- '((f13 f1)
- (f14 f2)
diff --git a/editors/xemacs-devel/files/patch-xgccache.c b/editors/xemacs-devel/files/patch-xgccache.c
deleted file mode 100644
index bc0d7dbef59e..000000000000
--- a/editors/xemacs-devel/files/patch-xgccache.c
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: src/xgccache.c
-===================================================================
-RCS file: /pack/xemacscvs/XEmacs/xemacs/src/xgccache.c,v
-retrieving revision 1.13
-diff -u -r1.13 xgccache.c
---- src/xgccache.c 2005/11/26 11:46:11 1.13
-+++ src/xgccache.c 2006/02/16 20:18:18
-@@ -233,7 +233,9 @@
- cache->head = cell->next;
- cache->head->prev = 0;
- if (cache->tail == cell) cache->tail = 0; /* only one */
-+#if 0
- debug_out ("Cache full, freeing GC: %08lx\n ", XE_GCONTEXT(cell));
-+#endif
- XFreeGC (cache->dpy, cell->gc);
- cache->delete_count++;
- #ifdef GCCACHE_HASH
diff --git a/editors/xemacs-devel/files/patch-xlwmenu.c b/editors/xemacs-devel/files/patch-xlwmenu.c
deleted file mode 100644
index ee91eba795b5..000000000000
--- a/editors/xemacs-devel/files/patch-xlwmenu.c
+++ /dev/null
@@ -1,18 +0,0 @@
-Index: lwlib/xlwmenu.c
-===================================================================
-RCS file: /pack/xemacscvs/XEmacs/xemacs/lwlib/xlwmenu.c,v
-retrieving revision 1.38
-diff -u -r1.38 xlwmenu.c
---- lwlib/xlwmenu.c 2005/11/26 11:45:59 1.38
-+++ lwlib/xlwmenu.c 2005/12/20 13:04:56
-@@ -2828,8 +2828,9 @@
- XColor xcolor;
- Visual *visual;
- int ignore;
-+ Colormap cmap;
- visual_info_from_widget ((Widget) mw, &visual, &ignore);
-- Colormap cmap = mw->core.colormap;
-+ cmap = mw->core.colormap;
- xcolor.pixel = mw->core.background_pixel;
- XQueryColor (dpy, cmap, &xcolor);
- xcolor.red = (xcolor.red * 17) / 20;