aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs
diff options
context:
space:
mode:
authorGary Jennejohn <gj@FreeBSD.org>2000-02-18 01:59:03 +0000
committerGary Jennejohn <gj@FreeBSD.org>2000-02-18 01:59:03 +0000
commit127577ee3980284180dec449e709cebcf566ec34 (patch)
treecf307deb45d1c7bd3a0868c2a4bcedc4d94ff0d7 /editors/xemacs
parent77116ce79ea1eaa5483bb5c33389552fd68c56b9 (diff)
downloadports-127577ee3980284180dec449e709cebcf566ec34.tar.gz
ports-127577ee3980284180dec449e709cebcf566ec34.zip
I added logic to the Makefile to make it easier for me test when
PREFIX != LOCALBASE. Unfortunately, the change is guaranteed to break pacakging on bento. Revert to the old way of doing things. Why does this sort of thing always have to happen at 3 AM ?
Notes
Notes: svn path=/head/; revision=25951
Diffstat (limited to 'editors/xemacs')
-rw-r--r--editors/xemacs/Makefile18
1 files changed, 2 insertions, 16 deletions
diff --git a/editors/xemacs/Makefile b/editors/xemacs/Makefile
index 2f7f452a9ed7..2e899fbe35e4 100644
--- a/editors/xemacs/Makefile
+++ b/editors/xemacs/Makefile
@@ -37,8 +37,8 @@ CONFIGURE_ARGS?=${XEMACS_ARCH} --prefix=${PREFIX} \
--with-clash-detection \
--lockdir=/var/run/emacs/lock \
--with-sound=native \
- --site-includes=${SITE_INCLUDES} \
- --site-libraries=${SITE_LIBRARIES} \
+ --site-includes=${PREFIX}/include \
+ --site-libraries=${PREFIX}/lib \
--with-session=yes \
--with-png=yes \
--with-tiff=yes \
@@ -98,17 +98,3 @@ post-install::
.endif
.include <bsd.port.mk>
-
-# this makes it easier to test using PREFIX != LOCALBASE. Do not do
-# this on bento. This has to go here because PREFIX and LOCALBASE are
-# normally defined in bsd.port.mk.
-
-.if !defined(PACKAGE_BUILDING)
-.if ${PREFIX} == ${LOCALBASE}
-SITE_INCLUDES= ${PREFIX}/include
-SITE_LIBRARIES= ${PREFIX}/lib
-.else
-SITE_INCLUDES= "${PREFIX}/include ${LOCALBASE}/include"
-SITE_LIBRARIES= "${PREFIX}/lib ${LOCALBASE}/lib"
-.endif
-.endif