aboutsummaryrefslogtreecommitdiff
path: root/editors/xmleditor/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /editors/xmleditor/Makefile
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'editors/xmleditor/Makefile')
-rw-r--r--editors/xmleditor/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/editors/xmleditor/Makefile b/editors/xmleditor/Makefile
index 8361f6e2c5f7..125b9e4f0ed5 100644
--- a/editors/xmleditor/Makefile
+++ b/editors/xmleditor/Makefile
@@ -21,8 +21,8 @@ USE_BISON= build
USE_GNOME= gnomehack libglade
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
USE_LDCONFIG= yes