aboutsummaryrefslogtreecommitdiff
path: root/editors/xvile
diff options
context:
space:
mode:
authorGary Jennejohn <gj@FreeBSD.org>2002-08-27 09:18:36 +0000
committerGary Jennejohn <gj@FreeBSD.org>2002-08-27 09:18:36 +0000
commit59ef216bedc2fa51562aff93b09a6d415eaab89b (patch)
treef771ab18fe9da47e1f5773c002e18d69a0dcc247 /editors/xvile
parentbd780d235833dcc25c91cc309751e0aa475d2b14 (diff)
downloadports-59ef216bedc2fa51562aff93b09a6d415eaab89b.tar.gz
ports-59ef216bedc2fa51562aff93b09a6d415eaab89b.zip
Add patch-file.c to fix an error in checking the return value from
mkdtemp. Bump PORTREVISION to reflect the fix.
Notes
Notes: svn path=/head/; revision=65088
Diffstat (limited to 'editors/xvile')
-rw-r--r--editors/xvile/Makefile1
-rw-r--r--editors/xvile/files/patch-file.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/editors/xvile/Makefile b/editors/xvile/Makefile
index 7f7ba614c0b8..d8357c6dcb1b 100644
--- a/editors/xvile/Makefile
+++ b/editors/xvile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xvile
PORTVERSION= 9.3c
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ftp://ftp.phred.org/pub/vile/ \
ftp://dickey.his.com/vile/
diff --git a/editors/xvile/files/patch-file.c b/editors/xvile/files/patch-file.c
new file mode 100644
index 000000000000..ba624d2b6137
--- /dev/null
+++ b/editors/xvile/files/patch-file.c
@@ -0,0 +1,11 @@
+--- file.c.orig Tue Aug 27 10:14:57 2002
++++ file.c Tue Aug 27 10:15:35 2002
+@@ -2351,7 +2351,7 @@
+
+ /* on failure, keep going */
+ #if defined(HAVE_MKSTEMP) && defined(HAVE_MKDTEMP)
+- result = (vl_mkdtemp(dirnam) == 0);
++ result = (vl_mkdtemp(dirnam) != 0);
+ #else
+ result = (vl_mkdir(dirnam, 0700) == 0);
+ #endif