aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-13 06:28:28 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-13 06:28:28 +0000
commit92f36fc209c41991a684bf67009aff536228a929 (patch)
treee6eb2a4b7d993ee99c264046cb35e0d7f6d4693f /editors
parent9399d8de62e7ffcdc86a621cd8b05806d7ebeb19 (diff)
downloadports-92f36fc209c41991a684bf67009aff536228a929.tar.gz
ports-92f36fc209c41991a684bf67009aff536228a929.zip
Fix build on 4.x
PR: ports/68965 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=113526
Diffstat (limited to 'editors')
-rw-r--r--editors/2bsd-vi/Makefile3
-rw-r--r--editors/2bsd-vi/files/patch-mapalloc.c17
-rw-r--r--editors/2bsd-vi/files/stable-Makefile.patch15
3 files changed, 34 insertions, 1 deletions
diff --git a/editors/2bsd-vi/Makefile b/editors/2bsd-vi/Makefile
index 6a888d7bad28..bd1ef39da03c 100644
--- a/editors/2bsd-vi/Makefile
+++ b/editors/2bsd-vi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vi
PORTVERSION= 040605
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ex-vi/
@@ -22,7 +23,7 @@ MLINKS= ex.1 edit.1 vi.1 vedit.1 vi.1 view.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= Requires FreeBSD-5.0 or newer
+EXTRA_PATCHES+= ${FILESDIR}/stable-Makefile.patch
.endif
.include <bsd.port.post.mk>
diff --git a/editors/2bsd-vi/files/patch-mapalloc.c b/editors/2bsd-vi/files/patch-mapalloc.c
new file mode 100644
index 000000000000..0d8513eb31af
--- /dev/null
+++ b/editors/2bsd-vi/files/patch-mapalloc.c
@@ -0,0 +1,17 @@
+--- /tmp/mapmalloc.c Mon Jul 12 16:28:16 2004
++++ mapmalloc.c Mon Jul 12 16:28:37 2004
+@@ -550,14 +550,6 @@
+ return NULL;
+ }
+
+-/*ARGSUSED*/
+-char *
+-valloc(size)
+-size_t size;
+-{
+- return NULL;
+-}
+-
+ char *
+ mallinfo()
+ {
diff --git a/editors/2bsd-vi/files/stable-Makefile.patch b/editors/2bsd-vi/files/stable-Makefile.patch
new file mode 100644
index 000000000000..f333e21c5829
--- /dev/null
+++ b/editors/2bsd-vi/files/stable-Makefile.patch
@@ -0,0 +1,15 @@
+--- /tmp/Makefile Mon Jul 12 16:26:36 2004
++++ Makefile Mon Jul 12 16:26:48 2004
+@@ -144,9 +144,9 @@
+ # advanced multibyte character support etc. which might not be present
+ # on your system.
+ #
+-REINC = -I./libuxre -DUXRE
+-RELIB = -L./libuxre -luxre
+-RETGT = uxre
++#REINC = -I./libuxre -DUXRE
++#RELIB = -L./libuxre -luxre
++#RETGT = uxre
+
+ #
+ # These settings should be correct for any modern Unix.