aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-01 07:39:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-12-01 07:39:02 +0000
commitd750615763ee2d3250de2115295079f66d813d1f (patch)
tree05b94e79be3ac272b9b617e50fc723ea52c6cf34 /editors
parent767bcfc72cf9c3574739d745cff6620fa75b0e74 (diff)
downloadports-d750615763ee2d3250de2115295079f66d813d1f.tar.gz
ports-d750615763ee2d3250de2115295079f66d813d1f.zip
- Use features of bsd.wx.mk, especially USE_WX
PR: ports/101613 Submitted by: alepulver
Notes
Notes: svn path=/head/; revision=178433
Diffstat (limited to 'editors')
-rw-r--r--editors/poedit/Makefile6
-rw-r--r--editors/spe/Makefile10
2 files changed, 6 insertions, 10 deletions
diff --git a/editors/poedit/Makefile b/editors/poedit/Makefile
index e7b388016cc3..96469760adcb 100644
--- a/editors/poedit/Makefile
+++ b/editors/poedit/Makefile
@@ -17,14 +17,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Gettext catalogs (.po files) editor
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell \
- wx_gtk2u_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26-unicode
+LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnometarget pkgconfig
USE_BDB= yes
WITH_BDB_HIGHEST= yes
+USE_WX= 2.6
+WX_CONF_ARGS= absolute
+WX_UNICODE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
diff --git a/editors/spe/Makefile b/editors/spe/Makefile
index 2c4432dde7f9..04bd7b0fc4a7 100644
--- a/editors/spe/Makefile
+++ b/editors/spe/Makefile
@@ -15,10 +15,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-wx2.6.1.0
MAINTAINER= nivit@email.it
COMMENT= Stani's Python Editor
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/${WX_PYTHON_DIR}/wxPython/_wx.py:${PORTSDIR}/x11-toolkits/py-wxPython26
-
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+USE_WX= 2.6
+WX_COMPS= python
OPTIONS= ENCRYPTED_DEBUG "Enable encrypted debug in SPE" off
@@ -45,12 +45,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if defined(WITH_UNICODE) && (${OSVERSION} > 500000)
-WX_PYTHON_DIR= wx-2.6-gtk2-unicode
-.else
-WX_PYTHON_DIR= wx-2.6-gtk2-ansi
-.endif
-
.if defined(WITH_ENCRYPTED_DEBUG)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
.endif