aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-06-05 20:05:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-06-05 20:05:46 +0000
commitb866cd829a1fa30ca8ab0db5f2bd5daa79c8b804 (patch)
tree7b6a0c6a8ac25b7be887d1d9a747347aa12249af /editors
parentf49a9118be508ff1e62e9c5f397d6d0985d0b86c (diff)
downloadports-b866cd829a1fa30ca8ab0db5f2bd5daa79c8b804.tar.gz
ports-b866cd829a1fa30ca8ab0db5f2bd5daa79c8b804.zip
- Support for SOUND even when X11 support is disabled.
- Disables gettext support with the help of WITHOUT_NLS knob. - LICENSE. PR: 147087 Submitted by: Ashish SHUKLA <wahjava@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=255830
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs/Makefile18
-rw-r--r--editors/emacs23/Makefile18
2 files changed, 22 insertions, 14 deletions
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index 44ae4bb2f158..424d34d3d9e5 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
@@ -29,7 +29,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
+LICENSE= GPLv3
MAN1= b2m.1 ctags.1 ebrowse.1 emacs.1 emacsclient.1 etags.1 \
grep-changelog.1 rcs-checkin.1
@@ -111,10 +111,6 @@ CONFIGURE_ARGS+= --with-x-toolkit=gtk
CONFIGURE_ARGS+= --without-toolkit-scroll-bars
.endif
-.if defined(WITHOUT_SOUND)
-CONFIGURE_ARGS+= --without-sound
-.endif
-
.if defined(WITHOUT_SYNC_INPUT)
CONFIGURE_ARGS+= --without-sync-input
.endif
@@ -192,6 +188,10 @@ CONFIGURE_ARGS+= --without-xim
.endif
+.if defined(WITHOUT_SOUND)
+CONFIGURE_ARGS+= --without-sound
+.endif
+
.if defined(WITHOUT_DBUS)
CONFIGURE_ARGS+= --without-dbus
.else
@@ -203,6 +203,10 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+.endif
+
.if defined(WITHOUT_SOURCES)
PLIST_SUB+= SOURCES="@comment "
.else
@@ -214,7 +218,7 @@ BROKEN= Emacs 23.X does not currently build on ia64
.endif
.if ${OSVERSION} < 700000 && defined(WITHOUT_X11) && defined(WITH_DBUS)
-BROKEN= Does not currently build with dbus support but without X11
+BROKEN= Does not currently build with dbus support but without X11
.endif
post-patch:
diff --git a/editors/emacs23/Makefile b/editors/emacs23/Makefile
index 44ae4bb2f158..424d34d3d9e5 100644
--- a/editors/emacs23/Makefile
+++ b/editors/emacs23/Makefile
@@ -7,7 +7,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
@@ -29,7 +29,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
+LICENSE= GPLv3
MAN1= b2m.1 ctags.1 ebrowse.1 emacs.1 emacsclient.1 etags.1 \
grep-changelog.1 rcs-checkin.1
@@ -111,10 +111,6 @@ CONFIGURE_ARGS+= --with-x-toolkit=gtk
CONFIGURE_ARGS+= --without-toolkit-scroll-bars
.endif
-.if defined(WITHOUT_SOUND)
-CONFIGURE_ARGS+= --without-sound
-.endif
-
.if defined(WITHOUT_SYNC_INPUT)
CONFIGURE_ARGS+= --without-sync-input
.endif
@@ -192,6 +188,10 @@ CONFIGURE_ARGS+= --without-xim
.endif
+.if defined(WITHOUT_SOUND)
+CONFIGURE_ARGS+= --without-sound
+.endif
+
.if defined(WITHOUT_DBUS)
CONFIGURE_ARGS+= --without-dbus
.else
@@ -203,6 +203,10 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+.endif
+
.if defined(WITHOUT_SOURCES)
PLIST_SUB+= SOURCES="@comment "
.else
@@ -214,7 +218,7 @@ BROKEN= Emacs 23.X does not currently build on ia64
.endif
.if ${OSVERSION} < 700000 && defined(WITHOUT_X11) && defined(WITH_DBUS)
-BROKEN= Does not currently build with dbus support but without X11
+BROKEN= Does not currently build with dbus support but without X11
.endif
post-patch: