aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMahdi Mokhtari <mmokhi@FreeBSD.org>2018-03-10 20:10:46 +0000
committerMahdi Mokhtari <mmokhi@FreeBSD.org>2018-03-10 20:10:46 +0000
commit25eb3f7b0ea0700ab251a209768d7fd02248c18b (patch)
treef13d87156426b52742f5a97ff24ca99405ff5144 /editors
parent78fa2cca520547ea8a0455d6ddb5152f2de8f18e (diff)
downloadports-25eb3f7b0ea0700ab251a209768d7fd02248c18b.tar.gz
ports-25eb3f7b0ea0700ab251a209768d7fd02248c18b.zip
editors/codelite: Add support for Clang(s) of llvm40, llvm50, and llvm60
PR: 226496 Reported by: O. Hartmann <ohartmann@walstatt.org> Sponsored by: Netzkommune GmbH
Notes
Notes: svn path=/head/; revision=464088
Diffstat (limited to 'editors')
-rw-r--r--editors/codelite/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index f43e1a448484..07e7bc88379f 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -3,6 +3,7 @@
PORTNAME= codelite
PORTVERSION= 11.0
+PORTREVISION= 1
CATEGORIES= editors devel
MAINTAINER= mmokhi@FreeBSD.org
@@ -44,10 +45,10 @@ SFTP_USES= localbase
CLANG_DESC= Clang code-completion
-.for v in 34 35 36 37 38 39
+.for v in 34 35 36 37 38 39 40 50 60
OPTIONS_RADIO_CLANG+= CLANG$v
CLANG$v_DESC= Clang ${v:C/(.)(.)/\1.\2.x/}
-.if $v == 39
+.if $v >= 39
CLANG$v_BUILD_DEPENDS= llvm$v>0:devel/llvm$v
CLANG$v_RUN_DEPENDS= llvm$v>0:devel/llvm$v
.else