aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorBrad Davis <brd@FreeBSD.org>2018-03-25 21:48:32 +0000
committerBrad Davis <brd@FreeBSD.org>2018-03-25 21:48:32 +0000
commit2912095c181608bdfe36fcb46484048442c5b144 (patch)
treeb0fc7deb9b188ae45b5edeff72f90392e8b7e426 /editors
parent1f5755641b7a2a59af91753c2313af2441393a05 (diff)
downloadports-2912095c181608bdfe36fcb46484048442c5b144.tar.gz
ports-2912095c181608bdfe36fcb46484048442c5b144.zip
Fix build on ppc64 by specifying what is needed from the compiler.
PR: 225635 Submitted by: jhibbits Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=465547
Diffstat (limited to 'editors')
-rw-r--r--editors/gedit-plugins/Makefile3
-rw-r--r--editors/gedit/Makefile5
-rw-r--r--editors/pluma/Makefile2
3 files changed, 6 insertions, 4 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index 5a593b6f120e..35acb1522082 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -20,8 +20,9 @@ RUN_DEPENDS= gedit>=0:editors/gedit
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome libtool pathfix pkgconfig \
+USES= compiler:c11 gettext gmake gnome libtool pathfix pkgconfig \
python:3.4+ tar:xz
+USE_CSTD= c11
USE_GNOME= gtk30 gtksourceview3 intlhack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 71b4a3311e9b..6d9dd7b25654 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -28,8 +28,9 @@ RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake gnome libtool localbase \
- pathfix pkgconfig python:3.2+ shebangfix tar:xz
+USES= compiler:c11 desktop-file-utils gettext gmake gnome libtool \
+ localbase pathfix pkgconfig python:3.2+ shebangfix tar:xz
+USE_CSTD= c11
USE_GNOME= cairo gdkpixbuf2 gtksourceview3 intlhack introspection \
libxml2 pygobject3
SHEBANG_FILES= plugins/externaltools/data/send-to-fpaste.tool.in
diff --git a/editors/pluma/Makefile b/editors/pluma/Makefile
index c3bc3da20d68..3cae9bdc9c95 100644
--- a/editors/pluma/Makefile
+++ b/editors/pluma/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gmake libtool localbase \
+USES= compiler:c11 desktop-file-utils gmake libtool localbase \
pathfix pkgconfig python:3.3+ shebangfix tar:xz
USE_XORG= ice sm x11
USE_GNOME= cairo gdkpixbuf2 gnomeprefix gtk30 gtksourceview3 \