aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2002-11-17 21:19:57 +0000
committerAlan Eldridge <alane@FreeBSD.org>2002-11-17 21:19:57 +0000
commit795b816cf1ea3c6752772a34603487af76f3d9a1 (patch)
tree9c17710923fb182f26310a2042a7386dd3a67538 /editors
parent8df466abc657aeb7da0568846b648a4ee5844075 (diff)
downloadports-795b816cf1ea3c6752772a34603487af76f3d9a1.tar.gz
ports-795b816cf1ea3c6752772a34603487af76f3d9a1.zip
add leo because addport barfed on itself
Notes
Notes: svn path=/head/; revision=70322
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/leo/Makefile53
-rw-r--r--editors/leo/distinfo1
-rw-r--r--editors/leo/files/leo.in12
-rw-r--r--editors/leo/pkg-comment1
-rw-r--r--editors/leo/pkg-descr6
6 files changed, 74 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index b3e1d7e0a49c..d75eae471ff7 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -78,6 +78,7 @@
SUBDIR += led
SUBDIR += leim20
SUBDIR += leim21
+ SUBDIR += leo
SUBDIR += lfhex
SUBDIR += lpe
SUBDIR += manedit
diff --git a/editors/leo/Makefile b/editors/leo/Makefile
new file mode 100644
index 000000000000..5eb29e3117ea
--- /dev/null
+++ b/editors/leo/Makefile
@@ -0,0 +1,53 @@
+# ex:ts=8
+#
+# New ports collection makefile for: leo
+# Date created: 2002/11/17
+# Whom: Alan Eldridge <ports@geeksrus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= leo
+PORTVERSION= 3.8
+PORTEPOCH= 0
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alane@freebsd.org
+
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
+USE_ZIP= yes
+USE_PYTHON= yes
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+PLIST=${WRKDIR}/plist
+INSTALL_DIR=${LOCALBASE}/share
+
+CPIO?= /usr/bin/cpio
+SORT?= /usr/bin/sort
+
+do-install:
+ cd ${WRKDIR}; ${FIND} ${DISTNAME} \
+ | ${CPIO} -pdmv -R ${LIBOWN}:${LIBGRP} ${INSTALL_DIR}
+ cd ${LOCALBASE}; ${FIND} share/${DISTNAME} -type f \
+ | ${XARGS} ${CHMOD} ${LIBMODE}
+ cd ${LOCALBASE}; ${FIND} share/${DISTNAME} -type d \
+ | ${XARGS} ${CHMOD} ${BINMODE}
+ ${SED} -e 's|@DISTNAME@|${DISTNAME}|' \
+ -e 's|@LOCALBASE@|${LOCALBASE}|'\
+ <${FILESDIR}/leo.in >${LOCALBASE}/bin/leo
+ ${CHMOD} ${BINMODE} ${LOCALBASE}/bin/leo
+ ${CHOWN} ${BINOWN}:${BINGRP} ${LOCALBASE}/bin/leo
+ ${ECHO_CMD} "bin/leo" >${PLIST}
+ cd ${LOCALBASE}; ${FIND} share/${DISTNAME} -type f \
+ | ${SORT} >>${PLIST}
+ cd ${LOCALBASE}; ${FIND} share/${DISTNAME} -type d \
+ | ${SORT} -r | ${SED} -e 's|^|@dirrm |' >>${PLIST}
+
+.include <bsd.port.post.mk>
+
+#EOF
diff --git a/editors/leo/distinfo b/editors/leo/distinfo
new file mode 100644
index 000000000000..f73a2332d745
--- /dev/null
+++ b/editors/leo/distinfo
@@ -0,0 +1 @@
+MD5 (leo-3.8.zip) = e54e75266c1bc7541f682fbd7e72c39e
diff --git a/editors/leo/files/leo.in b/editors/leo/files/leo.in
new file mode 100644
index 000000000000..bccf53d98fd7
--- /dev/null
+++ b/editors/leo/files/leo.in
@@ -0,0 +1,12 @@
+#!/bin/sh
+# -*-shell-script-*-
+#
+# leo
+#
+# Copyright (c) 2002 Alan Eldridge.
+# All rights reserved. Licensed under BSD license.
+#
+# 2002/11/17 alane@freebsd.org
+#
+exec python @LOCALBASE@/share/@DISTNAME@/leo.py ${1:+"$@"}
+
diff --git a/editors/leo/pkg-comment b/editors/leo/pkg-comment
new file mode 100644
index 000000000000..416a904fe8bc
--- /dev/null
+++ b/editors/leo/pkg-comment
@@ -0,0 +1 @@
+An advanced outline editor
diff --git a/editors/leo/pkg-descr b/editors/leo/pkg-descr
new file mode 100644
index 000000000000..af8cce488d0c
--- /dev/null
+++ b/editors/leo/pkg-descr
@@ -0,0 +1,6 @@
+Leo is an advanced outlining editor for "literate programming" and many
+other uses.
+
+WWW: http://personalpages.tds.net/~edream/front.html
+
+-- AlanE <alane@freebsd.org>