aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1999-01-02 12:26:11 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1999-01-02 12:26:11 +0000
commit66f2af6f3be451a0f1058d4cd31fb83bdae81b2f (patch)
tree860ac424f20464cb80b0d47c15032307a2df7a7b /editors
parent50dddc1f292ebd448b693e56040aeaed4c3e2840 (diff)
downloadports-66f2af6f3be451a0f1058d4cd31fb83bdae81b2f.tar.gz
ports-66f2af6f3be451a0f1058d4cd31fb83bdae81b2f.zip
Lock file correction and reflect change in /etc/mtree/BSD.local.dist.
PR: ports/8289 (part of) Submitted by: Satoshi Taoka <taoka@infonets.hiroshima-u.ac.jp>
Notes
Notes: svn path=/head/; revision=15768
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs/Makefile9
-rw-r--r--editors/emacs/files/emacs.sh10
-rw-r--r--editors/emacs/pkg-plist6
-rw-r--r--editors/emacs19/Makefile9
-rw-r--r--editors/emacs19/files/emacs.sh10
-rw-r--r--editors/emacs19/pkg-plist6
-rw-r--r--editors/emacs22/Makefile9
-rw-r--r--editors/emacs22/files/emacs.sh10
-rw-r--r--editors/emacs22/pkg-plist6
-rw-r--r--editors/emacs23/Makefile9
-rw-r--r--editors/emacs23/files/emacs.sh10
-rw-r--r--editors/emacs23/pkg-plist6
12 files changed, 84 insertions, 16 deletions
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index 7a8d539e944c..9957ad38ce08 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.31 1998/04/04 07:36:40 asami Exp $
+# $Id: Makefile,v 1.32 1998/09/14 07:26:02 asami Exp $
#
DISTNAME= emacs-19.34b
@@ -18,7 +18,8 @@ NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/emacs-19.34
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --with-x-toolkit
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
+ --sharedstatedir=/var/run
STRIP=
MAN1= emacs.1 etags.1 ctags.1
@@ -32,5 +33,9 @@ post-install:
.for info in emacs vip viper forms gnus mh-e cl sc dired-x ediff ccmode message
install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
.endfor
+# install emacs.sh into ${PREFIX}/etc/rc.d
+ chmod 1777 /var/run/emacs/lock
+ @${MKDIR} ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${FILESDIR}/emacs.sh ${PREFIX}/etc/rc.d
.include <bsd.port.mk>
diff --git a/editors/emacs/files/emacs.sh b/editors/emacs/files/emacs.sh
new file mode 100644
index 000000000000..09baabfd255c
--- /dev/null
+++ b/editors/emacs/files/emacs.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+if [ -d /var/run/emacs/lock ]
+then
+ rm -f /var/run/emacs/lock/*
+else
+ mkdir -p /var/run/emacs/lock
+fi
+chmod 1777 /var/run/emacs/lock
+exit 0
+
diff --git a/editors/emacs/pkg-plist b/editors/emacs/pkg-plist
index 9bb26b6d7d61..64141be5d27d 100644
--- a/editors/emacs/pkg-plist
+++ b/editors/emacs/pkg-plist
@@ -8,9 +8,10 @@ bin/etags
bin/emacsclient
@exec if [ ! -d %d/share/emacs/site-lisp ]; then mkdir -p %D/share/emacs/site-lisp; fi
@exec if [ ! -d %d/share/emacs/%%EMACS_VERSION%%/site-lisp ]; then mkdir -p %D/share/emacs/%%EMACS_VERSION%%/site-lisp; fi
-@comment these two can fail if other ports are installed, no need to
+@exec mkdir -p /var/run/emacs/lock ; chmod 1777 /var/run/emacs/lock
+etc/rc.d/emacs.sh
+@comment This can fail if other ports are installed, no need to
@comment scare user in that case
-@unexec rmdir %D/share/emacs/site-lisp 2>/dev/null || true
@unexec rmdir %D/share/emacs/%%EMACS_VERSION%%/site-lisp 2>/dev/null || true
@unexec install-info --delete %D/info/emacs %D/info/dir
@unexec install-info --delete %D/info/vip %D/info/dir
@@ -125,6 +126,7 @@ libexec/emacs/%%EMACS_VERSION%%/i386--freebsd/vcdiff
libexec/emacs/%%EMACS_VERSION%%/i386--freebsd/yow
@dirrm libexec/emacs/%%EMACS_VERSION%%/i386--freebsd
@dirrm libexec/emacs/%%EMACS_VERSION%%
+@unexec rmdir %D/libexec/emacs 2>/dev/null || true
share/emacs/%%EMACS_VERSION%%/etc/3B-MAXMEM
share/emacs/%%EMACS_VERSION%%/etc/AIX.DUMP
share/emacs/%%EMACS_VERSION%%/etc/BABYL
diff --git a/editors/emacs19/Makefile b/editors/emacs19/Makefile
index 7a8d539e944c..9957ad38ce08 100644
--- a/editors/emacs19/Makefile
+++ b/editors/emacs19/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.31 1998/04/04 07:36:40 asami Exp $
+# $Id: Makefile,v 1.32 1998/09/14 07:26:02 asami Exp $
#
DISTNAME= emacs-19.34b
@@ -18,7 +18,8 @@ NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/emacs-19.34
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --with-x-toolkit
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
+ --sharedstatedir=/var/run
STRIP=
MAN1= emacs.1 etags.1 ctags.1
@@ -32,5 +33,9 @@ post-install:
.for info in emacs vip viper forms gnus mh-e cl sc dired-x ediff ccmode message
install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
.endfor
+# install emacs.sh into ${PREFIX}/etc/rc.d
+ chmod 1777 /var/run/emacs/lock
+ @${MKDIR} ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${FILESDIR}/emacs.sh ${PREFIX}/etc/rc.d
.include <bsd.port.mk>
diff --git a/editors/emacs19/files/emacs.sh b/editors/emacs19/files/emacs.sh
new file mode 100644
index 000000000000..09baabfd255c
--- /dev/null
+++ b/editors/emacs19/files/emacs.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+if [ -d /var/run/emacs/lock ]
+then
+ rm -f /var/run/emacs/lock/*
+else
+ mkdir -p /var/run/emacs/lock
+fi
+chmod 1777 /var/run/emacs/lock
+exit 0
+
diff --git a/editors/emacs19/pkg-plist b/editors/emacs19/pkg-plist
index 9bb26b6d7d61..64141be5d27d 100644
--- a/editors/emacs19/pkg-plist
+++ b/editors/emacs19/pkg-plist
@@ -8,9 +8,10 @@ bin/etags
bin/emacsclient
@exec if [ ! -d %d/share/emacs/site-lisp ]; then mkdir -p %D/share/emacs/site-lisp; fi
@exec if [ ! -d %d/share/emacs/%%EMACS_VERSION%%/site-lisp ]; then mkdir -p %D/share/emacs/%%EMACS_VERSION%%/site-lisp; fi
-@comment these two can fail if other ports are installed, no need to
+@exec mkdir -p /var/run/emacs/lock ; chmod 1777 /var/run/emacs/lock
+etc/rc.d/emacs.sh
+@comment This can fail if other ports are installed, no need to
@comment scare user in that case
-@unexec rmdir %D/share/emacs/site-lisp 2>/dev/null || true
@unexec rmdir %D/share/emacs/%%EMACS_VERSION%%/site-lisp 2>/dev/null || true
@unexec install-info --delete %D/info/emacs %D/info/dir
@unexec install-info --delete %D/info/vip %D/info/dir
@@ -125,6 +126,7 @@ libexec/emacs/%%EMACS_VERSION%%/i386--freebsd/vcdiff
libexec/emacs/%%EMACS_VERSION%%/i386--freebsd/yow
@dirrm libexec/emacs/%%EMACS_VERSION%%/i386--freebsd
@dirrm libexec/emacs/%%EMACS_VERSION%%
+@unexec rmdir %D/libexec/emacs 2>/dev/null || true
share/emacs/%%EMACS_VERSION%%/etc/3B-MAXMEM
share/emacs/%%EMACS_VERSION%%/etc/AIX.DUMP
share/emacs/%%EMACS_VERSION%%/etc/BABYL
diff --git a/editors/emacs22/Makefile b/editors/emacs22/Makefile
index 7a8d539e944c..9957ad38ce08 100644
--- a/editors/emacs22/Makefile
+++ b/editors/emacs22/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.31 1998/04/04 07:36:40 asami Exp $
+# $Id: Makefile,v 1.32 1998/09/14 07:26:02 asami Exp $
#
DISTNAME= emacs-19.34b
@@ -18,7 +18,8 @@ NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/emacs-19.34
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --with-x-toolkit
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
+ --sharedstatedir=/var/run
STRIP=
MAN1= emacs.1 etags.1 ctags.1
@@ -32,5 +33,9 @@ post-install:
.for info in emacs vip viper forms gnus mh-e cl sc dired-x ediff ccmode message
install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
.endfor
+# install emacs.sh into ${PREFIX}/etc/rc.d
+ chmod 1777 /var/run/emacs/lock
+ @${MKDIR} ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${FILESDIR}/emacs.sh ${PREFIX}/etc/rc.d
.include <bsd.port.mk>
diff --git a/editors/emacs22/files/emacs.sh b/editors/emacs22/files/emacs.sh
new file mode 100644
index 000000000000..09baabfd255c
--- /dev/null
+++ b/editors/emacs22/files/emacs.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+if [ -d /var/run/emacs/lock ]
+then
+ rm -f /var/run/emacs/lock/*
+else
+ mkdir -p /var/run/emacs/lock
+fi
+chmod 1777 /var/run/emacs/lock
+exit 0
+
diff --git a/editors/emacs22/pkg-plist b/editors/emacs22/pkg-plist
index 9bb26b6d7d61..64141be5d27d 100644
--- a/editors/emacs22/pkg-plist
+++ b/editors/emacs22/pkg-plist
@@ -8,9 +8,10 @@ bin/etags
bin/emacsclient
@exec if [ ! -d %d/share/emacs/site-lisp ]; then mkdir -p %D/share/emacs/site-lisp; fi
@exec if [ ! -d %d/share/emacs/%%EMACS_VERSION%%/site-lisp ]; then mkdir -p %D/share/emacs/%%EMACS_VERSION%%/site-lisp; fi
-@comment these two can fail if other ports are installed, no need to
+@exec mkdir -p /var/run/emacs/lock ; chmod 1777 /var/run/emacs/lock
+etc/rc.d/emacs.sh
+@comment This can fail if other ports are installed, no need to
@comment scare user in that case
-@unexec rmdir %D/share/emacs/site-lisp 2>/dev/null || true
@unexec rmdir %D/share/emacs/%%EMACS_VERSION%%/site-lisp 2>/dev/null || true
@unexec install-info --delete %D/info/emacs %D/info/dir
@unexec install-info --delete %D/info/vip %D/info/dir
@@ -125,6 +126,7 @@ libexec/emacs/%%EMACS_VERSION%%/i386--freebsd/vcdiff
libexec/emacs/%%EMACS_VERSION%%/i386--freebsd/yow
@dirrm libexec/emacs/%%EMACS_VERSION%%/i386--freebsd
@dirrm libexec/emacs/%%EMACS_VERSION%%
+@unexec rmdir %D/libexec/emacs 2>/dev/null || true
share/emacs/%%EMACS_VERSION%%/etc/3B-MAXMEM
share/emacs/%%EMACS_VERSION%%/etc/AIX.DUMP
share/emacs/%%EMACS_VERSION%%/etc/BABYL
diff --git a/editors/emacs23/Makefile b/editors/emacs23/Makefile
index 7a8d539e944c..9957ad38ce08 100644
--- a/editors/emacs23/Makefile
+++ b/editors/emacs23/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.31 1998/04/04 07:36:40 asami Exp $
+# $Id: Makefile,v 1.32 1998/09/14 07:26:02 asami Exp $
#
DISTNAME= emacs-19.34b
@@ -18,7 +18,8 @@ NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/emacs-19.34
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386--freebsd --with-x-toolkit
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
+ --sharedstatedir=/var/run
STRIP=
MAN1= emacs.1 etags.1 ctags.1
@@ -32,5 +33,9 @@ post-install:
.for info in emacs vip viper forms gnus mh-e cl sc dired-x ediff ccmode message
install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
.endfor
+# install emacs.sh into ${PREFIX}/etc/rc.d
+ chmod 1777 /var/run/emacs/lock
+ @${MKDIR} ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${FILESDIR}/emacs.sh ${PREFIX}/etc/rc.d
.include <bsd.port.mk>
diff --git a/editors/emacs23/files/emacs.sh b/editors/emacs23/files/emacs.sh
new file mode 100644
index 000000000000..09baabfd255c
--- /dev/null
+++ b/editors/emacs23/files/emacs.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+if [ -d /var/run/emacs/lock ]
+then
+ rm -f /var/run/emacs/lock/*
+else
+ mkdir -p /var/run/emacs/lock
+fi
+chmod 1777 /var/run/emacs/lock
+exit 0
+
diff --git a/editors/emacs23/pkg-plist b/editors/emacs23/pkg-plist
index 9bb26b6d7d61..64141be5d27d 100644
--- a/editors/emacs23/pkg-plist
+++ b/editors/emacs23/pkg-plist
@@ -8,9 +8,10 @@ bin/etags
bin/emacsclient
@exec if [ ! -d %d/share/emacs/site-lisp ]; then mkdir -p %D/share/emacs/site-lisp; fi
@exec if [ ! -d %d/share/emacs/%%EMACS_VERSION%%/site-lisp ]; then mkdir -p %D/share/emacs/%%EMACS_VERSION%%/site-lisp; fi
-@comment these two can fail if other ports are installed, no need to
+@exec mkdir -p /var/run/emacs/lock ; chmod 1777 /var/run/emacs/lock
+etc/rc.d/emacs.sh
+@comment This can fail if other ports are installed, no need to
@comment scare user in that case
-@unexec rmdir %D/share/emacs/site-lisp 2>/dev/null || true
@unexec rmdir %D/share/emacs/%%EMACS_VERSION%%/site-lisp 2>/dev/null || true
@unexec install-info --delete %D/info/emacs %D/info/dir
@unexec install-info --delete %D/info/vip %D/info/dir
@@ -125,6 +126,7 @@ libexec/emacs/%%EMACS_VERSION%%/i386--freebsd/vcdiff
libexec/emacs/%%EMACS_VERSION%%/i386--freebsd/yow
@dirrm libexec/emacs/%%EMACS_VERSION%%/i386--freebsd
@dirrm libexec/emacs/%%EMACS_VERSION%%
+@unexec rmdir %D/libexec/emacs 2>/dev/null || true
share/emacs/%%EMACS_VERSION%%/etc/3B-MAXMEM
share/emacs/%%EMACS_VERSION%%/etc/AIX.DUMP
share/emacs/%%EMACS_VERSION%%/etc/BABYL