aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-18 09:46:46 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-18 09:46:46 +0000
commit8493a5819b74095ca9e0b9f0cf8e77fedad823e1 (patch)
tree19832c4fa0699d64a8eaf478f63987c7ab06da65 /editors
parent0b31d075bc0e27d93cf260d6dda0f3fbe47654e6 (diff)
downloadports-8493a5819b74095ca9e0b9f0cf8e77fedad823e1.tar.gz
ports-8493a5819b74095ca9e0b9f0cf8e77fedad823e1.zip
Iconv cleanup, stage 1b: correct {BUILD,LIB,RUN}_DEPENDS of all ports that need
libiconv.
Notes
Notes: svn path=/head/; revision=56287
Diffstat (limited to 'editors')
-rw-r--r--editors/AbiWord/Makefile5
-rw-r--r--editors/AbiWord2/Makefile5
-rw-r--r--editors/abiword-devel/Makefile5
-rw-r--r--editors/abiword/Makefile5
-rw-r--r--editors/calligra/Makefile2
-rw-r--r--editors/dedit/Makefile2
-rw-r--r--editors/koffice-kde3/Makefile2
-rw-r--r--editors/koffice-kde4/Makefile2
-rw-r--r--editors/koffice/Makefile2
-rw-r--r--editors/nvi-devel/Makefile2
10 files changed, 14 insertions, 18 deletions
diff --git a/editors/AbiWord/Makefile b/editors/AbiWord/Makefile
index d9352ba864cc..e25f897d904f 100644
--- a/editors/AbiWord/Makefile
+++ b/editors/AbiWord/Makefile
@@ -20,10 +20,9 @@ DISTNAME= abiword-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
# unzip is needed during the installation process
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
- giconv:${PORTSDIR}/converters/libiconv
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- giconv.2:${PORTSDIR}/converters/libiconv \
+ iconv.3:${PORTSDIR}/converters/libiconv \
psiconv.8:${PORTSDIR}/converters/psiconv
DIST_SUBDIR= AbiWord
diff --git a/editors/AbiWord2/Makefile b/editors/AbiWord2/Makefile
index d9352ba864cc..e25f897d904f 100644
--- a/editors/AbiWord2/Makefile
+++ b/editors/AbiWord2/Makefile
@@ -20,10 +20,9 @@ DISTNAME= abiword-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
# unzip is needed during the installation process
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
- giconv:${PORTSDIR}/converters/libiconv
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- giconv.2:${PORTSDIR}/converters/libiconv \
+ iconv.3:${PORTSDIR}/converters/libiconv \
psiconv.8:${PORTSDIR}/converters/psiconv
DIST_SUBDIR= AbiWord
diff --git a/editors/abiword-devel/Makefile b/editors/abiword-devel/Makefile
index d9352ba864cc..e25f897d904f 100644
--- a/editors/abiword-devel/Makefile
+++ b/editors/abiword-devel/Makefile
@@ -20,10 +20,9 @@ DISTNAME= abiword-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
# unzip is needed during the installation process
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
- giconv:${PORTSDIR}/converters/libiconv
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- giconv.2:${PORTSDIR}/converters/libiconv \
+ iconv.3:${PORTSDIR}/converters/libiconv \
psiconv.8:${PORTSDIR}/converters/psiconv
DIST_SUBDIR= AbiWord
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index d9352ba864cc..e25f897d904f 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -20,10 +20,9 @@ DISTNAME= abiword-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
# unzip is needed during the installation process
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
- giconv:${PORTSDIR}/converters/libiconv
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- giconv.2:${PORTSDIR}/converters/libiconv \
+ iconv.3:${PORTSDIR}/converters/libiconv \
psiconv.8:${PORTSDIR}/converters/psiconv
DIST_SUBDIR= AbiWord
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 03fa731054c6..6f52cf261a7a 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
USE_KDELIBS_VER=2
USE_PYTHON= yes
diff --git a/editors/dedit/Makefile b/editors/dedit/Makefile
index b440b85f2a61..f8bb3ea214ef 100644
--- a/editors/dedit/Makefile
+++ b/editors/dedit/Makefile
@@ -13,7 +13,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= nakai@FreeBSD.org
-LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index 03fa731054c6..6f52cf261a7a 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
USE_KDELIBS_VER=2
USE_PYTHON= yes
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 03fa731054c6..6f52cf261a7a 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
USE_KDELIBS_VER=2
USE_PYTHON= yes
diff --git a/editors/koffice/Makefile b/editors/koffice/Makefile
index 03fa731054c6..6f52cf261a7a 100644
--- a/editors/koffice/Makefile
+++ b/editors/koffice/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
USE_KDELIBS_VER=2
USE_PYTHON= yes
diff --git a/editors/nvi-devel/Makefile b/editors/nvi-devel/Makefile
index cf6c449b2fad..7f8315f48993 100644
--- a/editors/nvi-devel/Makefile
+++ b/editors/nvi-devel/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://www.kotnet.org/~skimo/nvi/devel/
MAINTAINER= dd@FreeBSD.org
-BUILD_DEPENDS= iconv:${PORTSDIR}/converters/iconv
+BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
LIB_DEPENDS= db3.2:${PORTSDIR}/databases/db3
USE_BZIP2= yes