aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>1999-09-27 16:40:53 +0000
committerChuck Robey <chuckr@FreeBSD.org>1999-09-27 16:40:53 +0000
commit141629beba83dbf5b748799ce750a584800fcc44 (patch)
tree104d95f835e2e204050b07d41dcf07c71d50ebd1 /editors
parentf9ac924e8e69bafdf9e3a8b14a98c6abe43280c6 (diff)
downloadports-141629beba83dbf5b748799ce750a584800fcc44.tar.gz
ports-141629beba83dbf5b748799ce750a584800fcc44.zip
Finally fix all parts of thoteditor.
Notes
Notes: svn path=/head/; revision=22005
Diffstat (limited to 'editors')
-rw-r--r--editors/thoteditor/Makefile9
-rw-r--r--editors/thoteditor/files/patch-ac12
-rw-r--r--editors/thoteditor/files/patch-af11
-rw-r--r--editors/thoteditor/files/patch-ag34
-rw-r--r--editors/thoteditor/pkg-plist2
5 files changed, 63 insertions, 5 deletions
diff --git a/editors/thoteditor/Makefile b/editors/thoteditor/Makefile
index 3289ceaf25d4..3f955eb7e8f7 100644
--- a/editors/thoteditor/Makefile
+++ b/editors/thoteditor/Makefile
@@ -22,9 +22,6 @@ MAINTAINER= chuckr@FreeBSD.org
THOT_SUBDIR= Target
REQUIRES_MOTIF= yes
WRKSRC= $(WRKDIR)/Thot/$(THOT_SUBDIR)
-
-BROKEN= initialization issues not finished yet
-
REQUIRES_MOTIF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya --disable-java --disable-intr --disable-jit --disable-math --disable-ilu
@@ -34,10 +31,16 @@ ALL_TARGET= all schemas
do-configure:
(cd $(WRKSRC);../configure $(CONFIGURE_ARGS))
+post-configure:
+ $(CP) $(WRKSRC)/../thotlib/base/registry.c $(WRKSRC)/../thotlib/base/registry.c.orig
+ $(SED) -e "s&%%PREFIX%%&$(PREFIX)&" <$(WRKSRC)/../thotlib/base/registry.c.orig >$(WRKSRC)/../thotlib/base/registry.c
+
post-extract:
(cd $(WRKDIR)/Thot;$(MKDIR) $(THOT_SUBDIR))
post-install:
${MKDIR} ${PREFIX}/share/thot/doc
+ $(SED) -e "s&%%PREFIX%%&$(PREFIX)&" < $(FILESDIR)/thoteditor > $(WRKDIR)/thoteditor
+ $(INSTALL_SCRIPT) $(WRKDIR)/thoteditor $(PREFIX)/bin
.include <bsd.port.mk>
diff --git a/editors/thoteditor/files/patch-ac b/editors/thoteditor/files/patch-ac
index 806f42c965de..45d8e0e9ca7f 100644
--- a/editors/thoteditor/files/patch-ac
+++ b/editors/thoteditor/files/patch-ac
@@ -1,6 +1,14 @@
--- ../thot/Makefile.in.orig Wed Nov 19 05:41:49 1997
-+++ ../thot/Makefile.in Sat Sep 25 11:53:28 1999
-@@ -54,30 +54,32 @@
++++ ../thot/Makefile.in Sun Sep 26 23:08:12 1999
+@@ -27,6 +27,7 @@
+ CONFIGFILES= \
+ XKeysymDB thot.ini thot.color thot.pattern thot.keyboard \
+ fr-thotdialogue en-appdialogue en-compildialogue en-corrdialogue \
++ en-cssmessage \
+ en-drawdialogue en-grmdialogue en-inddialogue en-itfdialogue \
+ en-libdialogue en-printdialogue en-prsdialogue en-strdialogue \
+ en-thotdialogue en-thotmessage en-thotversion en-transdialogue \
+@@ -54,30 +55,32 @@
$(RM) *.o EDITORAPP.c EDITOR.A
install : all
diff --git a/editors/thoteditor/files/patch-af b/editors/thoteditor/files/patch-af
new file mode 100644
index 000000000000..fa722a3de559
--- /dev/null
+++ b/editors/thoteditor/files/patch-af
@@ -0,0 +1,11 @@
+--- ../thotlib/include/sysdep.h.orig Sat Sep 25 15:08:35 1999
++++ ../thotlib/include/sysdep.h Sat Sep 25 15:10:04 1999
+@@ -1239,7 +1239,7 @@
+ */
+ #ifndef CACHE_FILE_PREFIX
+ #ifdef unix
+-#define CACHE_FILE_PREFIX "/usr/wsrc/"
++#define CACHE_FILE_PREFIX "/usr/tmp/"
+ #endif
+ #endif
+ /*
diff --git a/editors/thoteditor/files/patch-ag b/editors/thoteditor/files/patch-ag
new file mode 100644
index 000000000000..b935d6ed5c2a
--- /dev/null
+++ b/editors/thoteditor/files/patch-ag
@@ -0,0 +1,34 @@
+--- ../thotlib/base/registry.c.orig Mon Sep 27 00:32:18 1999
++++ ../thotlib/base/registry.c Mon Sep 27 00:34:52 1999
+@@ -833,6 +833,7 @@
+ PathBuffer path;
+ char *home_dir;
+ char filename[MAX_PATH];
++ char homecmd[MAX_PATH];
+ char *my_path;
+ char *dir_end = NULL;
+ char *appName;
+@@ -1084,13 +1085,22 @@
+ dir_end -= 3;
+ }
+ else
+- fprintf (stderr, "System wide %s not found at %s\n", THOT_INI_FILENAME, &filename[0]);
++ fprintf (stderr, " ");
++/* fprintf (stderr, "System wide %s not found at %s\n", THOT_INI_FILENAME, &filename[0]); */
+
+ if (home_dir != NULL)
+ {
+ strcpy (filename, home_dir);
+ strcat (filename, DIR_STR);
+ strcat (filename, THOT_RC_FILENAME);
++ if (!TtaFileExist (&filename[0]))
++ {
++ sprintf(homecmd,"/bin/cp /usr/local/share/thot/config/thot.ini %s%s.thotrc\n",home_dir,DIR_STR);
++ fprintf(stderr,"Copying system thot.ini into ~/.thotrc.\n");
++ system(homecmd);
++ sprintf(homecmd,"/bin/chmod u+w %s%s.thotrc\n",home_dir,DIR_STR);
++ system(homecmd);
++ }
+ if (TtaFileExist (&filename[0]))
+ {
+ #ifdef DEBUG_REGISTRY
diff --git a/editors/thoteditor/pkg-plist b/editors/thoteditor/pkg-plist
index 24dfaa3d8cb5..ada9cbee1fe2 100644
--- a/editors/thoteditor/pkg-plist
+++ b/editors/thoteditor/pkg-plist
@@ -7,6 +7,7 @@ bin/cextract
bin/print
bin/prs
bin/thot
+bin/thoteditor
share/thot/batch/APP.GRM
share/thot/batch/PRESEN.GRM
share/thot/batch/STRUCT.GRM
@@ -36,6 +37,7 @@ share/thot/config/fr-thotdialogue
share/thot/config/en-appdialogue
share/thot/config/en-compildialogue
share/thot/config/en-corrdialogue
+share/thot/config/en-cssmessage
share/thot/config/en-drawdialogue
share/thot/config/en-grmdialogue
share/thot/config/en-inddialogue