aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-06 20:04:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-06 20:04:24 +0000
commite07f6b9819c0f13e076e3ed9ac70fa37d44d5474 (patch)
tree82bdcf6d87fef20d73a924d9cc7d2d895a21768c /editors
parent9caf3d7e357aca7694c8538459db924587c78588 (diff)
downloadports-e07f6b9819c0f13e076e3ed9ac70fa37d44d5474.tar.gz
ports-e07f6b9819c0f13e076e3ed9ac70fa37d44d5474.zip
Add mlview, a tree based XML editor for GNOME
PR: ports/57169 Submitted by: Simon Barner <barner@in.tum.de>
Notes
Notes: svn path=/head/; revision=95199
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/mlview/Makefile27
-rw-r--r--editors/mlview/distinfo1
-rw-r--r--editors/mlview/files/patch-ltmain.sh41
-rw-r--r--editors/mlview/files/patch-src-mlview-icon-tree.c15
-rw-r--r--editors/mlview/files/patch-src-mlview-ns-editor.c28
-rw-r--r--editors/mlview/files/patch-src-mlview-tree-editor2.c15
-rw-r--r--editors/mlview/pkg-descr4
-rw-r--r--editors/mlview/pkg-plist40
9 files changed, 172 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 563f4bdd2099..3968730f26b7 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -87,6 +87,7 @@
SUBDIR += lpe
SUBDIR += manedit
SUBDIR += mg
+ SUBDIR += mlview
SUBDIR += mode-info
SUBDIR += moleskine
SUBDIR += mp
diff --git a/editors/mlview/Makefile b/editors/mlview/Makefile
new file mode 100644
index 000000000000..92e1273d4df0
--- /dev/null
+++ b/editors/mlview/Makefile
@@ -0,0 +1,27 @@
+# Ports collection Makefile for: mlview
+# Date created: 24 September 2003
+# Whom: Simon Barner <barner@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mlview
+PORTVERSION= 0.6.1
+CATEGORIES= editors gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
+DIST_SUBDIR= gnome2
+
+MAINTAINER= barner@gmx.de
+COMMENT= A tree oriented XML editor for Gnome
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_AUTOCONF_VER= 253
+USE_GNOME= gnomeprefix gnomehack libgnomeui
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/editors/mlview/distinfo b/editors/mlview/distinfo
new file mode 100644
index 000000000000..7d471c11dde4
--- /dev/null
+++ b/editors/mlview/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/mlview-0.6.1.tar.bz2) = a2f3b78faafc9dc8644c6c7e632de716
diff --git a/editors/mlview/files/patch-ltmain.sh b/editors/mlview/files/patch-ltmain.sh
new file mode 100644
index 000000000000..ea534afd592a
--- /dev/null
+++ b/editors/mlview/files/patch-ltmain.sh
@@ -0,0 +1,41 @@
+--- ltmain.sh.orig Fri Nov 21 21:36:55 2003
++++ ltmain.sh Sat Dec 6 20:58:32 2003
+@@ -1086,7 +1086,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1096,8 +1096,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -4351,10 +4359,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/editors/mlview/files/patch-src-mlview-icon-tree.c b/editors/mlview/files/patch-src-mlview-icon-tree.c
new file mode 100644
index 000000000000..468d902bb951
--- /dev/null
+++ b/editors/mlview/files/patch-src-mlview-icon-tree.c
@@ -0,0 +1,15 @@
+--- src/mlview-icon-tree.c.orig Thu Nov 20 21:07:14 2003
++++ src/mlview-icon-tree.c Sat Dec 6 20:52:53 2003
+@@ -388,9 +388,11 @@
+ guchar *result = NULL,
+ *content = NULL;
+
++ const gchar *colour_str;
++
+ g_return_val_if_fail (a_node != NULL, NULL);
+
+- const gchar *colour_str = mlview_tree_editor2_get_colour_string (a_node->type);
++ colour_str = mlview_tree_editor2_get_colour_string (a_node->type);
+
+ if (a_node->type == XML_ELEMENT_NODE) {
+ guchar *ns_prefix = NULL,
diff --git a/editors/mlview/files/patch-src-mlview-ns-editor.c b/editors/mlview/files/patch-src-mlview-ns-editor.c
new file mode 100644
index 000000000000..91b4c887bad4
--- /dev/null
+++ b/editors/mlview/files/patch-src-mlview-ns-editor.c
@@ -0,0 +1,28 @@
+--- src/mlview-ns-editor.c.orig Thu Nov 13 01:06:36 2003
++++ src/mlview-ns-editor.c Sat Dec 6 20:51:10 2003
+@@ -1063,12 +1063,6 @@
+ xmlNode *a_node,
+ xmlNs *a_ns)
+ {
+- g_return_val_if_fail (a_this
+- && MLVIEW_IS_NS_EDITOR (a_this)
+- && a_node
+- && a_ns,
+- MLVIEW_BAD_PARAM_ERROR) ;
+-
+ GtkTreeRowReference *row_ref = NULL ;
+ GtkTreePath *tree_path = NULL ;
+ GtkTreeIter iter = {0} ;
+@@ -1076,6 +1070,12 @@
+ gboolean is_ok = FALSE ;
+ xmlNs *ns = NULL ;
+ enum MlViewStatus status = MLVIEW_OK ;
++
++ g_return_val_if_fail (a_this
++ && MLVIEW_IS_NS_EDITOR (a_this)
++ && a_node
++ && a_ns,
++ MLVIEW_BAD_PARAM_ERROR) ;
+
+ if (PRIVATE (a_this)->cur_xml_node != a_node) {
+ return MLVIEW_OK ;
diff --git a/editors/mlview/files/patch-src-mlview-tree-editor2.c b/editors/mlview/files/patch-src-mlview-tree-editor2.c
new file mode 100644
index 000000000000..ccc1f2a30b23
--- /dev/null
+++ b/editors/mlview/files/patch-src-mlview-tree-editor2.c
@@ -0,0 +1,15 @@
+--- src/mlview-tree-editor2.c.orig Thu Nov 20 09:11:34 2003
++++ src/mlview-tree-editor2.c Sat Dec 6 20:48:30 2003
+@@ -760,9 +760,11 @@
+ guchar *result = NULL,
+ *content = NULL;
+
++ const gchar *colour_str;
++
+ g_return_val_if_fail (a_node != NULL, NULL);
+
+- const gchar *colour_str = mlview_tree_editor2_get_colour_string (a_node->type);
++ colour_str = mlview_tree_editor2_get_colour_string (a_node->type);
+
+ if (a_node->type == XML_ELEMENT_NODE) {
+ guchar *ns_prefix = NULL,
diff --git a/editors/mlview/pkg-descr b/editors/mlview/pkg-descr
new file mode 100644
index 000000000000..1122dcef0c4a
--- /dev/null
+++ b/editors/mlview/pkg-descr
@@ -0,0 +1,4 @@
+A tree oriented xml editor for gnome. It is an attempt to ease editing
+xml documents with or without validation by focusing on their tree view.
+
+WWW: http://www.mlview.org
diff --git a/editors/mlview/pkg-plist b/editors/mlview/pkg-plist
new file mode 100644
index 000000000000..a867f329805b
--- /dev/null
+++ b/editors/mlview/pkg-plist
@@ -0,0 +1,40 @@
+bin/mlv
+etc/gconf/gconf.xml.defaults/apps/mlview/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/mlview/%gconf.xml
+etc/gconf/schemas/mlview.schemas
+lib/libmlview.a
+lib/libmlview.so
+lib/libmlview.so.3
+share/gnome/applications/mlview.desktop
+share/gnome/mlview/mlview-dtd-choice.glade
+share/gnome/mlview/mlview-dtd-choice-dtd-not-resolved.glade
+share/gnome/mlview/mlview-preferences.glade
+share/gnome/mlview/tree-view-find-dialog.glade
+share/gnome/pixmaps/mlview-app-icon.png
+share/gnome/pixmaps/mlview-app-icon.xpm
+share/gnome/pixmaps/xml-comment-node.png
+share/gnome/pixmaps/xml-element-node.png
+share/gnome/pixmaps/xml-element-node-open.png
+share/gnome/pixmaps/xml-pi-node.png
+share/gnome/pixmaps/xml-root.png
+share/gnome/pixmaps/xml-root-open.png
+share/gnome/pixmaps/xml-text-node.png
+share/locale/az/LC_MESSAGES/mlview.mo
+share/locale/ca/LC_MESSAGES/mlview.mo
+share/locale/cs/LC_MESSAGES/mlview.mo
+share/locale/es/LC_MESSAGES/mlview.mo
+share/locale/fr/LC_MESSAGES/mlview.mo
+share/locale/ja/LC_MESSAGES/mlview.mo
+share/locale/ml/LC_MESSAGES/mlview.mo
+share/locale/ms/LC_MESSAGES/mlview.mo
+share/locale/nl/LC_MESSAGES/mlview.mo
+share/locale/pl/LC_MESSAGES/mlview.mo
+share/locale/pt/LC_MESSAGES/mlview.mo
+share/locale/pt_BR/LC_MESSAGES/mlview.mo
+share/locale/ru/LC_MESSAGES/mlview.mo
+share/locale/sr/LC_MESSAGES/mlview.mo
+share/locale/sr@Latn/LC_MESSAGES/mlview.mo
+share/locale/sv/LC_MESSAGES/mlview.mo
+@dirrm share/gnome/mlview
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/mlview
+@dirrm etc/gconf/gconf.xml.defaults/apps/mlview