aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2007-05-30 00:23:55 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2007-05-30 00:23:55 +0000
commit385ad0258bbc70aad5e506806b0352fef4e34b6b (patch)
treeb73445470bdd5fa802134e7134de814faec84609 /editors
parent821f3c51a136d4a41c411f5063c644bbc239c07a (diff)
downloadports-385ad0258bbc70aad5e506806b0352fef4e34b6b.tar.gz
ports-385ad0258bbc70aad5e506806b0352fef4e34b6b.zip
Fix build breakage with WITH_CUPS knob.
Approved by: maho (maintainer)
Notes
Notes: svn path=/head/; revision=192340
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3-devel/Makefile4
-rw-r--r--editors/openoffice.org-2-devel/Makefile4
-rw-r--r--editors/openoffice.org-3-devel/Makefile4
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile4
4 files changed, 12 insertions, 4 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index eb6a57ce7964..7263abc67477 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -105,7 +105,9 @@ OOOCXX= ${CCACHE_PREFIX} ${CXX}
OOOCC= ${CC}
OOOCXX= ${CXX}
.endif
-CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}"
+CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index eb6a57ce7964..7263abc67477 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -105,7 +105,9 @@ OOOCXX= ${CCACHE_PREFIX} ${CXX}
OOOCC= ${CC}
OOOCXX= ${CXX}
.endif
-CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}"
+CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index eb6a57ce7964..7263abc67477 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -105,7 +105,9 @@ OOOCXX= ${CCACHE_PREFIX} ${CXX}
OOOCC= ${CC}
OOOCXX= ${CXX}
.endif
-CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}"
+CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index eb6a57ce7964..7263abc67477 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -105,7 +105,9 @@ OOOCXX= ${CCACHE_PREFIX} ${CXX}
OOOCC= ${CC}
OOOCXX= ${CXX}
.endif
-CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}"
+CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \