aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-01-28 02:11:35 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-01-28 02:11:35 +0000
commitb09666fc1e84f3c48ffd364896f780150a2cf5a9 (patch)
treec998550baecf34be07870269231bbbcbca9ae8c8 /editors
parent59da8c223b9e2c7be998c21dd9ea8fcbb6977dc7 (diff)
downloadports-b09666fc1e84f3c48ffd364896f780150a2cf5a9.tar.gz
ports-b09666fc1e84f3c48ffd364896f780150a2cf5a9.zip
- Fix possibility of "infinite make fork" when "Registering install for ..."
EMACS ports. [1] - Allow building a port as root using an NFS-mounted /usr/ports if the server maps root to a UID other than root. [2] - Make 'BROKEN' and 'IGNORED' ports exit their "make install" with a fail status rather than success. [3] - Improve behavior when dealing with versioned dependencies. [4] - Fix false positives in check-conflicts target. [5] - Remove obsolete bzip2 code. [6] - Add physical category net-p2p. [7] - Don't fetch INDEXFILE if not necessary; respect FETCH_ENV. [8], [11] - INDEX can now be moved outside of ports tree. [9] - Add ghostscript-gpl. [10] - Remove obsolete USE_MESA. [12] - Force pkg_install tools from ports on FreeBSD 4.10 and older. [13] - Document ALWAYS_KEEP_DISTFILES. [14] - Remove USE_REINPLACE from bsd.port.mk USE_DOS2UNIX patch. [15] PR: ports/37596 [1], ports/57259 [2], ports/63216 [3], ports/89448 [4], ports/89710 [5], ports/88996 [6], ports/89260 [7], ports/89363 [8], ports/89809 [9], ports/89853 [10], ports/91086 [11], ports/91710 [12], ports/91727 [13], ports/92111 [14], ports/92124 [15] Submitted by: Jay Sachs <jay at eziba dot com> [1], sem [1, 3, 8, 12], Andrew Heybey <ath at niksun dot com> [2], Jamie Jones <jamie at thompson dot bishopston dot net>, tobez [4], Mark Andrews <Mark_Andrews at isc dot org> [5], edwin [6, 11, 15], pav [7, 13], Peter Jeremy <PeterJeremy at optushome dot com dot au> [9], Ulrich Spoerlein <q at galgenberg dot net> [10], netchild [11], erwin [14] Reviewed by: kris, clement (partially)
Notes
Notes: svn path=/head/; revision=154626
Diffstat (limited to 'editors')
-rw-r--r--editors/apel-emacs19/Makefile1
-rw-r--r--editors/apel-emacs20/Makefile1
-rw-r--r--editors/apel-mule/Makefile1
-rw-r--r--editors/apel/Makefile1
-rw-r--r--editors/bitmap-emacs20/Makefile1
-rw-r--r--editors/bitmap-mule/Makefile1
-rw-r--r--editors/bitmap/Makefile1
-rw-r--r--editors/custom-emacs/Makefile1
-rw-r--r--editors/custom-mule/Makefile1
-rw-r--r--editors/eshell-emacs20/Makefile1
-rw-r--r--editors/flim-emacs20/Makefile1
-rw-r--r--editors/flim-xemacs21-mule/Makefile1
-rw-r--r--editors/flim/Makefile1
-rw-r--r--editors/flim113-emacs19/Makefile1
-rw-r--r--editors/flim113-emacs20/Makefile1
-rw-r--r--editors/flim113-mule/Makefile1
-rw-r--r--editors/flim113/Makefile1
-rw-r--r--editors/gnuserv-emacs20/Makefile1
-rw-r--r--editors/gnuserv/Makefile1
-rw-r--r--editors/iiimecf/Makefile1
-rw-r--r--editors/mode-info/Makefile1
-rw-r--r--editors/nxml-emacs21/Makefile1
-rw-r--r--editors/nxml/Makefile1
-rw-r--r--editors/psgml-emacs19/Makefile1
-rw-r--r--editors/psgml-emacs20/Makefile1
-rw-r--r--editors/psgml-mule/Makefile1
-rw-r--r--editors/psgml/Makefile1
-rw-r--r--editors/semi-emacs20/Makefile1
-rw-r--r--editors/semi-xemacs21-mule/Makefile1
-rw-r--r--editors/semi/Makefile1
-rw-r--r--editors/semi113-emacs19/Makefile1
-rw-r--r--editors/semi113-emacs20/Makefile1
-rw-r--r--editors/semi113-mule/Makefile1
-rw-r--r--editors/semi113/Makefile1
-rw-r--r--editors/slime/Makefile1
-rw-r--r--editors/speedbar-emacs20/Makefile1
-rw-r--r--editors/speedbar/Makefile1
-rw-r--r--editors/tamago-emacs20/Makefile2
-rw-r--r--editors/tamago-emacs21/Makefile1
-rw-r--r--editors/tamago/Makefile1
-rw-r--r--editors/tree-widget/Makefile1
41 files changed, 42 insertions, 0 deletions
diff --git a/editors/apel-emacs19/Makefile b/editors/apel-emacs19/Makefile
index 1b291db80de1..bbe90d4c0023 100644
--- a/editors/apel-emacs19/Makefile
+++ b/editors/apel-emacs19/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/apel
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs19
.include "${MASTERDIR}/Makefile"
diff --git a/editors/apel-emacs20/Makefile b/editors/apel-emacs20/Makefile
index dc2f98fc56fd..b6787ad49d6c 100644
--- a/editors/apel-emacs20/Makefile
+++ b/editors/apel-emacs20/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/apel
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
.include "${MASTERDIR}/Makefile"
diff --git a/editors/apel-mule/Makefile b/editors/apel-mule/Makefile
index 9fb50087bc58..8c923e09a122 100644
--- a/editors/apel-mule/Makefile
+++ b/editors/apel-mule/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/apel
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= mule
.include <${MASTERDIR}/Makefile>
diff --git a/editors/apel/Makefile b/editors/apel/Makefile
index 8e8850caaddf..0da1c8e5ae3e 100644
--- a/editors/apel/Makefile
+++ b/editors/apel/Makefile
@@ -30,6 +30,7 @@ APEL_VERSION_SPECIFIC_LISPDIR?= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
PORTCLASS?= master
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
EMACS_MASTERDIR_PKGFILES=YES
diff --git a/editors/bitmap-emacs20/Makefile b/editors/bitmap-emacs20/Makefile
index 1c0d2a3e2973..e3559969b905 100644
--- a/editors/bitmap-emacs20/Makefile
+++ b/editors/bitmap-emacs20/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/bitmap
# Setup EMACS_PORT_NAME variable.
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
.include "${MASTERDIR}/Makefile"
diff --git a/editors/bitmap-mule/Makefile b/editors/bitmap-mule/Makefile
index 9fef02f8a6a1..b8d9767f0823 100644
--- a/editors/bitmap-mule/Makefile
+++ b/editors/bitmap-mule/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/bitmap
# Setup EMACS_PORT_NAME variable.
+USE_EMACS= yes
EMACS_PORT_NAME= mule
.include <${MASTERDIR}/Makefile>
diff --git a/editors/bitmap/Makefile b/editors/bitmap/Makefile
index dbd4f4751430..160f97a7f8d0 100644
--- a/editors/bitmap/Makefile
+++ b/editors/bitmap/Makefile
@@ -40,6 +40,7 @@ PORTCLASS?= master
# Setup EMACS_PORT_NAME variable.
.if (${PORTCLASS} == "master")
+USE_EMACS= yes
EMACS_PORT_NAME= emacs21
DEPPORT_SUFFIX=
.else
diff --git a/editors/custom-emacs/Makefile b/editors/custom-emacs/Makefile
index f33df591755b..9e40b88955d3 100644
--- a/editors/custom-emacs/Makefile
+++ b/editors/custom-emacs/Makefile
@@ -27,6 +27,7 @@ CUSTOM_ELS= cus-edit.el cus-face.el custom.el \
PORTCLASS?= master
.if (${PORTCLASS} == "master")
+USE_EMACS= yes
EMACS_PORT_NAME= emacs19
.endif
diff --git a/editors/custom-mule/Makefile b/editors/custom-mule/Makefile
index 30d2ee090cd1..f50344542992 100644
--- a/editors/custom-mule/Makefile
+++ b/editors/custom-mule/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/custom-emacs
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= mule
# pkg/* files but PLIST are used in ${.CURDIR}
diff --git a/editors/eshell-emacs20/Makefile b/editors/eshell-emacs20/Makefile
index 6dbd2c428871..477281c25636 100644
--- a/editors/eshell-emacs20/Makefile
+++ b/editors/eshell-emacs20/Makefile
@@ -16,6 +16,7 @@ DISTNAME= ${PORTNAME}
MAINTAINER= yoichi@FreeBSD.org
COMMENT= Command shell implemented in emacs lisp
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
PCOMPLETE_VERSION= 1.1.7
diff --git a/editors/flim-emacs20/Makefile b/editors/flim-emacs20/Makefile
index ed7a160b2af9..90803fd65375 100644
--- a/editors/flim-emacs20/Makefile
+++ b/editors/flim-emacs20/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/flim
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
.include "${MASTERDIR}/Makefile"
diff --git a/editors/flim-xemacs21-mule/Makefile b/editors/flim-xemacs21-mule/Makefile
index bbddbe69c1e1..4045c43d1c40 100644
--- a/editors/flim-xemacs21-mule/Makefile
+++ b/editors/flim-xemacs21-mule/Makefile
@@ -14,6 +14,7 @@ MASTERDIR= ${.CURDIR}/../../editors/flim
COMMENT= FLIM, message representation or encoding elisp library for xemacs21-mule
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= xemacs21-mule
EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
diff --git a/editors/flim/Makefile b/editors/flim/Makefile
index e0292a8bad4d..034784f72b68 100644
--- a/editors/flim/Makefile
+++ b/editors/flim/Makefile
@@ -29,6 +29,7 @@ FLIM_LISPDIR= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
FLIM_VERSION_SPECIFIC_LISPDIR= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
.if (${PORTCLASS} == "master")
+USE_EMACS= yes
EMACS_PORT_NAME= emacs21
DEPPORT_SUFFIX=
.else
diff --git a/editors/flim113-emacs19/Makefile b/editors/flim113-emacs19/Makefile
index d2b8497f6a53..b219755ab18a 100644
--- a/editors/flim113-emacs19/Makefile
+++ b/editors/flim113-emacs19/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/flim113
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs19
.include "${MASTERDIR}/Makefile"
diff --git a/editors/flim113-emacs20/Makefile b/editors/flim113-emacs20/Makefile
index e87e3c765f4b..f301a62279bf 100644
--- a/editors/flim113-emacs20/Makefile
+++ b/editors/flim113-emacs20/Makefile
@@ -15,6 +15,7 @@ NO_LATEST_LINK= yes
MASTERDIR= ${.CURDIR}/../../editors/flim113
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
.include "${MASTERDIR}/Makefile"
diff --git a/editors/flim113-mule/Makefile b/editors/flim113-mule/Makefile
index a888e36c64d9..927839bfa481 100644
--- a/editors/flim113-mule/Makefile
+++ b/editors/flim113-mule/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/flim113
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= mule
.include "${MASTERDIR}/Makefile"
diff --git a/editors/flim113/Makefile b/editors/flim113/Makefile
index c6d261b4501d..76bd30ada869 100644
--- a/editors/flim113/Makefile
+++ b/editors/flim113/Makefile
@@ -33,6 +33,7 @@ FLIM_LISPDIR?= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
FLIM_VERSION_SPECIFIC_LISPDIR?= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
.if (${PORTCLASS} == "master")
+USE_EMACS= yes
EMACS_PORT_NAME= emacs21
DEPPORT_SUFFIX=
.else
diff --git a/editors/gnuserv-emacs20/Makefile b/editors/gnuserv-emacs20/Makefile
index 38ecd5a30346..cf02f75a806c 100644
--- a/editors/gnuserv-emacs20/Makefile
+++ b/editors/gnuserv-emacs20/Makefile
@@ -11,6 +11,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../gnuserv
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
.include "${MASTERDIR}/Makefile"
diff --git a/editors/gnuserv/Makefile b/editors/gnuserv/Makefile
index 23637f3ca6b2..eb1c44a3fd62 100644
--- a/editors/gnuserv/Makefile
+++ b/editors/gnuserv/Makefile
@@ -19,6 +19,7 @@ USE_REINPLACE= yes
BINSUFFIX?= -emacs
+USE_EMACS= yes
EMACS_PORT_NAME?=emacs21
.if defined(WITHOUT_X11)
diff --git a/editors/iiimecf/Makefile b/editors/iiimecf/Makefile
index 2eeff4d6ec01..36b17d645f13 100644
--- a/editors/iiimecf/Makefile
+++ b/editors/iiimecf/Makefile
@@ -18,6 +18,7 @@ COMMENT= Internet/Intranet Input Method Emacs Client Framework for GNU Emacs 20
BUILD_DEPENDS= ${UN_DEFINE}:${PORTSDIR}/converters/mule-ucs-emacs20
RUN_DEPENDS= ${UN_DEFINE}:${PORTSDIR}/converters/mule-ucs-emacs20
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
UN_DEFINE= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/mule-ucs/un-define.el
diff --git a/editors/mode-info/Makefile b/editors/mode-info/Makefile
index 9bc3190d3a75..666912efa0b4 100644
--- a/editors/mode-info/Makefile
+++ b/editors/mode-info/Makefile
@@ -43,6 +43,7 @@ PLIST_SUB+= MI_WITH_MAKE=""
PLIST_SUB+= MI_WITH_MAKE="@comment "
.endif
+USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
EMACS_NO_RUN_DEPENDS= yes
LISPDIR?= ${PREFIX}/${EMACS_SITE_LISPDIR}/${PORTNAME}
diff --git a/editors/nxml-emacs21/Makefile b/editors/nxml-emacs21/Makefile
index 9feaaae55b03..ed693cbfdf9b 100644
--- a/editors/nxml-emacs21/Makefile
+++ b/editors/nxml-emacs21/Makefile
@@ -16,6 +16,7 @@ COMMENT= A major mode for editing XML documents for emacs21
# distfile version
NXML_VER= 20041004
NXML_STARTUPEL= nxml-startup.el
+USE_EMACS= yes
EMACS_PORT_NAME=emacs21
INFO= nxml-mode
diff --git a/editors/nxml/Makefile b/editors/nxml/Makefile
index 9feaaae55b03..ed693cbfdf9b 100644
--- a/editors/nxml/Makefile
+++ b/editors/nxml/Makefile
@@ -16,6 +16,7 @@ COMMENT= A major mode for editing XML documents for emacs21
# distfile version
NXML_VER= 20041004
NXML_STARTUPEL= nxml-startup.el
+USE_EMACS= yes
EMACS_PORT_NAME=emacs21
INFO= nxml-mode
diff --git a/editors/psgml-emacs19/Makefile b/editors/psgml-emacs19/Makefile
index e9a65e0f47c4..a9b939160014 100644
--- a/editors/psgml-emacs19/Makefile
+++ b/editors/psgml-emacs19/Makefile
@@ -12,6 +12,7 @@ COMMENT= A major mode for editing SGML and XML documents for emacs19
MASTERDIR= ${.CURDIR}/../psgml
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs19
BUILD_DEPENDS+= makeinfo:${PORTSDIR}/print/texinfo
diff --git a/editors/psgml-emacs20/Makefile b/editors/psgml-emacs20/Makefile
index 21ee2d530f46..c5ff81e26a13 100644
--- a/editors/psgml-emacs20/Makefile
+++ b/editors/psgml-emacs20/Makefile
@@ -12,6 +12,7 @@ COMMENT= A major mode for editing SGML and XML documents for emacs20
MASTERDIR= ${.CURDIR}/../psgml
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
.include "${MASTERDIR}/Makefile"
diff --git a/editors/psgml-mule/Makefile b/editors/psgml-mule/Makefile
index a212a8c2b3bb..51b1b3f467a0 100644
--- a/editors/psgml-mule/Makefile
+++ b/editors/psgml-mule/Makefile
@@ -12,6 +12,7 @@ COMMENT= A major mode for editing SGML and XML documents for mule
MASTERDIR= ${.CURDIR}/../psgml
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= mule
BUILD_DEPENDS+= makeinfo:${PORTSDIR}/print/texinfo
diff --git a/editors/psgml/Makefile b/editors/psgml/Makefile
index 279bc72acaec..a592b0670526 100644
--- a/editors/psgml/Makefile
+++ b/editors/psgml/Makefile
@@ -30,6 +30,7 @@ PLIST_SUB= PSGML_STARTUPEL=${PSGML_STARTUPEL}
NOT_FOR_ARCHS= ia64
# This is a master port.
+USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
.if ${EMACS_PORT_NAME} == xemacs21-mule
diff --git a/editors/semi-emacs20/Makefile b/editors/semi-emacs20/Makefile
index d0185dea73e6..6554a51aeb92 100644
--- a/editors/semi-emacs20/Makefile
+++ b/editors/semi-emacs20/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/semi
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
.include "${MASTERDIR}/Makefile"
diff --git a/editors/semi-xemacs21-mule/Makefile b/editors/semi-xemacs21-mule/Makefile
index 4a40d910023b..12a5c6e179f0 100644
--- a/editors/semi-xemacs21-mule/Makefile
+++ b/editors/semi-xemacs21-mule/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/semi
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= xemacs21-mule
EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
diff --git a/editors/semi/Makefile b/editors/semi/Makefile
index 7a74418019fa..16ebe2539a18 100644
--- a/editors/semi/Makefile
+++ b/editors/semi/Makefile
@@ -30,6 +30,7 @@ SEMI_LISPDIR= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
SEMI_VERSION_SPECIFIC_LISPDIR= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
.if (${PORTCLASS} == "master")
+USE_EMACS= yes
EMACS_PORT_NAME= emacs21
DEPPORT_SUFFIX=
.else
diff --git a/editors/semi113-emacs19/Makefile b/editors/semi113-emacs19/Makefile
index e31820182694..58c52a7114c8 100644
--- a/editors/semi113-emacs19/Makefile
+++ b/editors/semi113-emacs19/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/semi113
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs19
.include "${MASTERDIR}/Makefile"
diff --git a/editors/semi113-emacs20/Makefile b/editors/semi113-emacs20/Makefile
index 74f0c0ee8283..a2e02c625997 100644
--- a/editors/semi113-emacs20/Makefile
+++ b/editors/semi113-emacs20/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/semi113
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
.include <${MASTERDIR}/Makefile>
diff --git a/editors/semi113-mule/Makefile b/editors/semi113-mule/Makefile
index 756356005d67..48b7877a8b41 100644
--- a/editors/semi113-mule/Makefile
+++ b/editors/semi113-mule/Makefile
@@ -14,6 +14,7 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/semi113
# emacs port setup
+USE_EMACS= yes
EMACS_PORT_NAME= mule
.include <${MASTERDIR}/Makefile>
diff --git a/editors/semi113/Makefile b/editors/semi113/Makefile
index dfa452e72c04..fc0bbd7759e9 100644
--- a/editors/semi113/Makefile
+++ b/editors/semi113/Makefile
@@ -35,6 +35,7 @@ SEMI_LISPDIR?= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
SEMI_VERSION_SPECIFIC_LISPDIR?= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
.if (${PORTCLASS} == "master")
+USE_EMACS= yes
EMACS_PORT_NAME= emacs21
DEPPORT_SUFFIX=
.else
diff --git a/editors/slime/Makefile b/editors/slime/Makefile
index 9416d721acba..eae2fd79bbb3 100644
--- a/editors/slime/Makefile
+++ b/editors/slime/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= dom@happygiraffe.net
COMMENT= Superior Lisp Interaction Mode for Emacs
USE_GMAKE= yes
+USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
INFO= slime
diff --git a/editors/speedbar-emacs20/Makefile b/editors/speedbar-emacs20/Makefile
index f48df7ca14ea..df3bcdb1ccea 100644
--- a/editors/speedbar-emacs20/Makefile
+++ b/editors/speedbar-emacs20/Makefile
@@ -7,6 +7,7 @@
MASTERDIR= ${.CURDIR}/../../editors/speedbar
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
.include "${MASTERDIR}/Makefile"
diff --git a/editors/speedbar/Makefile b/editors/speedbar/Makefile
index 3500abca2815..95b44dd62e75 100644
--- a/editors/speedbar/Makefile
+++ b/editors/speedbar/Makefile
@@ -18,6 +18,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/beta/}
MAINTAINER= dryice@dryice.name
COMMENT= Quick access to files and tags in an Emacs frame
+USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
USE_REINPLACE= yes
diff --git a/editors/tamago-emacs20/Makefile b/editors/tamago-emacs20/Makefile
index cb436ebbbc17..8134ec329412 100644
--- a/editors/tamago-emacs20/Makefile
+++ b/editors/tamago-emacs20/Makefile
@@ -9,6 +9,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The Multilingual Input Method - Egg V4 for Emacs20
MASTERDIR= ${.CURDIR}/../tamago
+
+USE_EMACS= yes
EMACS_PORT_NAME= emacs20
.include "${MASTERDIR}/Makefile"
diff --git a/editors/tamago-emacs21/Makefile b/editors/tamago-emacs21/Makefile
index abae26b70ab3..4faf10dbf533 100644
--- a/editors/tamago-emacs21/Makefile
+++ b/editors/tamago-emacs21/Makefile
@@ -25,6 +25,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
WRKSRC= ${WRKDIR}/egg-4.0.6+0.20041122cvs
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index abae26b70ab3..4faf10dbf533 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -25,6 +25,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
WRKSRC= ${WRKDIR}/egg-4.0.6+0.20041122cvs
diff --git a/editors/tree-widget/Makefile b/editors/tree-widget/Makefile
index 93ee77f5aa63..d6cf5301efa7 100644
--- a/editors/tree-widget/Makefile
+++ b/editors/tree-widget/Makefile
@@ -16,6 +16,7 @@ PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER= dryice@dryice.name
COMMENT= A tree widget for Emacs
+USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
.if ${EMACS_PORT_NAME} != "emacs21"