aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>2000-01-09 16:28:42 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>2000-01-09 16:28:42 +0000
commit16d317466b581ce6431d3a44c39736d72d196c4c (patch)
treed4b349be94847e785f89c1520a9f65018917ca4f /editors
parente00eb716de14ff610d50b9a64b8011638c0c2734 (diff)
downloadports-16d317466b581ce6431d3a44c39736d72d196c4c.tar.gz
ports-16d317466b581ce6431d3a44c39736d72d196c4c.zip
Install _pkg.el for xemacs(21.x or later) package version descriptor.
Notes
Notes: svn path=/head/; revision=24603
Diffstat (limited to 'editors')
-rw-r--r--editors/apel-emacs/Makefile12
-rw-r--r--editors/apel-emacs/files/_pkg.el4
-rw-r--r--editors/apel/Makefile12
-rw-r--r--editors/apel/files/_pkg.el4
4 files changed, 30 insertions, 2 deletions
diff --git a/editors/apel-emacs/Makefile b/editors/apel-emacs/Makefile
index b0089ea64ce4..692f92d2831e 100644
--- a/editors/apel-emacs/Makefile
+++ b/editors/apel-emacs/Makefile
@@ -39,7 +39,7 @@ ALL_TARGET?= elc
.if defined(EMACS_PORT)
PKGNAME= apel-${EMACS_PORT}-${APEL_VER}
-EMACS_CMD= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
+EMACS_CMD?= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
BUILD_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
.if defined(HAVE_COMMON_PORT) && (${HAVE_COMMON_PORT} == "YES")
RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}-common
@@ -82,6 +82,9 @@ pre-install:
.if defined(EMACS_PACKAGESDIR) && defined(EMACS_PACKAGES_SUBDIRS)
@${MAKE} mkdir-site-packages
.endif
+.if defined(EMACS_PACKAGESDIR) && defined(XEMACS_PKGNAME)
+ @${MAKE} pkg-el-install
+.endif
post-install:
.if defined(REQUIRE_SETUPEL) && (${REQUIRE_SETUPEL} == "YES")
@@ -104,6 +107,13 @@ mkdir-site-packages:
${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/$${i} ; \
done)
+pkg-el-install:
+ @(if [ -f ${FILESDIR}/_pkg.el ] ; then \
+ ${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME} ;\
+ ${INSTALL_DATA} ${FILESDIR}/_pkg.el \
+ ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME}/_pkg.el ;\
+ fi)
+
doc-install:
@${MKDIR} ${PREFIX}/${APELDOCDIR}
@(cd ${WRKSRC} ; \
diff --git a/editors/apel-emacs/files/_pkg.el b/editors/apel-emacs/files/_pkg.el
new file mode 100644
index 000000000000..d3d55387912f
--- /dev/null
+++ b/editors/apel-emacs/files/_pkg.el
@@ -0,0 +1,4 @@
+;;;###autoload
+(package-provide 'apel
+ :version 1.16
+ :type 'regular)
diff --git a/editors/apel/Makefile b/editors/apel/Makefile
index b0089ea64ce4..692f92d2831e 100644
--- a/editors/apel/Makefile
+++ b/editors/apel/Makefile
@@ -39,7 +39,7 @@ ALL_TARGET?= elc
.if defined(EMACS_PORT)
PKGNAME= apel-${EMACS_PORT}-${APEL_VER}
-EMACS_CMD= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
+EMACS_CMD?= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
BUILD_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
.if defined(HAVE_COMMON_PORT) && (${HAVE_COMMON_PORT} == "YES")
RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}-common
@@ -82,6 +82,9 @@ pre-install:
.if defined(EMACS_PACKAGESDIR) && defined(EMACS_PACKAGES_SUBDIRS)
@${MAKE} mkdir-site-packages
.endif
+.if defined(EMACS_PACKAGESDIR) && defined(XEMACS_PKGNAME)
+ @${MAKE} pkg-el-install
+.endif
post-install:
.if defined(REQUIRE_SETUPEL) && (${REQUIRE_SETUPEL} == "YES")
@@ -104,6 +107,13 @@ mkdir-site-packages:
${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/$${i} ; \
done)
+pkg-el-install:
+ @(if [ -f ${FILESDIR}/_pkg.el ] ; then \
+ ${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME} ;\
+ ${INSTALL_DATA} ${FILESDIR}/_pkg.el \
+ ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME}/_pkg.el ;\
+ fi)
+
doc-install:
@${MKDIR} ${PREFIX}/${APELDOCDIR}
@(cd ${WRKSRC} ; \
diff --git a/editors/apel/files/_pkg.el b/editors/apel/files/_pkg.el
new file mode 100644
index 000000000000..d3d55387912f
--- /dev/null
+++ b/editors/apel/files/_pkg.el
@@ -0,0 +1,4 @@
+;;;###autoload
+(package-provide 'apel
+ :version 1.16
+ :type 'regular)