aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>2000-01-08 16:36:44 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>2000-01-08 16:36:44 +0000
commitab685b2a17beee636a4eb62e01feea4783d3e180 (patch)
tree75a2d701806b170e813e2ee4e0ae9aad402513cb /editors
parentfdeab087318efec90d3006d2bc9544f79fcbee71 (diff)
downloadports-ab685b2a17beee636a4eb62e01feea4783d3e180.tar.gz
ports-ab685b2a17beee636a4eb62e01feea4783d3e180.zip
Fix unfetchable problem.
Import "custom-1.9962.patch" in patches directory, because there is no this patch's PATCH_SITES. NOTE: This patch is too short. Including it in the ports tree is no problem. :)
Notes
Notes: svn path=/head/; revision=24555
Diffstat (limited to 'editors')
-rw-r--r--editors/custom-mule/Makefile5
-rw-r--r--editors/custom-mule/files/patch-aa11
2 files changed, 12 insertions, 4 deletions
diff --git a/editors/custom-mule/Makefile b/editors/custom-mule/Makefile
index 963ee3bb8a0d..caaeb2c6eb82 100644
--- a/editors/custom-mule/Makefile
+++ b/editors/custom-mule/Makefile
@@ -8,10 +8,6 @@
MAINTAINER= shige@FreeBSD.org
-PATCHFILES= custom-1.9962.patch
-PATCH_SITES= ftp://ftp.jpl.org/pub/elisp/semi-gnus-mule23@1934/
-PATCH_DIST_STRIP= -p1
-
# This is a slave port.
PORTCLASS= slave
@@ -26,6 +22,7 @@ HAVE_COMMON_PORT= YES
# pkg/* files but PLIST are used in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
+PATCHDIR= ${.CURDIR}/patches
PLIST= ${MASTERDIR}/pkg/PLIST
.include <${MASTERDIR}/Makefile>
diff --git a/editors/custom-mule/files/patch-aa b/editors/custom-mule/files/patch-aa
new file mode 100644
index 000000000000..f82989c491dc
--- /dev/null
+++ b/editors/custom-mule/files/patch-aa
@@ -0,0 +1,11 @@
+--- cus-face.el.orig Wed Mar 4 19:52:39 1998
++++ cus-face.el Mon Mar 9 08:05:33 1998
+@@ -96,7 +96,7 @@
+ "Define a new FACE on all frames, ignoring X resources."
+ (interactive "SMake face: ")
+ (or (internal-find-face name)
+- (let ((face (make-vector 8 nil)))
++ (let ((face (make-vector face-vector-length nil)))
+ (aset face 0 'face)
+ (aset face 1 name)
+ (let* ((frames (frame-list))