aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2012-09-25 06:48:07 +0000
committerMaho Nakata <maho@FreeBSD.org>2012-09-25 06:48:07 +0000
commit84601ad2c418dbeb2c86cc9ca4dac514d742d8d9 (patch)
tree571516ebc80422520538c0d8c2020f27f3e9f4bf /editors
parent3993ba2769a4e66cfe35265646c96e316c19910e (diff)
downloadports-84601ad2c418dbeb2c86cc9ca4dac514d742d8d9.tar.gz
ports-84601ad2c418dbeb2c86cc9ca4dac514d742d8d9.zip
Allow openjdk7 build.
Submitted by: Jan Henrik Sylvester <me@janh.de>
Notes
Notes: svn path=/head/; revision=304815
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3/Makefile2
-rw-r--r--editors/openoffice-3/files/patch-jdk7-hsqldb-debian282
-rw-r--r--editors/openoffice-3/files/patch-jdk7-hsqldb-debian-x12
-rw-r--r--editors/openoffice-3/files/patch-jdk7-httpclient-apache-pfg145
-rw-r--r--editors/openoffice-3/files/patch-jdk7-httpclient-r135896713
-rw-r--r--editors/openoffice-3/files/patch-jdk7-httpclient-r135968117
6 files changed, 470 insertions, 1 deletions
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 29daa94614ef..357b2bc41512 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -44,7 +44,7 @@ GNOMEVFS_DESC= Enable GNOME Virtual File System
USE_JAVA= yes
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava openjdk
-JAVA_VERSION= 1.5 1.6
+JAVA_VERSION= 1.5 1.6 1.7
.if !defined(WITHOUT_GCONF)
USE_GNOME+= gconf2
diff --git a/editors/openoffice-3/files/patch-jdk7-hsqldb-debian b/editors/openoffice-3/files/patch-jdk7-hsqldb-debian
new file mode 100644
index 000000000000..b42d966286fb
--- /dev/null
+++ b/editors/openoffice-3/files/patch-jdk7-hsqldb-debian
@@ -0,0 +1,282 @@
+--- codemaker/source/javamaker/classfile.cxx
++++ codemaker/source/javamaker/classfile.cxx
+@@ -693,7 +693,7 @@ void ClassFile::addMethod(
+ void ClassFile::write(FileStream & file) const {
+ writeU4(file, 0xCAFEBABE);
+ writeU2(file, 0);
+- writeU2(file, 46);
++ writeU2(file, 49); // class file version of JRE 1.5
+ writeU2(file, m_constantPoolCount);
+ writeStream(file, m_constantPool);
+ writeU2(file, static_cast< sal_uInt16 >(m_accessFlags));
+--
+--- hsqldb/patches/jdbc-4.1.patch
++++ hsqldb/patches/jdbc-4.1.patch
+@@ -0,0 +1,267 @@
++--- misc/hsqldb/build/build.xml 2012-02-08 15:14:42.827123541 +0000
+++++ misc/build/hsqldb/build/build.xml 2012-02-08 15:21:43.827722388 +0000
++@@ -98,7 +98,11 @@
++ <echo message="ant.java.hasjsse=${ant.java.hasjsse}" />
++ </target>
++
++- <target name="javaversion6">
+++ <target name="javaversion7">
+++ <available classname="java.util.Objects" property="ant.java.iscjava17"/>
+++ </target>
+++
+++ <target name="javaversion6" depends="javaversion7" unless="ant.java.iscjava17">
++ <available classname="java.net.IDN" property="ant.java.iscjava16"/>
++ </target>
++
++@@ -210,6 +214,7 @@
++ <arg value="+JAVA2FULL"/>
++ <arg value="-JAVA4"/>
++ <arg value="-JAVA6"/>
+++ <arg value="-JAVA7"/>
++ </java>
++ </target>
++
++@@ -244,6 +249,7 @@
++ <arg value="+JAVA2FULL"/>
++ <arg value="+JAVA4"/>
++ <arg value="-JAVA6"/>
+++ <arg value="-JAVA7"/>
++ </java>
++ </target>
++
++@@ -279,10 +285,47 @@
++ <arg value="+JAVA2FULL"/>
++ <arg value="+JAVA4"/>
++ <arg value="+JAVA6"/>
+++ <arg value="+JAVA7"/>
+++ </java>
+++ </target>
+++
+++ <target name="switchtojdk17" depends="switchtojdk16"
+++ description="self explanatory" if="ant.java.iscjava17">
+++ <java classname="org.hsqldb.util.CodeSwitcher" classpath="classes" >
+++ <arg file="${src}/org/hsqldb/lib/java/JavaSystem.java"/>
+++ <arg file="${src}/org/hsqldb/lib/HsqlTimer.java"/>
+++ <arg file="${src}/org/hsqldb/jdbcDriver.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcBlob.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcDatabaseMetaData.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcDataSource.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcCallableStatement.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcClob.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcConnection.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcParameterMetaData.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcPreparedStatement.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcResultSet.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcResultSetMetaData.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcStatement.java"/>
+++ <arg file="${src}/org/hsqldb/persist/LockFile.java"/>
+++ <arg file="${src}/org/hsqldb/persist/Logger.java"/>
+++ <arg file="${src}/org/hsqldb/persist/ScaledRAFile.java"/>
+++ <arg file="${src}/org/hsqldb/rowio/RowInputTextLog.java"/>
+++ <arg file="${src}/org/hsqldb/util/DatabaseManager.java"/>
+++ <arg file="${src}/org/hsqldb/util/ConnectionDialogCommon.java"/>
+++ <arg file="${src}/org/hsqldb/lib/SimpleLog.java"/>
+++ <arg file="${src}/org/hsqldb/rowio/RowInputTextLog.java"/>
+++ <arg file="${src}/org/hsqldb/lib/SimpleLog.java"/>
+++ <arg file="${src}/org/hsqldb/rowio/RowInputTextLog.java"/>
+++ <arg file="${src}/org/hsqldb/HsqlDateTime.java"/>
+++ <arg value="+JAVA2"/>
+++ <arg value="+JAVA2FULL"/>
+++ <arg value="+JAVA4"/>
+++ <arg value="+JAVA6"/>
+++ <arg value="+JAVA7"/>
++ </java>
++ </target>
++
++- <target name="store" depends="switchtojdk16"
+++ <target name="store" depends="switchtojdk17"
++ description="compiles the /store folder">
++ <javac srcdir="${src}"
++ destdir="classes"
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcCallableStatement.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcCallableStatement.java 2012-02-08 15:47:35.842635642 +0000
++@@ -3375,4 +3375,18 @@
++ }
++
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++ public <T> T getObject(String columnLabel, Class<T> type) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public <T> T getObject(int ColumnIndex, Class<T> type) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++
+++//#endif JAVA7
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcConnection.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcConnection.java 2012-02-08 15:47:35.851635628 +0000
++@@ -48,6 +48,12 @@
++ import java.sql.SQLXML;
++
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++import java.util.concurrent.Executor;
+++
+++//#endif JAVA7
+++
++ import java.sql.PreparedStatement;
++ import java.sql.SQLException;
++ import java.sql.SQLWarning;
++@@ -2793,4 +2799,31 @@
++ }
++
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++ public int getNetworkTimeout() throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public void setNetworkTimeout(Executor executor, int millis) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public void abort(Executor executor) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public String getSchema() throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public void setSchema(String schema) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++//#endif JAVA7
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcDatabaseMetaData.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcDatabaseMetaData.java 2012-02-08 15:47:35.835635654 +0000
++@@ -5693,4 +5693,21 @@
++ }
++
++ //#endif JAVA6
+++
+++
+++//#ifdef JAVA7
+++ public boolean generatedKeyAlwaysReturned() throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public ResultSet getPseudoColumns(String catalog, String schemaPattern,
+++ String tableNamePattern, String columnNamePattern) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++
+++//#endif JAVA7
+++
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcDataSource.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcDataSource.java 2012-02-08 15:47:35.836635653 +0000
++@@ -47,6 +47,11 @@
++ //#endif JAVA4
++ import org.hsqldb.jdbcDriver;
++
+++//#ifdef JAVA7
+++import java.sql.SQLFeatureNotSupportedException;
+++import java.util.logging.Logger;
+++//#endif JAVA7
+++
++ // boucherb@users 20040411 - doc 1.7.2 - javadoc updates toward 1.7.2 final
++
++ /**
++@@ -323,4 +328,12 @@
++ }
++
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++ public Logger getParentLogger() throws SQLFeatureNotSupportedException
+++ {
+++ throw new SQLFeatureNotSupportedException("Not supported yet.");
+++ }
+++
+++//#endif JAVA7
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcResultSet.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcResultSet.java 2012-02-08 15:47:35.866635606 +0000
++@@ -5324,4 +5324,19 @@
++ }
++
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++
+++ public <T> T getObject(String columnLabel, Class<T> type) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public <T> T getObject(int columnNum, Class<T> type) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++//#endif JAVA7
+++
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcStatement.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcStatement.java 2012-02-08 15:47:35.872635595 +0000
++@@ -1608,4 +1608,16 @@
++ throw new UnsupportedOperationException("Not supported yet.");
++ }
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++ public boolean isCloseOnCompletion() throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public void closeOnCompletion() throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++//#endif JAVA7
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbcDriver.java 2012-02-08 15:14:42.800123566 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbcDriver.java 2012-02-08 15:47:35.826635667 +0000
++@@ -42,6 +42,11 @@
++ import org.hsqldb.persist.HsqlDatabaseProperties;
++ import org.hsqldb.persist.HsqlProperties;
++
+++//#ifdef JAVA7
+++import java.sql.SQLFeatureNotSupportedException;
+++import java.util.logging.Logger;
+++//#endif JAVA7
+++
++ // fredt@users 20011220 - patch 1.7.0 by fredt
++ // new version numbering scheme
++ // fredt@users 20020320 - patch 1.7.0 - JDBC 2 support and error trapping
++@@ -321,4 +326,12 @@
++ DriverManager.registerDriver(new jdbcDriver());
++ } catch (Exception e) {}
++ }
+++
+++//#ifdef JAVA7
+++ public Logger getParentLogger() throws SQLFeatureNotSupportedException
+++ {
+++ throw new SQLFeatureNotSupportedException("Not supported yet.");
+++ }
+++
+++//#endif JAVA7
++ }
diff --git a/editors/openoffice-3/files/patch-jdk7-hsqldb-debian-x b/editors/openoffice-3/files/patch-jdk7-hsqldb-debian-x
new file mode 100644
index 000000000000..0b3ead629058
--- /dev/null
+++ b/editors/openoffice-3/files/patch-jdk7-hsqldb-debian-x
@@ -0,0 +1,12 @@
+--- hsqldb/makefile.mk.orig 2012-02-17 08:46:16.000000000 +0000
++++ hsqldb/makefile.mk 2012-09-15 18:00:27.000000000 +0000
+@@ -52,7 +52,8 @@
+ PATCH_FILES=patches$/i96823.patch \
+ patches$/i97032.patch \
+ patches$/i103528.patch \
+- patches$/i104901.patch
++ patches$/i104901.patch \
++ patches$/jdbc-4.1.patch
+
+ .IF "$(JAVACISGCJ)"=="yes"
+ JAVA_HOME=
diff --git a/editors/openoffice-3/files/patch-jdk7-httpclient-apache-pfg b/editors/openoffice-3/files/patch-jdk7-httpclient-apache-pfg
new file mode 100644
index 000000000000..570e3efd30ba
--- /dev/null
+++ b/editors/openoffice-3/files/patch-jdk7-httpclient-apache-pfg
@@ -0,0 +1,145 @@
+--- apache-commons/patches/httpclient.patch.orig 2012-09-15 20:01:46.000000000 +0000
++++ apache-commons/patches/httpclient.patch 2012-09-15 21:26:34.000000000 +0000
+@@ -0,0 +1,142 @@
++diff -ru misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/ConnectMethod.java misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/ConnectMethod.java
++--- misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/ConnectMethod.java 2012-05-07 12:34:01.000000000 -0500
+++++ misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/ConnectMethod.java 2012-05-07 12:37:50.000000000 -0500
++@@ -38,7 +38,7 @@
++ /**
++ * Establishes a tunneled HTTP connection via the CONNECT method.
++ *
++- * @author Ortwin Gl???ck
+++ * @author Ortwin Glueck
++ * @author dIon Gillard
++ * @author <a href="mailto:mbowler@GargoyleSoftware.com">Mike Bowler</a>
++ * @author <a href="mailto:oleg@ural.ru">Oleg Kalnichevski</a>
++diff -ru misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/HttpClient.java misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/HttpClient.java
++--- misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/HttpClient.java 2012-05-07 12:34:01.000000000 -0500
+++++ misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/HttpClient.java 2012-05-07 12:37:50.000000000 -0500
++@@ -48,7 +48,7 @@
++ * @author <a href="mailto:rwaldhoff@apache.org">Rodney Waldhoff</a>
++ * @author Sean C. Sullivan
++ * @author <a href="mailto:dion@apache.org">dIon Gillard</a>
++- * @author Ortwin Gl?ck
+++ * @author Ortwin Glueck
++ * @author <a href="mailto:becke@u.washington.edu">Michael Becke</a>
++ * @author <a href="mailto:mbowler@GargoyleSoftware.com">Mike Bowler</a>
++ * @author Sam Maloney
++diff -ru misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/HttpClientError.java misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/HttpClientError.java
++--- misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/HttpClientError.java 2012-05-07 12:34:01.000000000 -0500
+++++ misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/HttpClientError.java 2012-05-07 12:37:50.000000000 -0500
++@@ -33,7 +33,7 @@
++ /**
++ * Signals that an error has occurred.
++ *
++- * @author Ortwin Gl?ck
+++ * @author Ortwin Glueck
++ * @version $Revision: 480424 $ $Date: 2006-11-29 06:56:49 +0100 (Wed, 29 Nov 2006) $
++ * @since 3.0
++ */
++diff -ru misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/HttpContentTooLargeException.java misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/HttpContentTooLargeException.java
++--- misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/HttpContentTooLargeException.java 2012-05-07 12:34:01.000000000 -0500
+++++ misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/HttpContentTooLargeException.java 2012-05-07 12:37:50.000000000 -0500
++@@ -3,7 +3,7 @@
++ /**
++ * Signals that the response content was larger than anticipated.
++ *
++- * @author Ortwin Glück
+++ * @author Ortwin Glueck
++ */
++ public class HttpContentTooLargeException extends HttpException {
++ private int maxlen;
++diff -ru misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/WireLogInputStream.java misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/WireLogInputStream.java
++--- misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/WireLogInputStream.java 2012-05-07 12:34:01.000000000 -0500
+++++ misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/WireLogInputStream.java 2012-05-07 12:37:50.000000000 -0500
++@@ -37,7 +37,7 @@
++ /**
++ * Logs all data read to the wire LOG.
++ *
++- * @author Ortwin Gl�ck
+++ * @author Ortwin Glueck
++ * @author <a href="mailto:mbowler@GargoyleSoftware.com">Mike Bowler</a>
++ * @author <a href="mailto:oleg@ural.ru">Oleg Kalnichevski</a>
++ *
++diff -ru misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/auth/BasicScheme.java misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/auth/BasicScheme.java
++--- misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/auth/BasicScheme.java 2012-05-07 12:34:01.000000000 -0500
+++++ misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/auth/BasicScheme.java 2012-05-07 12:37:50.000000000 -0500
++@@ -46,7 +46,7 @@
++ * @author <a href="mailto:remm@apache.org">Remy Maucherat</a>
++ * @author Rodney Waldhoff
++ * @author <a href="mailto:jsdever@apache.org">Jeff Dever</a>
++- * @author Ortwin Gl?ck
+++ * @author Ortwin Glueck
++ * @author Sean C. Sullivan
++ * @author <a href="mailto:adrian@ephox.com">Adrian Sutton</a>
++ * @author <a href="mailto:mbowler@GargoyleSoftware.com">Mike Bowler</a>
++diff -ru misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/auth/DigestScheme.java misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/auth/DigestScheme.java
++--- misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/auth/DigestScheme.java 2012-05-07 12:34:01.000000000 -0500
+++++ misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/auth/DigestScheme.java 2012-05-07 12:37:50.000000000 -0500
++@@ -67,7 +67,7 @@
++ * @author <a href="mailto:remm@apache.org">Remy Maucherat</a>
++ * @author Rodney Waldhoff
++ * @author <a href="mailto:jsdever@apache.org">Jeff Dever</a>
++- * @author Ortwin Gl?ck
+++ * @author Ortwin Glueck
++ * @author Sean C. Sullivan
++ * @author <a href="mailto:adrian@ephox.com">Adrian Sutton</a>
++ * @author <a href="mailto:mbowler@GargoyleSoftware.com">Mike Bowler</a>
++diff -ru misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/auth/HttpAuthenticator.java misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/auth/HttpAuthenticator.java
++--- misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/auth/HttpAuthenticator.java 2012-05-07 12:34:01.000000000 -0500
+++++ misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/auth/HttpAuthenticator.java 2012-05-07 12:37:50.000000000 -0500
++@@ -62,7 +62,7 @@
++ * @author <a href="mailto:remm@apache.org">Remy Maucherat</a>
++ * @author Rodney Waldhoff
++ * @author <a href="mailto:jsdever@apache.org">Jeff Dever</a>
++- * @author Ortwin Gl�ck
+++ * @author Ortwin Glueck
++ * @author Sean C. Sullivan
++ * @author <a href="mailto:adrian@ephox.com">Adrian Sutton</a>
++ * @author <a href="mailto:mbowler@GargoyleSoftware.com">Mike Bowler</a>
++diff -ru misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/auth/NTLMScheme.java misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/auth/NTLMScheme.java
++--- misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/auth/NTLMScheme.java 2012-05-07 12:34:01.000000000 -0500
+++++ misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/auth/NTLMScheme.java 2012-05-07 12:37:50.000000000 -0500
++@@ -43,7 +43,7 @@
++ * @author <a href="mailto:remm@apache.org">Remy Maucherat</a>
++ * @author Rodney Waldhoff
++ * @author <a href="mailto:jsdever@apache.org">Jeff Dever</a>
++- * @author Ortwin Gl???ck
+++ * @author Ortwin Glueck
++ * @author Sean C. Sullivan
++ * @author <a href="mailto:adrian@ephox.com">Adrian Sutton</a>
++ * @author <a href="mailto:mbowler@GargoyleSoftware.com">Mike Bowler</a>
++diff -ru misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/methods/PostMethod.java misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/methods/PostMethod.java
++--- misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient.orig/methods/PostMethod.java 2012-05-07 12:34:01.000000000 -0500
+++++ misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/methods/PostMethod.java 2012-05-07 12:37:50.000000000 -0500
++@@ -62,7 +62,7 @@
++ * @author <a href="mailto:remm@apache.org">Remy Maucherat</a>
++ * @author <a href="mailto:dsale@us.britannica.com">Doug Sale</a>
++ * @author <a href="mailto:jsdever@apache.org">Jeff Dever</a>
++- * @author Ortwin Gl???ck
+++ * @author Ortwin Glueck
++ * @author <a href="mailto:mbowler@GargoyleSoftware.com">Mike Bowler</a>
++ * @author <a href="mailto:oleg@ural.ru">Oleg Kalnichevski</a>
++ *
++--- misc/build/commons-httpclient-3.1/src/examples/TrivialApp.java 2007-08-18 09:02:14.000000000 +0000
+++++ misc/build/commons-httpclient-3.1/src/examples/TrivialApp.java 2012-09-15 21:21:52.000000000 +0000
++@@ -47,7 +47,7 @@
++ * how to use the Jakarta HttpClient API.
++ *
++ * @author <a href="mailto:jsdever@apache.org">Jeff Dever</a>
++- * @author Ortwin Glück
+++ * @author Ortwin Glueck
++ */
++ public class TrivialApp
++ {
++--- misc/build/commons-httpclient-3.1/src/examples/ClientApp.java 2007-08-18 09:02:14.000000000 +0000
+++++ misc/build/commons-httpclient-3.1/src/examples/ClientApp.java 2012-09-15 21:22:11.000000000 +0000
++@@ -61,7 +61,7 @@
++ * content as text and as rendered HTML.
++ *
++ * @author Sean C. Sullivan
++- * @author Ortwin Glück
+++ * @author Ortwin Glueck
++ * @author Michael Becke
++ */
++ public class ClientApp {
diff --git a/editors/openoffice-3/files/patch-jdk7-httpclient-r1358967 b/editors/openoffice-3/files/patch-jdk7-httpclient-r1358967
new file mode 100644
index 000000000000..c1e4211439ab
--- /dev/null
+++ b/editors/openoffice-3/files/patch-jdk7-httpclient-r1358967
@@ -0,0 +1,13 @@
+--- apache-commons/java/httpclient/makefile.mk 2012-01-16 09:13:38.000000000 +0000
++++ apache-commons/java/httpclient/makefile.mk 2012-09-15 19:45:11.000000000 +0000
+@@ -45,7 +45,9 @@
+
+ TARFILE_ROOTDIR=commons-httpclient-3.1
+
+-#PATCH_FILES=$(PRJ)$/patches$/httpclient.patch
++PATCH_FILES= \
++ $(PRJ)$/patches$/httpclient.patch \
++ $(PRJ)$/patches$/httpclient_no_javadoc.patch
+
+ #CONVERTFILES=build.xml
+
diff --git a/editors/openoffice-3/files/patch-jdk7-httpclient-r1359681 b/editors/openoffice-3/files/patch-jdk7-httpclient-r1359681
new file mode 100644
index 000000000000..7cca30900098
--- /dev/null
+++ b/editors/openoffice-3/files/patch-jdk7-httpclient-r1359681
@@ -0,0 +1,17 @@
+--- apache-commons/patches/httpclient_no_javadoc.patch (added)
++++ apache-commons/patches/httpclient_no_javadoc.patch Tue Jul 10 14:06:59 2012
+@@ -0,0 +1,11 @@
++--- misc/commons-httpclient-3.1/build.xml 2007-08-18 11:02:14.000000000 +0200
+++++ misc/build/commons-httpclient-3.1/build.xml 2012-07-09 09:59:21.364830700 +0200
++@@ -142,7 +142,7 @@
++
++ <!-- ========== Targets: "External" Targets =============================== -->
++
++- <target name="dist" depends="compile,doc"
+++ <target name="dist" depends="compile"
++ description="Create binary distribution">
++ <mkdir dir="${dist.home}"/>
++ <copy file="LICENSE.txt" todir="${dist.home}"/>
+
+
+