aboutsummaryrefslogtreecommitdiff
path: root/emulators/adamem
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2014-04-11 12:51:21 +0000
committerAlex Kozlov <ak@FreeBSD.org>2014-04-11 12:51:21 +0000
commitaf5bcc59077a4ffede0a7da2e6dc10686be6df39 (patch)
tree92062bc41f9b9492ea360cf13307cddf3198a64f /emulators/adamem
parentee06ae79899b56efe6aef734157256bf76b6b1e5 (diff)
downloadports-af5bcc59077a4ffede0a7da2e6dc10686be6df39.tar.gz
ports-af5bcc59077a4ffede0a7da2e6dc10686be6df39.zip
- Fix plist and build on i386
Notes
Notes: svn path=/head/; revision=350938
Diffstat (limited to 'emulators/adamem')
-rw-r--r--emulators/adamem/files/patch-Z80IO.h14
-rw-r--r--emulators/adamem/pkg-plist1
2 files changed, 15 insertions, 0 deletions
diff --git a/emulators/adamem/files/patch-Z80IO.h b/emulators/adamem/files/patch-Z80IO.h
index 789d76abf0e1..f5cd2495b369 100644
--- a/emulators/adamem/files/patch-Z80IO.h
+++ b/emulators/adamem/files/patch-Z80IO.h
@@ -7,3 +7,17 @@ Index: Z80IO.h
#ifdef __GNUC__
#define FASTCALL __attribute__ ((regparm(3)))
+@@ -36,11 +35,11 @@
+ /***************************************************************************/
+ /* Read a byte from given memory location */
+ /***************************************************************************/
+- unsigned Z80_RDMEM(dword a) FASTCALL;
++ unsigned Z80_RDMEM(dword a);
+ /***************************************************************************/
+ /* Write a byte to given memory location */
+ /***************************************************************************/
+- void Z80_WRMEM(dword a,byte v) FASTCALL;
++ void Z80_WRMEM(dword a,byte v);
+ #else
+ extern byte *AddrTabl[256];
+ extern byte *WriteAddrTabl[256];
diff --git a/emulators/adamem/pkg-plist b/emulators/adamem/pkg-plist
index 6e1372153c5e..6ddf766466c0 100644
--- a/emulators/adamem/pkg-plist
+++ b/emulators/adamem/pkg-plist
@@ -6,3 +6,4 @@ bin/cvem
%%DATADIR%%/EOS.rom
%%PORTDOCS%%%%DOCSDIR%%/adamem.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%