aboutsummaryrefslogtreecommitdiff
path: root/emulators/atari800
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-05 06:36:21 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-05 06:36:21 +0000
commit1f3a52cc74eba21bdc0479993d9bee833437a087 (patch)
tree621bff98ddb16584468c8eccb3c605d61078303e /emulators/atari800
parent9792a9c3c311981a40ae25df54c0e8d8ab449dd2 (diff)
downloadports-1f3a52cc74eba21bdc0479993d9bee833437a087.tar.gz
ports-1f3a52cc74eba21bdc0479993d9bee833437a087.zip
Update to 1.2.2
PR: 33562 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=52593
Diffstat (limited to 'emulators/atari800')
-rw-r--r--emulators/atari800/Makefile58
-rw-r--r--emulators/atari800/distinfo2
-rw-r--r--emulators/atari800/files/config.h4
-rw-r--r--emulators/atari800/files/patch-aa44
-rw-r--r--emulators/atari800/pkg-descr2
-rw-r--r--emulators/atari800/pkg-plist1
6 files changed, 29 insertions, 82 deletions
diff --git a/emulators/atari800/Makefile b/emulators/atari800/Makefile
index 196110323de7..c7265931c32a 100644
--- a/emulators/atari800/Makefile
+++ b/emulators/atari800/Makefile
@@ -6,60 +6,56 @@
#
PORTNAME= atari800
-PORTVERSION= 1.0.7
+PORTVERSION= 1.2.2
CATEGORIES= emulators
-MASTER_SITES= ftp://ftp.sophics.cz/pub/Atari800/src/ \
- http://joy.sophics.cz/www/
-DISTFILES= a800s${PORTVERSION:S/.//g}.zip xf25.zip
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} xf25.zip
DIST_SUBDIR= ${PORTNAME}
-EXTRACT_ONLY= a800s${PORTVERSION:S/.//g}.zip
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
RESTRICTED= "xf25 contains copyright ROMs and cannot be distributed."
NO_PACKAGE= ${RESTRICTED}
-WRKSRC= ${WRKDIR}/Atari800-${PORTVERSION}/src
-USE_ZIP= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
USE_XLIB= yes
USE_GMAKE= yes
-
-.if defined(WITH_SHM)
-ALL_TARGET= x11-shm
-.else
-ALL_TARGET= x11
-.endif
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --target=x11
MAN1= atari800.1
-ATARI_LIB= ${PREFIX}/share/${PKGBASE}
ATARI_XF= ataribas.rom atariosb.rom atarixl.rom demos1.xfd \
demos2.xfd dos25.xfd mydos45d.atr
-ATARI_DOC= ${PREFIX}/share/doc/${PKGBASE}
-DOC_FILES= BUGS CHANGES CREDITS FAQ INSTALL README TODO USAGE
post-extract:
- @unzip -q -L -o ${_DISTDIR}/xf25.zip ${ATARI_XF} -d ${WRKSRC}
+ @unzip -q -L -o ${DISTDIR}/${DIST_SUBDIR}/xf25.zip ${ATARI_XF} -d ${WRKSRC}
post-patch:
- @${LN} -sf Makefile.unix ${WRKSRC}/Makefile
- @${CP} ${FILESDIR}/config.h ${WRKSRC}
- @${TOUCH} ${WRKSRC}/.atari800
- @${SED} -e 's:GUMBY:${ATARI_LIB}:g' \
- ${FILESDIR}/atari800.cfg > ${WRKSRC}/atari800.cfg
-
-post-install:
- @${MKDIR} ${ATARI_LIB}
- ${INSTALL_DATA} -m 664 ${WRKSRC}/atari800.cfg ${ATARI_LIB}
+ @${CP} ${FILESDIR}/atari800.cfg ${WRKSRC}
+ @${PERL} -pi -e 's|GUMBY|${DATADIR}|g' ${WRKSRC}/atari800.cfg
+ @${PERL} -pi -e 's|/etc|${DATADIR}|g' ${WRKSRC}/rt-config.c
+ @${PERL} -pi -e 's|tmpnam|mkstemp|g' ${WRKSRC}/devices.c \
+ ${WRKSRC}/compfile.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/atari800 ${PREFIX}/bin/atari800
+ @${INSTALL_MAN} ${WRKSRC}/atari800.man ${MANPREFIX}/man/man1/atari800.1
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} -m 644 ${WRKSRC}/atari800.cfg ${DATADIR}
.for file in ${ATARI_XF}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${ATARI_LIB}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DATADIR}
.endfor
.if !defined(NOPORTDOCS)
- @${MKDIR} ${ATARI_DOC}
-.for file in ${DOC_FILES}
- ${INSTALL_DATA} ${WRKSRC}/../DOC/${file} ${ATARI_DOC}
+ @${MKDIR} ${DOCSDIR}
+.for file in BUGS CHANGES CREDITS FAQ INSTALL README TODO USAGE
+ @${INSTALL_DATA} ${WRKSRC}/../DOC/${file} ${DOCSDIR}
.endfor
- ${INSTALL_DATA} ${DESCR} ${ATARI_DOC}/README.FreeBSD
.endif
.include <bsd.port.mk>
diff --git a/emulators/atari800/distinfo b/emulators/atari800/distinfo
index c901147992ea..00953b4508d5 100644
--- a/emulators/atari800/distinfo
+++ b/emulators/atari800/distinfo
@@ -1,2 +1,2 @@
-MD5 (atari800/a800s107.zip) = 83dd41e8f2e90737627ac0c9484bd621
+MD5 (atari800/atari800-1.2.2.tar.gz) = 8e44b40722b4711af7affb135a13960f
MD5 (atari800/xf25.zip) = 4dc3b6b4313e9596c4d474785a37b94d
diff --git a/emulators/atari800/files/config.h b/emulators/atari800/files/config.h
deleted file mode 100644
index 1c4f7ecbc5b9..000000000000
--- a/emulators/atari800/files/config.h
+++ /dev/null
@@ -1,4 +0,0 @@
-#ifndef __CONFIG__
-#define __CONFIG__
-#define UNALIGNED_LONG_OK
-#endif
diff --git a/emulators/atari800/files/patch-aa b/emulators/atari800/files/patch-aa
deleted file mode 100644
index afce41daf337..000000000000
--- a/emulators/atari800/files/patch-aa
+++ /dev/null
@@ -1,44 +0,0 @@
---- Makefile.unix.orig Wed Apr 4 07:35:36 2001
-+++ Makefile.unix Wed May 23 23:29:50 2001
-@@ -1,11 +1,11 @@
- # $Id: Makefile.unix,v 1.5 2001/04/04 05:35:36 knik Exp $
-
--CC = gcc
-+CC ?= gcc
- EXE=
--CFLAGS = -O2 -Wall
--DEFS =
-+CFLAGS ?= -O2 -Wall
-+DEFS = -DDEFAULT_CFG_PATH=\\"\"${PREFIX}/share/atari800/atari800.cfg\\"\"
-
--PREFIX = /usr/local
-+PREFIX ?= /usr/local
- BIN_PATH = ${PREFIX}/bin
- LIB_PATH = ${PREFIX}/lib
- MAN_PATH = ${PREFIX}/man
-@@ -72,13 +72,13 @@
-
- x11:
- $(MAKE) $(TARGET) DEFS="$(DEFS) -DX11" OBJ="$(OBJ) $(XOBJ)" \
-- INCLUDE="$(INCLUDE) -I/usr/X11R6/include" \
-- LIBS="-L/usr/X11/lib -L/usr/X11R6/lib $(LIBS) -lX11"
-+ INCLUDE="$(INCLUDE) -I${X11BASE}/include" \
-+ LIBS="-L${X11BASE}/lib $(LIBS) -lX11"
-
- x11-shm:
- $(MAKE) $(TARGET) DEFS="$(DEFS) -DX11 -DSHM" OBJ="$(OBJ) $(XOBJ)" \
-- INCLUDE="$(INCLUDE) -I/usr/X11R6/include" \
-- LIBS="-L/usr/X11/lib -L/usr/X11R6/lib $(LIBS) -lX11 -lXext"
-+ INCLUDE="$(INCLUDE) -I${X11BASE}/include" \
-+ LIBS="-L${X11BASE}/lib $(LIBS) -lX11 -lXext"
-
- hp9000-ansic-x11:
- $(MAKE) $(TARGET) \
-@@ -113,5 +113,5 @@
- chmod 4755 ${BIN_PATH}/$(TARGET)
-
- install :
-- cp atari800 ${BIN_PATH}/$(TARGET)
-- cp atari800.man ${MAN_PATH}/man1/atari800.1
-+ ${BSD_INSTALL_PROGRAM} atari800 ${BIN_PATH}/$(TARGET)
-+ ${BSD_INSTALL_MAN} atari800.man ${MAN_PATH}/man1/atari800.1
diff --git a/emulators/atari800/pkg-descr b/emulators/atari800/pkg-descr
index b66c840baca9..be8025a9f2cb 100644
--- a/emulators/atari800/pkg-descr
+++ b/emulators/atari800/pkg-descr
@@ -14,4 +14,4 @@ called PC Xformer 2.5 which contains copies of these ROM files. If you
would like to take a further look at XF2.5 you should find it in your
distfiles directory (if it successfully down-loaded :->).
-WWW: http://joy.sophics.cz/a800/
+WWW: http://atari800.sourceforge.net/
diff --git a/emulators/atari800/pkg-plist b/emulators/atari800/pkg-plist
index 8e2960d3c144..7ffd973963a0 100644
--- a/emulators/atari800/pkg-plist
+++ b/emulators/atari800/pkg-plist
@@ -13,7 +13,6 @@ share/atari800/mydos45d.atr
%%PORTDOCS%%share/doc/atari800/FAQ
%%PORTDOCS%%share/doc/atari800/INSTALL
%%PORTDOCS%%share/doc/atari800/README
-%%PORTDOCS%%share/doc/atari800/README.FreeBSD
%%PORTDOCS%%share/doc/atari800/TODO
%%PORTDOCS%%share/doc/atari800/USAGE
%%PORTDOCS%%@dirrm share/doc/atari800