aboutsummaryrefslogtreecommitdiff
path: root/emulators/bfe
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-04-15 19:54:08 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-04-15 19:54:08 +0000
commita232942161103290dfbb6e569d56dba5f8bb1fbc (patch)
tree324eee0834fb4bb1684913cde871c51634d7a9e1 /emulators/bfe
parentb7bf966f624b6446fe756b771459b9ce1baac9e3 (diff)
downloadports-a232942161103290dfbb6e569d56dba5f8bb1fbc.tar.gz
ports-a232942161103290dfbb6e569d56dba5f8bb1fbc.zip
Update to 24jan2003 (maintainer timeout).
PR: 47980 (partially) Submitted by: Sergey A. Osokin <osa@FreeBSD.org.ru>
Notes
Notes: svn path=/head/; revision=79032
Diffstat (limited to 'emulators/bfe')
-rw-r--r--emulators/bfe/Makefile33
-rw-r--r--emulators/bfe/distinfo2
-rw-r--r--emulators/bfe/files/patch-configure.sh49
-rw-r--r--emulators/bfe/pkg-descr5
-rw-r--r--emulators/bfe/pkg-plist2
5 files changed, 74 insertions, 17 deletions
diff --git a/emulators/bfe/Makefile b/emulators/bfe/Makefile
index df4300911ccd..9a95ddc3b360 100644
--- a/emulators/bfe/Makefile
+++ b/emulators/bfe/Makefile
@@ -5,30 +5,37 @@
# $FreeBSD$
#
-PORTNAME= bfe
-PORTVERSION= 2mar2001
+PORTNAME= bfe2
+PORTVERSION= 20030124
CATEGORIES= emulators
-MASTER_SITES= http://www.qzx.com/bfe/_download/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= bfe
+DISTNAME= bfe2-24jan2003
MAINTAINER= greid@FreeBSD.org
-COMMENT= X11 GUI for the bochs debugger
+COMMENT= X11 GUI for the bochs debugger (revision 2)
-LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
RUN_DEPENDS= bochs:${PORTSDIR}/emulators/bochs
+BUILD_DEPENDS= ${RUN_DEPENDS}
+USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_XPM= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+CONFIGURE_SCRIPT= configure.sh
+WRKSRC= ${WRKDIR}/bfe2
-WRKSRC= ${WRKDIR}/bfe
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
+ -e 's|%%CC%%|${CC}|' -e 's|%%CFLAGS%%|${CFLAGS}|' \
+ -e 's|gtk-config|${GTK_CONFIG}|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-pre-build:
- ${PERL} -pi -e "s@/usr/X11R6@${X11BASE}@g; \
- s@/usr/local@${LOCALBASE}@g; \
- s@-lforms@-lforms -lXpm@g; \
- s@gcc@${CC}@g; s@-O2@${CFLAGS}@g" ${WRKSRC}/Makefile
+do-configure:
+ @cd ${WRKSRC} && ${SH} ${CONFIGURE_SCRIPT}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bfe ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bfe2 ${PREFIX}/bin
-@${MKDIR} ${PREFIX}/share/bfe
${INSTALL_DATA} ${WRKSRC}/README.bferc ${PREFIX}/share/bfe/bferc.sample
${INSTALL_DATA} ${WRKSRC}/README.bferc ${PREFIX}/share/bfe
diff --git a/emulators/bfe/distinfo b/emulators/bfe/distinfo
index e38de4f51989..4fb9355bf09a 100644
--- a/emulators/bfe/distinfo
+++ b/emulators/bfe/distinfo
@@ -1 +1 @@
-MD5 (bfe-2mar2001.tar.gz) = 6aac85b944f0b907fad2cbe18d3bc136
+MD5 (bfe2-24jan2003.tar.gz) = 83018142b4d30ba13def376f4996d845
diff --git a/emulators/bfe/files/patch-configure.sh b/emulators/bfe/files/patch-configure.sh
new file mode 100644
index 000000000000..35fb2d731677
--- /dev/null
+++ b/emulators/bfe/files/patch-configure.sh
@@ -0,0 +1,49 @@
+--- configure.sh.orig Sat Jan 25 07:08:39 2003
++++ configure.sh Thu Feb 6 02:11:55 2003
+@@ -1,26 +1,18 @@
+-#!/bin/bash
+-
+-# csh and tcsh do not like this file
+-# ash produces incorrect quoting
+-
+-if [ "`/bin/ls -la /bin/sh |grep '\-> ash'`" != "" ]; then
+- echo -e "\nash shell is not supported\n"
+- exit
+-fi
++#!/bin/sh
+
+ ##############################################################################
+
+-CC="cc"
+-LD="cc"
+-CFLAGS="-O2 -Wall"
++CC=%%CC%%
++LD=%%CC%%
++CFLAGS=%%CFLAGS%%
+ LFLAGS=""
+
+ PROG="bfe2"
+ OWNER="root"
+-GROUP="root"
++GROUP="whell"
+
+ # install directories
+-PREFIX="/usr/local"
++PREFIX=%%PREFIX%%
+ BIN="bin"
+ SYSCONF="etc"
+
+@@ -106,13 +98,6 @@
+ INCS="\`pkg-config --cflags gtk+-2.0\`"
+ else
+ echo -e "\tInvalid GTK version [$GTK]"
+- exit
+-fi
+-
+-if [ "$BOCHS" == "2.0" ]; then
+- BOCHSPATH="$BOCHSPATH -q"
+-else
+- echo -e "\tInvalid Bochs version [$BOCHS]"
+ exit
+ fi
+
diff --git a/emulators/bfe/pkg-descr b/emulators/bfe/pkg-descr
index 0fd75a53e69e..4d0441a037d4 100644
--- a/emulators/bfe/pkg-descr
+++ b/emulators/bfe/pkg-descr
@@ -1,6 +1,7 @@
-Bochs Frontend is a graphical interface for X11 to the bochs x86 emulator.
+Bochs Frontend (bfe2) is a graphical interface for X11 to the
+bochs x86 emulator.
-WWW: http://www.qzx.com/bfe/
+WWW: http://bfe.sourceforge.net/
- John
jhb@FreeBSD.org
diff --git a/emulators/bfe/pkg-plist b/emulators/bfe/pkg-plist
index d4c0cfc01330..6c2f96504570 100644
--- a/emulators/bfe/pkg-plist
+++ b/emulators/bfe/pkg-plist
@@ -1,4 +1,4 @@
-bin/bfe
+bin/bfe2
share/bfe/bferc.sample
share/bfe/README.bferc
@dirrm share/bfe