aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-06-03 00:40:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-06-03 00:40:13 +0000
commit1f9444e0f65c146f0fd22d896e24787c79495960 (patch)
tree6d789d0ad68d0cafa73fc3819c6d6bc7843d1934 /emulators/bochs
parent9f79db2e8ba378aef3f0a9786233e8f66fcc7fe3 (diff)
downloadports-1f9444e0f65c146f0fd22d896e24787c79495960.tar.gz
ports-1f9444e0f65c146f0fd22d896e24787c79495960.zip
- Add USES=libtool
- Strip binaries
Notes
Notes: svn path=/head/; revision=356267
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 881e17142b65..d4bb26c6fe40 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -74,8 +74,8 @@ VMX_DESC= Enable Virtialization extensions
VOODOO_DESC= Enable 3dfx Voodoo Graphics emulation
X86_64_DESC= Enable x86-64 instructions support
-USES= gmake pkgconfig
-USE_AUTOTOOLS= libtool
+USES= gmake pkgconfig libtool
+GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_alsa_asoundlib_h=no
CONFIGURE_ARGS= --disable-docbook --disable-instrumentation
@@ -288,6 +288,9 @@ post-patch:
${WRKSRC}/gui/Makefile.in
post-install:
+.for f in bochs bxcommit bximage
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
+.endfor
.if ${PORT_OPTIONS:MPLUGINS}
@${FIND} ${STAGEDIR}${PREFIX}/lib/bochs ! -type d | \
${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}