aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2008-06-15 02:09:59 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2008-06-15 02:09:59 +0000
commit6d31f58a7118ce40fba507e41fd2a0c36663b75e (patch)
treea4816ac8e19972aa453c9ba34b05342c68039941 /emulators/bochs
parentc18cc1388802d06be9676207b396fba9badd3984 (diff)
downloadports-6d31f58a7118ce40fba507e41fd2a0c36663b75e.tar.gz
ports-6d31f58a7118ce40fba507e41fd2a0c36663b75e.zip
- Update to version 2.3.7
PR: ports/124586 Submitted by: KATO Tsuguru <tkato432 AT yahoo.com>
Notes
Notes: svn path=/head/; revision=214870
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile33
-rw-r--r--emulators/bochs/distinfo6
-rw-r--r--emulators/bochs/pkg-descr2
3 files changed, 26 insertions, 15 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index a7875418a23f..2cddfaa37fb4 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= bochs
-PORTVERSION= 2.3.6
-PORTREVISION= 1
+PORTVERSION= 2.3.7
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= SF
@@ -18,13 +17,14 @@ COMMENT= An IA-32 (x86) PC emulator that runs DOS, Win 95, and more
BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-docbook
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
-OPTIONS= CDROM "Enable CDROM support" on \
+OPTIONS= AES "Enable support of AES CPU extensions" off \
+ CDROM "Enable CDROM support" on \
CLGD54XX "Enable Cirrus Logic GD54xx video card" off \
DEBUGGER "Enable debugger and disassembler support" off \
DEBUGGER_X86 "Enable x86 hardware debugger" off \
@@ -55,9 +55,12 @@ OPTIONS= CDROM "Enable CDROM support" on \
WX "Use WxWidgets display interface" off \
X11 "Use X11 display interface" on \
X86_64 "Enable AMD x86-64 support" off \
- XPM "Enable XPM library support" off
+ XPM "Enable XPM library support" off \
+ XSAVE "Enable support of XSAVE/XRSTOR CPU extensions" off
CFLAGS+= -fno-rtti -fno-exceptions -fomit-frame-pointer
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
MANCOMPRESSED= yes
MAN1= bochs.1 bochs-dlx.1 bxcommit.1 bximage.1
@@ -71,6 +74,10 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+=--with-nogui
.endif
+.if defined(WITH_AES)
+CONFIGURE_ARGS+=--enable-aes
+.endif
+
.if defined(WITHOUT_CDROM)
CONFIGURE_ARGS+=--disable-cdrom
.endif
@@ -163,8 +170,9 @@ CONFIGURE_ARGS+=--with-sdl
CONFIGURE_ARGS+=--enable-show-ips
.endif
-.if defined(WITH_SSE4)
+.if defined(WITH_SSE4) || defined(WITH_AES) || defined(WITH_XSAVE)
CONFIGURE_ARGS+=--enable-sse=4 --enable-sse-extension
+WITH_CPU_LEVEL= 6
.endif
.if defined(WITH_SVGA)
@@ -206,7 +214,12 @@ CONFIGURE_ARGS+=--enable-x86-64
.if defined(WITH_XPM)
USE_XORG= xpm
-CONFIGURE_ARGS+=--with-xpm
+.else
+CONFIGURE_ARGS+=--disable-xpm
+.endif
+
+.if defined(WITH_XSAVE)
+CONFIGURE_ARGS+=--enable-xsave
.endif
.if defined(WITH_CPU_LEVEL)
@@ -256,10 +269,8 @@ post-patch:
${WRKSRC}/doc/docbook/user/user.dbk ${WRKSRC}/doc/man/*.[15]
@${REINPLACE_CMD} -Ee 's|/usr/(include/vga\.h)|${LOCALBASE}/\1|' \
${WRKSRC}/gui/svga.cc
-.if defined(WITH_SVGA)
- @${REINPLACE_CMD} -e 's|-lvga -lvgagl|@LDFLAGS@ &|' \
+ @${REINPLACE_CMD} -Ee 's|(^LOCAL_CXXFLAGS.+=)|\1 @CPPFLAGS@|' \
${WRKSRC}/gui/Makefile.in
-.endif
post-install:
.if defined(WITH_PLUGINS)
diff --git a/emulators/bochs/distinfo b/emulators/bochs/distinfo
index 3c09cb16ef13..5917ec3d8f39 100644
--- a/emulators/bochs/distinfo
+++ b/emulators/bochs/distinfo
@@ -1,3 +1,3 @@
-MD5 (bochs-2.3.6.tar.gz) = 5b666fb64d7ccf9baa0122ec15a3f4b9
-SHA256 (bochs-2.3.6.tar.gz) = 11b4026f0717266d01c59a3f95046077bc046949aa752d0f0773b2b20dfb16aa
-SIZE (bochs-2.3.6.tar.gz) = 3951132
+MD5 (bochs-2.3.7.tar.gz) = a2e5f922505bf16cabd36bb9d571a2c4
+SHA256 (bochs-2.3.7.tar.gz) = 77f27fedadc6431df0a06ee226259a80443524ae9d221c97c5986e3f7927bb04
+SIZE (bochs-2.3.7.tar.gz) = 3989982
diff --git a/emulators/bochs/pkg-descr b/emulators/bochs/pkg-descr
index 31fb2bd2a0da..b8ca337e1a60 100644
--- a/emulators/bochs/pkg-descr
+++ b/emulators/bochs/pkg-descr
@@ -5,7 +5,7 @@ be compiled to emulate a 386, 486, Pentium, Pentium Pro or AMD64 CPU,
including optional MMX, SSE, SSE2 and 3DNow instructions.
Bochs is capable of running most Operating Systems inside the emulation
-including Linux, DOS, Windows® 95/98 and Windows® NT/2000/XP.
+including Linux, DOS, Windows 95/98 and Windows NT/2000/XP.
Bochs was written by Kevin Lawton and is currently maintained by the Bochs
project.