aboutsummaryrefslogtreecommitdiff
path: root/emulators/darcnes/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-02 15:48:45 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-02 15:48:45 +0000
commit245be80d7660ae21a4fc975750067ae1cc2334f8 (patch)
tree7f125a81ffc6b69c5adc4b4c0f41750c73ddc922 /emulators/darcnes/Makefile
parent31868e48659385b7a468058336d8d1ad6ab97ffe (diff)
downloadports-245be80d7660ae21a4fc975750067ae1cc2334f8.tar.gz
ports-245be80d7660ae21a4fc975750067ae1cc2334f8.zip
- Fix build on non-i386 arch
- Add option to support Gtk/SVGAlib GUI - Support NOPORTDOCS - Fix WWW: line PR: ports/62262 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=99819
Diffstat (limited to 'emulators/darcnes/Makefile')
-rw-r--r--emulators/darcnes/Makefile42
1 files changed, 37 insertions, 5 deletions
diff --git a/emulators/darcnes/Makefile b/emulators/darcnes/Makefile
index a273a740f561..7b61e26ef029 100644
--- a/emulators/darcnes/Makefile
+++ b/emulators/darcnes/Makefile
@@ -7,6 +7,7 @@
PORTNAME= darcnes
PORTVERSION= 9b0401
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://www.dridus.com/~nyef/darcnes/download/
DISTNAME= dn${PORTVERSION}
@@ -15,14 +16,45 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= multi-system emulator
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
NO_CDROM= Commercial use is restricted
-USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+WANT_GNOME= yes
USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" TARGET_CC="${CC}" CXX="${CXX}" TARGET_CXX="${CXX}" \
+ AS="${AS}" TARGET_AS="${CC}" LD="${LD}" TARGET_LD="${CC}"
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" || defined(WITHOUT_X86_ASM)
+MAKE_ARGS+= C_ONLY=-DC_ONLY
+.else
+MAKE_ARGS+= MACH_TYPES=-DMACH_TYPES=\\\"types-i386.h\\\"
+.endif
+
+.if ${HAVE_GNOME:Mgtk12}!=""
+USE_GNOME= gtk12
+MAKE_ARGS+= TARGET=Linux_GTK
+PKGNAMESUFFIX= -gtk
+.else
+.if defined(WITH_SVGALIB)
+LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
+MAKE_ARGS+= TARGET=Linux_svgalib
+PKGNAMESUFFIX= -svgalib
+.else
+USE_XLIB= yes
+.endif
+.endif
+
+post-patch:
+ @${CP} ${FILESDIR}/endian.h ${WRKSRC}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/darcnes ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/darcnes ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>