aboutsummaryrefslogtreecommitdiff
path: root/emulators/dosbox
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-08-26 17:23:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-08-26 17:23:59 +0000
commit771539cd45da4c92780dcf69cecf103b6b1c9ff9 (patch)
tree6b402367da0ced4b0fbdcef2b7e6dfdc2c2c855e /emulators/dosbox
parenta110650af3f47fadb845c86674c3a6241bbb7ef7 (diff)
downloadports-771539cd45da4c92780dcf69cecf103b6b1c9ff9.tar.gz
ports-771539cd45da4c92780dcf69cecf103b6b1c9ff9.zip
- Install an icon and use it in a desktop file
PR: 181499 Submitted by: myself Approved by: Tom Carrick <knyght@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=325405
Diffstat (limited to 'emulators/dosbox')
-rw-r--r--emulators/dosbox/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
index feb3db9178a8..c2050ad1a481 100644
--- a/emulators/dosbox/Makefile
+++ b/emulators/dosbox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dosbox
PORTVERSION= 0.74
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= SF
@@ -14,7 +14,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
USE_SDL= sdl net sound
-PLIST_FILES= bin/dosbox
+PLIST_FILES= bin/dosbox share/pixmaps/dosbox.ico
PORTDOCS= NEWS README
MAN1= dosbox.1
@@ -24,7 +24,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-core-inline
DESKTOP_ENTRIES="DOSBox" "${COMMENT}" \
- "" "dosbox" \
+ "${PREFIX}/share/pixmaps/dosbox.ico" "dosbox" \
"System;Emulator;" "true"
OPTIONS_RADIO= DEBUGGER
@@ -46,6 +46,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/dosbox ${PREFIX}/bin/dosbox
+ ${INSTALL_DATA} ${WRKSRC}/src/dosbox.ico ${PREFIX}/share/pixmaps/
${INSTALL_MAN} ${WRKSRC}/docs/dosbox.1 ${MAN1PREFIX}/man/man1/
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}