aboutsummaryrefslogtreecommitdiff
path: root/emulators/dynamips
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2006-02-13 19:42:36 +0000
committerMax Khon <fjoe@FreeBSD.org>2006-02-13 19:42:36 +0000
commit5775a87fbc9e60b266f72b11a8843dbbe45f30a5 (patch)
tree7054c47fb1ca230a6e3b9597aefbb2ebed44ade0 /emulators/dynamips
parent87e9768329c05ba8d5eca5e8b8ae181b5f6a483a (diff)
downloadports-5775a87fbc9e60b266f72b11a8843dbbe45f30a5.tar.gz
ports-5775a87fbc9e60b266f72b11a8843dbbe45f30a5.zip
Update to 0.2.3c.
- Fixed a stupid bug in DMA handling, which in certain conditions can cause an infinite loop. - Added an "instruction block hash" which avoids lookups in the instruction red-black tree. The IBH table takes only 16 Kb of memory. - Added CRC-12 and CRC-16 functions for future use. - Added a "gen_eth" NetIO driver, which allow to access ethernet interfaces in a portable way (tested on Linux and Cygwin). - Fixes to the PowerPC build on Darwin thanks to Olivier Cahagne. - Minor cosmetic changes to display supported/unsupported PA and NPE. Note: gen_eth is not supported on RELENG_4 (requires libpcap 0.9+).
Notes
Notes: svn path=/head/; revision=155958
Diffstat (limited to 'emulators/dynamips')
-rw-r--r--emulators/dynamips/Makefile12
-rw-r--r--emulators/dynamips/distinfo6
-rw-r--r--emulators/dynamips/files/patch-Makefile23
3 files changed, 26 insertions, 15 deletions
diff --git a/emulators/dynamips/Makefile b/emulators/dynamips/Makefile
index 5e5a9346865d..6c115aeabe58 100644
--- a/emulators/dynamips/Makefile
+++ b/emulators/dynamips/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dynamips
-PORTVERSION= 0.2.3b
-PORTREVISION= 1
+PORTVERSION= 0.2.3c
CATEGORIES= emulators
MASTER_SITES= http://www.ipflow.utc.fr/dynamips/
@@ -45,4 +44,13 @@ DYNAMIPS_ARCH= "amd64"
DYNAMIPS_ARCH= "nojit"
.endif
+.if ${OSVERSION} < 500000
+#
+# Requires libpcap 0.9+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/^HAS_PCAP=1/HAS_PCAP=0/' ${WRKSRC}/Makefile
+.endif
+
.include <bsd.port.post.mk>
diff --git a/emulators/dynamips/distinfo b/emulators/dynamips/distinfo
index 076ba7c1eaff..9de23669370a 100644
--- a/emulators/dynamips/distinfo
+++ b/emulators/dynamips/distinfo
@@ -1,3 +1,3 @@
-MD5 (dynamips-0.2.3b.tar.gz) = 5ec12dedc04391aed8c8f4c7b22c5c75
-SHA256 (dynamips-0.2.3b.tar.gz) = 3764e2cd967674097118637484bc0855ffeac515190a8f13991b0189fbf2b5b6
-SIZE (dynamips-0.2.3b.tar.gz) = 182549
+MD5 (dynamips-0.2.3c.tar.gz) = 0202d82ee8f8879f84f3f03579d6a5ef
+SHA256 (dynamips-0.2.3c.tar.gz) = d7fb998c3bc6d5aaec10acdaab6d2ba5d5a5c5dd17cb92cd3a4452d94e29d5bf
+SIZE (dynamips-0.2.3c.tar.gz) = 185450
diff --git a/emulators/dynamips/files/patch-Makefile b/emulators/dynamips/files/patch-Makefile
index d66349dc1144..783bf76598af 100644
--- a/emulators/dynamips/files/patch-Makefile
+++ b/emulators/dynamips/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Mon Jan 30 19:09:47 2006
-+++ Makefile Tue Feb 14 01:13:29 2006
+--- Makefile.orig Thu Feb 2 00:08:41 2006
++++ Makefile Tue Feb 14 01:26:49 2006
@@ -3,7 +3,7 @@
# Replace x86 by amd64 for a build on x86_64.
@@ -9,9 +9,9 @@
# Change this to 0 if your system doesn't support RFC 2553 extensions
HAS_RFC2553=1
-@@ -11,21 +11,21 @@
+@@ -15,14 +15,14 @@
# Current dynamips release
- VERSION=0.2.3b
+ VERSION=0.2.3c
-CC=gcc
+CC?=gcc
@@ -27,16 +27,19 @@
-DARCH_INC_FILE=$(ARCH_INC_FILE) \
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE \
-DHAS_RFC2553=$(HAS_RFC2553)
+@@ -30,8 +30,9 @@
+ PCAP_LIB=-lpcap
ifeq ($(shell uname), FreeBSD)
- CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf
- LIBS=-L/usr/local/lib -L. -lelf -pthread
-+ CFLAGS+=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/libelf $(PTHREAD_CFLAGS)
-+ LIBS=-L$(LOCALBASE)/lib -lelf $(PTHREAD_LIBS)
++ PTHREAD_LIBS?=-pthread
++ CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf $(PTHREAD_CFLAGS)
++ LIBS=-L/usr/local/lib -L. -lelf $(PTHREAD_LIBS)
else
- ifeq ($(shell uname -o), Cygwin)
- CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf
-@@ -61,17 +61,17 @@
+ ifeq ($(shell uname -s), Darwin)
+ CFLAGS+=-I/usr/local/include
+@@ -73,17 +74,17 @@
#SOURCES += profiler.c
#CFLAGS += -p -DPROFILE -DPROFILE_FILE=\"$(PROG).profile\"
@@ -57,7 +60,7 @@
HDR += nojit_trans.h
SOURCES += nojit_trans.c
endif
-@@ -101,7 +101,7 @@
+@@ -123,7 +124,7 @@
.PHONY: microcode
microcode: