aboutsummaryrefslogtreecommitdiff
path: root/emulators/fceu/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-27 16:00:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-27 16:00:51 +0000
commit8005d6203526e434ac5ceee21db329021331fcdf (patch)
treea9cb6abc8fa210e6b83bad5f948d0c02dd7e78ee /emulators/fceu/Makefile
parentc0b9c99fa0efade725da745448f266274dc7f9c4 (diff)
downloadports-8005d6203526e434ac5ceee21db329021331fcdf.tar.gz
ports-8005d6203526e434ac5ceee21db329021331fcdf.zip
- Update to 0.98.13
PR: ports/78094 Submitted by: Greg J. <xcas@cox.net> (maintainer)
Notes
Notes: svn path=/head/; revision=129898
Diffstat (limited to 'emulators/fceu/Makefile')
-rw-r--r--emulators/fceu/Makefile86
1 files changed, 29 insertions, 57 deletions
diff --git a/emulators/fceu/Makefile b/emulators/fceu/Makefile
index e0508e74cbd0..2015ef39632e 100644
--- a/emulators/fceu/Makefile
+++ b/emulators/fceu/Makefile
@@ -6,86 +6,58 @@
#
PORTNAME= fceu
-PORTVERSION= 0.98.12
+PORTVERSION= 0.98.13
CATEGORIES= emulators
-MASTER_SITES= http://www.mavetju.org/download/adopted/
-DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+MASTER_SITES= http://bsd-unix.org/downloads/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-pre.src
MAINTAINER= xcas@cox.net
COMMENT= A portable NES/Famicom emulator based on Bero's original FCE
-USE_SDL= sdl
-MAN6= fceu.6
-WRKSRC= ${WRKDIR}/fceu
-USE_X_PREFIX= yes
USE_BZIP2= yes
+USE_GCC= 3.4
USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_SDL= sdl
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/fceu
+
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-DOCS= cheat.html faq.html fceultra.html fcm.txt fcs.txt protocol.txt
-TECHDOCS= README.now README.sound UNIF_current.txt nsfspec.txt
-TECHCPUDOCS= 4017.txt 6502_cpu.txt NESSOUND-4th.txt NESSOUND.txt dmc.txt
-TECHEXPDOCS= SMB2j.txt mmc5-e.txt mmc5_bank_switch.txt namco.txt taito.txt \
- tengen.txt vrcvi.txt vrcvii.txt
-TECHPPUDOCS= "2C02_technical_operation.TXT" loopy1.txt loopy2.txt
+MAN6= fceu.6
+
+PLIST_FILES= bin/fceu %%DOCSDIR%%/cheat.html %%DOCSDIR%%/faq.html \
+ %%DOCSDIR%%/fceultra.html %%DOCSDIR%%/fcm.txt \
+ %%DOCSDIR%%/fcs.txt %%DOCSDIR%%/protocol.txt
+PLIST_DIRS= %%DOCSDIR%%
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
+.if ${ARCH} == "amd64"
+BROKEN= "Does not configure"
.endif
-pre-everything::
-.if !defined(NOPORTDOCS) && !defined(TECH_DOC_INSTALL)
- @${ECHO_MSG} "You can install technical documents"
- @${ECHO_MSG} "by defining TECH_DOC_INSTALL"
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
.endif
-.if !defined(NOPORTDOCS) && defined(TECH_DOC_INSTALL)
-PLIST_SUB= TECHDOCS=""
-.else
-PLIST_SUB= TECHDOCS="@comment "
-.endif
+post-extract:
+ ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' ${WRKSRC}/src/drivers/common/vidblit.c
pre-build:
@${CP} ${WRKSRC}/Documentation/fceu-sdl.6 ${WRKSRC}/Documentation/fceu.6
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/fceu ${PREFIX}/bin
-
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.if !defined(NOPORTDOCS)
-.for docs in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/${docs} ${DOCSDIR}
-.endfor
-.endif
-
-.if !defined(NOPORTDOCS)
${INSTALL_MAN} ${WRKSRC}/Documentation/fceu.6 ${PREFIX}/man/man6
-.if defined(TECH_DOC_INSTALL)
- @${MKDIR} ${DOCSDIR}/tech
-.for docs in ${TECHDOCS}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/tech/${docs} ${DOCSDIR}/tech
-.endfor
- @${MKDIR} ${DOCSDIR}/tech/cpu
-.for docs in ${TECHCPUDOCS}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/tech/cpu/${docs} \
- ${DOCSDIR}/tech/cpu
-.endfor
- @${MKDIR} ${DOCSDIR}/tech/exp
-.for docs in ${TECHEXPDOCS}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/tech/exp/${docs} \
- ${DOCSDIR}/tech/exp
-.endfor
- @${MKDIR} ${DOCSDIR}/tech/ppu
-.for docs in ${TECHPPUDOCS}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/tech/ppu/${docs:S|_| |g} \
- ${DOCSDIR}/tech/ppu/${docs}
-.endfor
-.endif
-.endif
-.endif
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/cheat.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/faq.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/fceultra.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/fcm.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/fcs.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/protocol.txt ${DOCSDIR}
.include <bsd.port.post.mk>