aboutsummaryrefslogtreecommitdiff
path: root/emulators/gbe
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:36:55 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:36:55 +0000
commit6dd69bbdb162ba8206dcdfa59fab1841398aa524 (patch)
treedf0a35486711b4525aaf6d61505210a105ec04aa /emulators/gbe
parentb53baaf9b8f46684bcebe28bfe399cef95cad66e (diff)
downloadports-6dd69bbdb162ba8206dcdfa59fab1841398aa524.tar.gz
ports-6dd69bbdb162ba8206dcdfa59fab1841398aa524.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. respect CFLAGS.
Notes
Notes: svn path=/head/; revision=84830
Diffstat (limited to 'emulators/gbe')
-rw-r--r--emulators/gbe/Makefile5
-rw-r--r--emulators/gbe/files/patch-aa58
2 files changed, 57 insertions, 6 deletions
diff --git a/emulators/gbe/Makefile b/emulators/gbe/Makefile
index ac63bf7d1733..adb1b97877aa 100644
--- a/emulators/gbe/Makefile
+++ b/emulators/gbe/Makefile
@@ -7,15 +7,18 @@
PORTNAME= gbe
PORTVERSION= 0.0.22
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://www.zophar.net/unix/Files/
MAINTAINER= nakai@FreeBSD.org
COMMENT= Nintendo GameBoy(tm) emulator with GNU source code
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_GETOPT_LONG=yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${X11BASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${X11BASE}/lib"
USE_X_PREFIX= yes
diff --git a/emulators/gbe/files/patch-aa b/emulators/gbe/files/patch-aa
index 0aa72cececc3..ca6942297088 100644
--- a/emulators/gbe/files/patch-aa
+++ b/emulators/gbe/files/patch-aa
@@ -1,10 +1,58 @@
---- Makefile.orig Mon Apr 16 21:07:21 2001
-+++ Makefile Mon Apr 16 21:13:21 2001
-@@ -1,5 +1,5 @@
+--- Makefile.orig Mon Sep 27 00:29:10 1999
++++ Makefile Sun Jul 6 19:34:42 2003
+@@ -1,42 +1,42 @@
-LFLAGS = -L/usr/X11R6/lib -lX11 -g3 -lreadline -lncurses -lvga
-CFLAGS = -O6 -DBUILD_SVGA -DBUILD_X11 -DBUILD_JLIB -DCPU_DEBUG -g3 -ffast-math -fomit-frame-pointer -finline-functions #-DNOT_LINEBASED #-DCPU_DEBUG_EXTENDED
-+LFLAGS = -L/usr/X11R6/lib -lX11 -g3 -lgnugetopt -L/usr/local/lib
-+CFLAGS = -I/usr/X11R6/include -I/usr/local/include -O6 -DBUILD_X11 -g3 -ffast-math -fomit-frame-pointer -finline-functions #-DNOT_LINEBASED #-DCPU_DEBUG_EXTENDED
++LFLAGS = -lX11 -g3 $(LDFLAGS)
++CFLAGS += ${CPPFLAGS} -DBUILD_X11 -g3 #-DNOT_LINEBASED #-DCPU_DEBUG_EXTENDED
OBJS = main.o rom.o mem.o cpu.o vram.o debug.o joypad.o jlib.o x11.o svga.o
BIN = gbe
+ all: $(BIN)
+
+ $(BIN): $(OBJS)
+- gcc $(CFLAGS) -o $(BIN) $(OBJS) $(LFLAGS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LFLAGS)
+
+ main.o: main.c rom.h mem.h data.h vram.h
+- gcc $(CFLAGS) -o main.o -c main.c
++ $(CC) $(CFLAGS) -o main.o -c main.c
+
+ rom.o: rom.c rom.h mem.h
+- gcc $(CFLAGS) -o rom.o -c rom.c
++ $(CC) $(CFLAGS) -o rom.o -c rom.c
+
+ mem.o: mem.c mem.h regs.h
+- gcc $(CFLAGS) -o mem.o -c mem.c
++ $(CC) $(CFLAGS) -o mem.o -c mem.c
+
+ cpu.o: cpu.c cpu.h mem.h data.h
+- gcc $(CFLAGS) -o cpu.o -c cpu.c
++ $(CC) $(CFLAGS) -o cpu.o -c cpu.c
+
+ vram.o: vram.c vram.h x11.h mem.h regs.h
+- gcc $(CFLAGS) -o vram.o -c vram.c
++ $(CC) $(CFLAGS) -o vram.o -c vram.c
+
+ debug.o: debug.c debug.h
+- gcc $(CFLAGS) -o debug.o -c debug.c
++ $(CC) $(CFLAGS) -o debug.o -c debug.c
+
+ joypad.o: joypad.c joypad.c jlib.h
+- gcc $(CFLAGS) -o joypad.o -c joypad.c
++ $(CC) $(CFLAGS) -o joypad.o -c joypad.c
+
+ jlib.o: jlib.c jlib.h
+- gcc $(CFLAGS) -o jlib.o -c jlib.c
++ $(CC) $(CFLAGS) -o jlib.o -c jlib.c
+
+ x11.o: x11.c x11.h
+- gcc $(CFLAGS) -o x11.o -c x11.c
++ $(CC) $(CFLAGS) -o x11.o -c x11.c
+
+ svga.o: svga.c svga.h
+- gcc $(CFLAGS) -o svga.o -c svga.c
++ $(CC) $(CFLAGS) -o svga.o -c svga.c
+
+ clean:
+ rm -f $(BIN) $(OBJS) *~ core vram.dump