aboutsummaryrefslogtreecommitdiff
path: root/emulators/generator
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-09-04 12:55:45 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-09-04 12:55:45 +0000
commit682c6520789aab997e2af4714ece325021180b94 (patch)
tree0695ad7ab88fdef4523eb0572864ea392e9c35d0 /emulators/generator
parent983ae7c2d9de5dc13243f5d3ac3200cb07ba13c0 (diff)
downloadports-682c6520789aab997e2af4714ece325021180b94.tar.gz
ports-682c6520789aab997e2af4714ece325021180b94.zip
- Makefile clean up: remove old gcc version checking.
PR: ports/84926 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=141905
Diffstat (limited to 'emulators/generator')
-rw-r--r--emulators/generator/Makefile23
1 files changed, 5 insertions, 18 deletions
diff --git a/emulators/generator/Makefile b/emulators/generator/Makefile
index e08a97958506..eda9ff18e97c 100644
--- a/emulators/generator/Makefile
+++ b/emulators/generator/Makefile
@@ -53,28 +53,15 @@ post-patch:
.endif
.endif
-# Generator needs GCC 2.95.x or GCC >= 3.4.2 to work properly.
# Generator does not automatically determine the GCC version.
-.if ${OSVERSION} < 400012
-# GCC < 2.95 is in the base system.
-USE_GCC= 2.95
-.endif
-
-.if ${OSVERSION} >= 500035 && ${OSVERSION} < 502126
-# GCC > 2.95 (3.X) && GCC < 3.4.2 is in the base system.
-USE_GCC= 3.4
-.endif
-
-.if ${OSVERSION} < 500035
+.if defined(WITH_OPTIMIZED_CFLAGS)
+. if ${OSVERSION} < 500035
CONFIGURE_ARGS+= --with-gcc=2
-.endif
-
-.if ${OSVERSION} >= 500035
+. elif ${OSVERSION} >= 500035
CONFIGURE_ARGS+= --with-gcc=3
-.endif
-
-.if defined(WITHOUT_OPTIMIZED_CFLAGS)
+. endif
+.else
CONFIGURE_ARGS+= --without-gcc
.endif