aboutsummaryrefslogtreecommitdiff
path: root/emulators/gngb
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2001-04-22 01:40:59 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2001-04-22 01:40:59 +0000
commitb945b1899951fee56b24e9e904c331a87096e58f (patch)
tree1c23a02c43aad8032ee734acfcf85ad2865a5340 /emulators/gngb
parent3283bd8c618a6a957d93bd47da689a6d5d1d8e34 (diff)
downloadports-b945b1899951fee56b24e9e904c331a87096e58f.tar.gz
ports-b945b1899951fee56b24e9e904c331a87096e58f.zip
Initial import.
Another Gameboy(tm) emulator.
Notes
Notes: svn path=/head/; revision=41784
Diffstat (limited to 'emulators/gngb')
-rw-r--r--emulators/gngb/Makefile29
-rw-r--r--emulators/gngb/distinfo1
-rw-r--r--emulators/gngb/files/patch-aa30
-rw-r--r--emulators/gngb/pkg-comment1
-rw-r--r--emulators/gngb/pkg-descr3
-rw-r--r--emulators/gngb/pkg-plist1
6 files changed, 65 insertions, 0 deletions
diff --git a/emulators/gngb/Makefile b/emulators/gngb/Makefile
new file mode 100644
index 000000000000..bc373453e7ff
--- /dev/null
+++ b/emulators/gngb/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gngb
+# Date created: 16 April 2001
+# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gngb
+PORTVERSION= 20010318
+CATEGORIES= emulators
+MASTER_SITES= http://frogus.multimania.com/
+DISTNAME= ${PORTNAME}_${PORTVERSION}_src
+
+MAINTAINER= nakai@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+post-patch:
+ perl -pi -e 's/<SDL\//<SDL11\//' ${WRKSRC}/*.[ch]
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gngb ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/emulators/gngb/distinfo b/emulators/gngb/distinfo
new file mode 100644
index 000000000000..862ccf2b3ad1
--- /dev/null
+++ b/emulators/gngb/distinfo
@@ -0,0 +1 @@
+MD5 (gngb_20010318_src.tar.gz) = cd7d0c1cd8852f49ae938f0f8c1ba9a5
diff --git a/emulators/gngb/files/patch-aa b/emulators/gngb/files/patch-aa
new file mode 100644
index 000000000000..20bbca29b48a
--- /dev/null
+++ b/emulators/gngb/files/patch-aa
@@ -0,0 +1,30 @@
+--- Makefile.orig Sun Apr 22 10:34:08 2001
++++ Makefile Sun Apr 22 10:39:35 2001
+@@ -15,23 +15,23 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-GL_MODE = 1
++#GL_MODE = 1
+
+ CC = gcc
+ INCDIRS = -I. -I/usr/include
+ LIBDIRS = -L/usr/X11R6/lib
+ DEBUG = -g
+ PROFILE = -pg -O3
+-OPT = -O3 -mpentiumpro -Wno-unused -funroll-loops -fstrength-reduce -ffast-math -malign-functions=2 -malign-jumps=2 -malign-loops=2 -fomit-frame-pointer -Wall -g
++OPT = -O3 -mpentiumpro -Wno-unused -funroll-loops -fstrength-reduce -ffast-math -malign-functions=2 -malign-jumps=2 -malign-loops=2 -fomit-frame-pointer -Wall -g -I/usr/local/include/
+ OBJ = memory.o vram.o interrupt.o cpu.o rom.o sound.o serial.o frame_skip.o main.o
+ DOBJ = debuger/memory.o debuger/vram.o debuger/interrupt.o debuger/cpu.o debuger/rom.o debuger/sound.o debuger/serial.o debuger/frame_skip.o debuger/log.o debuger/debuger.o
+
+ ifdef GL_MODE
+ CFLAGS = $(OPT) -D_REENTRANT -DSDL_GL
+-LIBS = -lSDL -lpthread -lGL
++LIBS = -lSDL-1.1 -lpthread -lGL -L/usr/local/lib
+ else
+ CFLAGS = $(OPT) -D_REENTRANT
+-LIBS = -lSDL -lpthread
++LIBS = -lSDL-1.1 -L/usr/local/lib -lc_r
+ endif
+
+ all : gngb
diff --git a/emulators/gngb/pkg-comment b/emulators/gngb/pkg-comment
new file mode 100644
index 000000000000..b2ccdad9ac89
--- /dev/null
+++ b/emulators/gngb/pkg-comment
@@ -0,0 +1 @@
+GameBoy(tm) emulator
diff --git a/emulators/gngb/pkg-descr b/emulators/gngb/pkg-descr
new file mode 100644
index 000000000000..e047e6659178
--- /dev/null
+++ b/emulators/gngb/pkg-descr
@@ -0,0 +1,3 @@
+GameBoy(tm) emulator
+
+WWW: http://frogus.multimania.com/gngb.html
diff --git a/emulators/gngb/pkg-plist b/emulators/gngb/pkg-plist
new file mode 100644
index 000000000000..b377ac5037a3
--- /dev/null
+++ b/emulators/gngb/pkg-plist
@@ -0,0 +1 @@
+bin/gngb