aboutsummaryrefslogtreecommitdiff
path: root/emulators/gngeo
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-02-28 16:19:16 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-02-28 16:19:16 +0000
commitb626c304ae9d1a29019810f8cac662efaefdf202 (patch)
treeac787151b26b3b00a326e43a56ccf1f57e239bc0 /emulators/gngeo
parent60baa57008ba16ae431477e7f175f8a2cbb9ca76 (diff)
downloadports-b626c304ae9d1a29019810f8cac662efaefdf202.tar.gz
ports-b626c304ae9d1a29019810f8cac662efaefdf202.zip
MFH: r380131
- Simplify MASTER_SITES - Remove unneeded MAN1 - Don't show pkg-message from Makefile - Disable and mark broken RAZE and STAR options, as they fail to link - Fix configure to properly detect amd64 arch - When compiling with clang, drop compiler flags not supported by it - Disable -malign-double on amd64, gcc says it makes no sense Approved by: bapt Approved by: ports-secteam (zi)
Notes
Notes: svn path=/branches/2015Q1/; revision=380151
Diffstat (limited to 'emulators/gngeo')
-rw-r--r--emulators/gngeo/Makefile25
1 files changed, 17 insertions, 8 deletions
diff --git a/emulators/gngeo/Makefile b/emulators/gngeo/Makefile
index 9517695bb70a..0eefac1fab36 100644
--- a/emulators/gngeo/Makefile
+++ b/emulators/gngeo/Makefile
@@ -5,13 +5,12 @@ PORTNAME= gngeo
PORTVERSION= 0.8
PORTREVISION= 2
CATEGORIES= emulators
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= GOOGLE_CODE/${PORTNAME}
MAINTAINER= acm@FreeBSD.org
COMMENT= NeoGeo emulator
-USES= gmake
+USES= compiler:features gmake
USE_SDL= image sdl
USE_GL= yes
@@ -27,11 +26,10 @@ MAKE_ARGS+= CC_FOR_BUILD=${CC}
SUB_FILES= pkg-message
OPTIONS_DEFINE_i386= ASM RAZE STAR
-OPTIONS_DEFAULT_i386= ASM RAZE STAR
-RAZE_DESC= Use Raze as z80 emulator
-STAR_DESC= Use Starscream as 68k emulator
+OPTIONS_DEFAULT_i386= ASM
+RAZE_DESC= Use Raze as z80 emulator (broken)
+STAR_DESC= Use Starscream as 68k emulator (broken)
-MAN1= gngeo.1
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MI386ASM} || ${PORT_OPTIONS:MRAZE} || \
@@ -47,17 +45,29 @@ CONFIGURE_ARGS+= --disable-i386asm
.if ${PORT_OPTIONS:MRAZE}
CONFIGURE_ARGS+= --with-z80core=raze
+BROKEN= fails to link
.else
CONFIGURE_ARGS+= --with-z80core=mamez80
.endif
.if ${PORT_OPTIONS:MSTAR}
CONFIGURE_ARGS+= --with-m68kcore=starscream
+BROKEN= fails to link
.else
CONFIGURE_ARGS+= --with-m68kcore=gen68k
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|x86_64|amd64|' ${WRKSRC}/configure
+.if ${ARCH} == "amd64"
+ @${REINPLACE_CMD} -e 's|-malign-double||' ${WRKSRC}/configure
+.endif
+.if ${COMPILER_TYPE} == "clang"
+ @${REINPLACE_CMD} -e 's|-frerun-loop-opt||; \
+ s|-falign-jumps=2||; s|-falign-loops=2||; \
+ s|-fschedule-insns2||; s|-malign-double||' \
+ ${WRKSRC}/configure
+.endif
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT} \
${WRKSRC}/src/generator68k/Makefile.in
@@ -65,6 +75,5 @@ post-patch:
post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample_gngeorc ${STAGEDIR}${EXAMPLESDIR}/gngeorc
- @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
.include <bsd.port.post.mk>