aboutsummaryrefslogtreecommitdiff
path: root/emulators/klh10
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-19 13:28:24 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-19 13:28:24 +0000
commit89ae52566263f39ba8737263d0adc0900aff9f43 (patch)
tree8d57b1e57485087de9e50db7b10df922adbd1a39 /emulators/klh10
parent32c616cd74f090e3cf2e0b46c22eb656330d8f65 (diff)
downloadports-89ae52566263f39ba8737263d0adc0900aff9f43.tar.gz
ports-89ae52566263f39ba8737263d0adc0900aff9f43.zip
New port of KLH10 PDP-10 mainframe emulator.
This is a port of Kenneth L. Harrenstien's KLH10 DEC PDP-10 mainframe emulator. PR: ports/39955 Submitted by: Ken Stailey <kstailey@speakeasy.net>
Notes
Notes: svn path=/head/; revision=73485
Diffstat (limited to 'emulators/klh10')
-rw-r--r--emulators/klh10/Makefile131
-rw-r--r--emulators/klh10/distinfo2
-rw-r--r--emulators/klh10/files/PDPs32
-rw-r--r--emulators/klh10/files/patch-aa12
-rw-r--r--emulators/klh10/files/patch-ab25
-rw-r--r--emulators/klh10/pkg-comment1
-rw-r--r--emulators/klh10/pkg-descr22
-rw-r--r--emulators/klh10/pkg-message4
-rw-r--r--emulators/klh10/pkg-plist49
9 files changed, 278 insertions, 0 deletions
diff --git a/emulators/klh10/Makefile b/emulators/klh10/Makefile
new file mode 100644
index 000000000000..4eb77296e801
--- /dev/null
+++ b/emulators/klh10/Makefile
@@ -0,0 +1,131 @@
+# New ports collection makefile for: klh10
+# Date created: 11 January 2002
+# Whom: kstailey
+#
+# $FreeBSD$
+#
+
+PORTNAME= klh10
+PORTVERSION= 2.0a
+CATEGORIES= emulators
+MASTER_SITES= http://klh10.trailing-edge.com/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+DISTFILES= ${DISTNAME}.tgz klh10-2.0a-aux.tgz
+
+MAINTAINER= kstailey@yahoo.com
+
+ONLY_FOR_ARCHS= i386
+
+BUILD_WRKSRC= ${WRKSRC}/bld/fbx86
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+# KSITS_ prefix for Komputer Small Incompatible Timesharing System
+# a KLH10 configuration.
+
+# KSITS_KLH10_HOME and KSITS_DRIVER_DIR must be set to the same
+# locations that the its port uses.
+
+KSITS_KLH10_DIR= klh10-ks-its
+KSITS_KLH10_HOME= ${PREFIX}/share/${KSITS_KLH10_DIR}
+KSITS_DRIVER_DIR= ${PREFIX}/libexec/${KSITS_KLH10_DIR}
+KSITS_DOCDIR= ${PREFIX}/share/doc/${KSITS_KLH10_DIR}
+# someday add support for base-kl and base-ks targets
+MAKE_ENV+= KLH10_HOME=${KSITS_KLH10_HOME}
+ALL_TARGET= base-ks-its
+
+KSITS_NATIVE_PROGS= kn10-ks \
+ tapedd \
+ udlconv \
+ vdkfmt \
+ wfconv \
+ wxtest
+
+KSITS_EM_DRIVERS= dprpxx \
+ dptm03
+
+KSITS_EM_SDRIVERS= dpimp
+
+KSITS_EM_DAT= @.ddt-u \
+ @.its-647kn-u \
+ @.nsalv-260-u \
+ itsbin.647kn-u \
+ klh10-kn.ini
+
+KSITS_PUBADM= hosts.its \
+ its.ipfw \
+ rc.firewall-its \
+ router.notes
+
+KSITS_PUBDOC= bootload.files \
+ distrib.its \
+ dumpsys.help
+
+KSITS_DOCS= Intro.txt \
+ backgrnd.txt \
+ cmdref.txt \
+ cmdsum.txt \
+ coding.txt \
+ dfkfb.txt \
+ dvhost.txt \
+ history.txt \
+ install.txt \
+ kldiff.txt \
+ klt10.txt \
+ klt20.txt \
+ ksits.txt \
+ kst10.txt \
+ kst20.txt \
+ news.txt \
+ usage.txt \
+ utils.txt \
+ vtape.txt
+
+pre-install:
+ @ ${MKDIR} ${KSITS_KLH10_HOME}
+ @ ${MKDIR} ${KSITS_DRIVER_DIR}
+ @ ${MKDIR} ${KSITS_DOCDIR}
+ @ ${ECHO} KLH10 contains a setuid that accepts network connections. \
+ > ${PKGDIR}/pkg-message
+ @ ${ECHO} Consider using a firewall to limit access to KLH10. \
+ >> ${PKGDIR}/pkg-message
+ @ ${ECHO} See the ${KSITS_DOCDIR}/pubits/adm >> ${PKGDIR}/pkg-message
+ @ ${ECHO} for firewall documentation. >> ${PKGDIR}/pkg-message
+
+post-install:
+.for file in ${KSITS_NATIVE_PROGS} ${KSITS_EM_DRIVERS} ${KSITS_EM_SDRIVERS}
+ @ ${STRIP_CMD} ${KSITS_KLH10_HOME}/${file}
+.endfor
+.for file in ${KSITS_NATIVE_PROGS}
+ @ ${MV} ${KSITS_KLH10_HOME}/${file} ${PREFIX}/bin
+.endfor
+.for file in ${KSITS_EM_DRIVERS} ${KSITS_EM_SDRIVERS}
+ @ ${MV} ${KSITS_KLH10_HOME}/${file} ${KSITS_DRIVER_DIR}
+.endfor
+.for file in ${KSITS_EM_SDRIVERS}
+ @ ${CHGRP} network ${KSITS_DRIVER_DIR}/${file}
+ @ ${CHMOD} 4754 ${KSITS_DRIVER_DIR}/${file}
+.endfor
+.for file in ${KSITS_EM_DAT}
+ @ ${INSTALL_DATA} ${WRKSRC}/run/ksits/${file} ${KSITS_KLH10_HOME}
+.endfor
+ @ ${INSTALL_MAN} ${WRKSRC}/run/ksits/README ${KSITS_DOCDIR}
+ @ ${MKDIR} ${KSITS_DOCDIR}/pubits/adm
+ @ ${MKDIR} ${KSITS_DOCDIR}/pubits/doc
+.for file in ${KSITS_DOCS}
+ @ ${INSTALL_MAN} ${WRKSRC}/doc/${file} ${KSITS_DOCDIR}
+.endfor
+.for file in ${KSITS_PUBADM}
+ @ ${INSTALL_MAN} ${WRKSRC}/run/ksits/pubits/adm/${file} \
+ ${KSITS_DOCDIR}/pubits/adm
+.endfor
+.for file in ${KSITS_PUBDOC}
+ @ ${INSTALL_MAN} ${WRKSRC}/run/ksits/pubits/doc/${file} \
+ ${KSITS_DOCDIR}/pubits/doc
+.endfor
+ @ ${INSTALL_MAN} ${FILESDIR}/PDPs ${KSITS_DOCDIR}
+ @ ${ECHO} !!! KLH10 contains a setuid that accepts network connections.
+ @ ${ECHO} !!! Consider using a firewall to limit access to KLH10.
+ @ ${ECHO} !!! See the ${KSITS_DOCDIR}/pubits/adm
+ @ ${ECHO} !!! for firewall documentation.
+
+.include <bsd.port.mk>
diff --git a/emulators/klh10/distinfo b/emulators/klh10/distinfo
new file mode 100644
index 000000000000..6fe33f346539
--- /dev/null
+++ b/emulators/klh10/distinfo
@@ -0,0 +1,2 @@
+MD5 (klh10-2.0a.tgz) = a79f63c3351c23fb5b805220e452cc50
+MD5 (klh10-2.0a-aux.tgz) = b54d8341ded187a79899d202f18d605f
diff --git a/emulators/klh10/files/PDPs b/emulators/klh10/files/PDPs
new file mode 100644
index 000000000000..6e8884a3e083
--- /dev/null
+++ b/emulators/klh10/files/PDPs
@@ -0,0 +1,32 @@
+Year 18-bitters 12-bitters 16-bitters 36-bitters
+
+1960 PDP-1 --------------------------------------------------------
+1961 | \
+1962 PDP-4 <--- LINC -------- \
+1963 | PDP-5 \ \ |
+1964 PDP-7 | \ \ PDP-6
+1965 | PDP-8 --\ | \ |
+1966 | PDP-8/S LINC-8 | |
+1967 | | | | KA10
+1968 PDP-9 PDP-8/I,L | | |
+1969 | | PDP-12 | |
+1970 PDP-15 | PDP-14 PDP-11(/20) |
+1971 | PDP-8/E / | \ |
+1972 PDP-15/76 PDP-8/M - PDP-11/05 | PDP-11/45 -- KI10
+1973 | / | PDP-11/40 | \ |
+1974 | / | | | \ |
+1975 PDP-8/A PDP-11/03 PDP-11/04 | | PDP-11/70 KL10
+1976 | PDP-11/34 | PDP-11/55 | |
+1977 VT78 | PDP-11/60 | |
+1978 PDP-11/34C VAX-11/780 KS10
+
+The first DEC 36-bit system, the PDP-6, came out in 1964. The PDP-10
+line consisted of the KA which arrived in 1967, the KI in 1972. The
+KL came out early in 1974; the KS was a 1978 entry. In 1984 the
+unreleased KC was canceled.
+
+Source: C.G. Bell, et al's "Computer Engineering" 1978 (mostly)
+
+More at
+
+http://groups.google.com/groups?selm=346s0s%24icv%40tardis.Tymnet.COM
diff --git a/emulators/klh10/files/patch-aa b/emulators/klh10/files/patch-aa
new file mode 100644
index 000000000000..d3079d97bc85
--- /dev/null
+++ b/emulators/klh10/files/patch-aa
@@ -0,0 +1,12 @@
+--- src/Mk-fbx86.mk.DIST Sat Jan 12 15:40:10 2002
++++ src/Mk-fbx86.mk Sat Jan 12 15:40:55 2002
+@@ -21,7 +21,7 @@
+
+ # Build definitions
+ SRC = ../../src
+-CFLAGS = -c -g3 -O -I. -I$(SRC)
++CFLAGS += -c -g3 -O -I. -I$(SRC)
+ CFLAGS_LINT = -ansi -pedantic -Wall -Wshadow \
+ -Wstrict-prototypes -Wmissing-prototypes \
+ -Wmissing-declarations -Wredundant-decls
+
diff --git a/emulators/klh10/files/patch-ab b/emulators/klh10/files/patch-ab
new file mode 100644
index 000000000000..70c3a5dbac9a
--- /dev/null
+++ b/emulators/klh10/files/patch-ab
@@ -0,0 +1,25 @@
+--- src/vmtape.c 2002/01/12 16:47:42 1.1
++++ src/vmtape.c 2002/01/12 16:48:35
+@@ -696,13 +696,11 @@
+
+ /* Now verify filenames don't already exist */
+ if (cfn && (cf = fopen(cfn, "r"))) {
+- fclose(cf);
+ vmterror(t, "Tape control file \"%.256s\" already exists", cfn);
+ goto badret;
+ }
+
+ if (df = fopen(dfn, "rb")) {
+- fclose(df);
+ vmterror(t, "Tape data file \"%.256s\" already exists", dfn);
+ goto badret;
+ }
+@@ -714,8 +712,6 @@
+ goto badret;
+ }
+ if (!(df = fopen(dfn, "w+b"))) {
+- fclose(df);
+- if (cfn) fclose(cf);
+ vmterror(t, "Cannot create tape data file \"%.256s\": %.80s",
+ dfn, os_strerror(errno));
+ goto badret;
diff --git a/emulators/klh10/pkg-comment b/emulators/klh10/pkg-comment
new file mode 100644
index 000000000000..3fec37868ec8
--- /dev/null
+++ b/emulators/klh10/pkg-comment
@@ -0,0 +1 @@
+Emulator for DEC PDP-10
diff --git a/emulators/klh10/pkg-descr b/emulators/klh10/pkg-descr
new file mode 100644
index 000000000000..fda7e484da70
--- /dev/null
+++ b/emulators/klh10/pkg-descr
@@ -0,0 +1,22 @@
+This is a port of Kenneth L. Harrenstien's KLH10 DEC PDP-10 mainframe
+emulator.
+
+For information about PDP-10 see WWW: http://www.inwap.com/pdp10/
+
+This port currently only builds klh10 in the ksits configuration for
+running MIT Incompatible Timesharing System (ITS.) Future release
+will configure KLH10 for additional systems.
+
+Warning: to make use of KLH10 over a LAN the network driver
+subprocesses (currently only dpimp is built and installed
+automatically) must run as root in order use the tun(4) network
+interface and to insert proxy ARP table entries. If you do not want
+dpimp to be setuid root you must run the emulator from the root
+account to use networking. KLH10 may be run without networking and
+only provide console access to a single user without using any root
+privileges. We do not know if KLH10's network driver subprocesses
+have been audited for buffer overflows, etc only that they accept
+incoming TCP connections and require root privileges. You take your
+chances running this in the default configuration. Consider using a
+firewall to limit access to klh-10. See the pub-its/adm directory for
+firewall documentation.
diff --git a/emulators/klh10/pkg-message b/emulators/klh10/pkg-message
new file mode 100644
index 000000000000..17c01bc52818
--- /dev/null
+++ b/emulators/klh10/pkg-message
@@ -0,0 +1,4 @@
+KLH10 contains a setuid that accepts network connections.
+Consider using a firewall to limit access to KLH10.
+See the /home/edwin/ports/local5/share/doc/klh10-ks-its/pubits/adm
+for firewall documentation.
diff --git a/emulators/klh10/pkg-plist b/emulators/klh10/pkg-plist
new file mode 100644
index 000000000000..e6cc87e4d68b
--- /dev/null
+++ b/emulators/klh10/pkg-plist
@@ -0,0 +1,49 @@
+bin/kn10-ks
+bin/tapedd
+bin/udlconv
+bin/vdkfmt
+bin/wfconv
+bin/wxtest
+libexec/klh10-ks-its/dpimp
+libexec/klh10-ks-its/dprpxx
+libexec/klh10-ks-its/dptm03
+share/klh10-ks-its/@.ddt-u
+share/klh10-ks-its/@.its-647kn-u
+share/klh10-ks-its/@.nsalv-260-u
+share/klh10-ks-its/itsbin.647kn-u
+share/klh10-ks-its/klh10-kn.ini
+%%PORTDOCS%%share/doc/klh10-ks-its/pubits/adm/hosts.its
+%%PORTDOCS%%share/doc/klh10-ks-its/pubits/adm/its.ipfw
+%%PORTDOCS%%share/doc/klh10-ks-its/pubits/adm/rc.firewall-its
+%%PORTDOCS%%share/doc/klh10-ks-its/pubits/adm/router.notes
+%%PORTDOCS%%share/doc/klh10-ks-its/pubits/doc/bootload.files
+%%PORTDOCS%%share/doc/klh10-ks-its/pubits/doc/distrib.its
+%%PORTDOCS%%share/doc/klh10-ks-its/pubits/doc/dumpsys.help
+%%PORTDOCS%%share/doc/klh10-ks-its/Intro.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/backgrnd.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/cmdref.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/cmdsum.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/coding.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/dfkfb.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/dvhost.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/history.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/install.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/kldiff.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/klt10.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/klt20.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/ksits.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/kst10.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/kst20.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/news.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/PDPs
+%%PORTDOCS%%share/doc/klh10-ks-its/README
+%%PORTDOCS%%share/doc/klh10-ks-its/usage.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/utils.txt
+%%PORTDOCS%%share/doc/klh10-ks-its/vtape.txt
+@dirrm share/klh10-ks-its/flushed
+@dirrm share/klh10-ks-its
+@dirrm libexec/klh10-ks-its
+%%PORTDOCS%%@dirrm share/doc/klh10-ks-its/pubits/adm
+%%PORTDOCS%%@dirrm share/doc/klh10-ks-its/pubits/doc
+%%PORTDOCS%%@dirrm share/doc/klh10-ks-its/pubits
+%%PORTDOCS%%@dirrm share/doc/klh10-ks-its