aboutsummaryrefslogtreecommitdiff
path: root/emulators/libspectrum
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-10-29 16:19:28 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-10-29 16:19:28 +0000
commit6098698feace84a611f0e877a6c0d556b2a59400 (patch)
tree4fbb00919c47fa7c121b0af1671fe3899aabe52e /emulators/libspectrum
parent777967b433a765c6bdb0525e4079d32787253f33 (diff)
downloadports-6098698feace84a611f0e877a6c0d556b2a59400.tar.gz
ports-6098698feace84a611f0e877a6c0d556b2a59400.zip
Add libspectrum 0.2.0.1, handling of ZX-Spectrum emulator files formats.
libspectrum is a fairly simple library designed to make the handling of various ZX Spectrum emulator-related file formats easy. So far it handles: * Snapshots: .z80, .szx, .sna (all read/write), .zxs, .sp., .snp and +D snapshots (read only) * Tape images: .tzx, .tap (read/write) and Warajevo .tap (read only) * Input recordings: .rzx (read/write) * Timex cartridges: .dck (read only) There are also some subsidiary functions which may be generally useful for Spectrum-related utilities. Author: Philip Kendall <pak21-spectrum@srcf.ucam.org> WWW: http://www.srcf.ucam.org/~pak21/spectrum/libspectrum.html PR: 58638 Submitted by: Alexey V. Antipovsky <kemm@in-line.ru>
Notes
Notes: svn path=/head/; revision=92573
Diffstat (limited to 'emulators/libspectrum')
-rw-r--r--emulators/libspectrum/Makefile48
-rw-r--r--emulators/libspectrum/distinfo1
-rw-r--r--emulators/libspectrum/pkg-descr18
-rw-r--r--emulators/libspectrum/pkg-plist12
4 files changed, 79 insertions, 0 deletions
diff --git a/emulators/libspectrum/Makefile b/emulators/libspectrum/Makefile
new file mode 100644
index 000000000000..0b71b42c0a5c
--- /dev/null
+++ b/emulators/libspectrum/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: libspectrum
+# Date created: 2003-10-27
+# Whom: Alexey V. Antipovsky <kemm@in-line.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libspectrum
+PORTVERSION= 0.2.0.1
+CATEGORIES= emulators devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fuse-emulator
+
+MAINTAINER= kemm@in-line.ru
+COMMENT= Handling of ZX-Spectrum emulator files formats
+
+USE_PERL5_BUILD= yes
+USE_GNOME= glib12
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+.if !defined(WITHOUT_GLIB)
+USE_GNOME= glib12
+.else
+CONFIGURE_ARGS= --without-glib
+.endif
+
+.if defined(WITH_GCRYPT) || exists(${LOCALBASE}/include/gcrypt.h)
+LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
+.endif
+
+DOCS= AUTHORS ChangeLog README THANKS doc/*
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_GLIB=yes don't use GLib"
+ @${ECHO_MSG} " WITH_GCRYPT=yes use libgcrypt"
+ @${ECHO_MSG} ""
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/emulators/libspectrum/distinfo b/emulators/libspectrum/distinfo
new file mode 100644
index 000000000000..efe096d062b7
--- /dev/null
+++ b/emulators/libspectrum/distinfo
@@ -0,0 +1 @@
+MD5 (libspectrum-0.2.0.1.tar.gz) = 576f41f0c7db0c7c34a447db4a11f22a
diff --git a/emulators/libspectrum/pkg-descr b/emulators/libspectrum/pkg-descr
new file mode 100644
index 000000000000..037bbb52b799
--- /dev/null
+++ b/emulators/libspectrum/pkg-descr
@@ -0,0 +1,18 @@
+libspectrum is a fairly simple library designed to make the handling
+of various ZX Spectrum emulator-related file formats easy.
+So far it handles:
+
+* Snapshots: .z80, .szx, .sna (all read/write), .zxs, .sp.,
+ .snp and +D snapshots (read only)
+* Tape images: .tzx, .tap (read/write) and Warajevo .tap (read only)
+* Input recordings: .rzx (read/write)
+* Timex cartridges: .dck (read only)
+
+There are also some subsidiary functions which may be generally useful
+for Spectrum-related utilities.
+
+Author: Philip Kendall <pak21-spectrum@srcf.ucam.org>
+WWW: http://www.srcf.ucam.org/~pak21/spectrum/libspectrum.html
+--
+Alexey V. Antipovsky
+kemm@in-line.ru
diff --git a/emulators/libspectrum/pkg-plist b/emulators/libspectrum/pkg-plist
new file mode 100644
index 000000000000..86fab81705ab
--- /dev/null
+++ b/emulators/libspectrum/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+include/libspectrum.h
+lib/libspectrum.a
+lib/libspectrum.la
+lib/libspectrum.so
+lib/libspectrum.so.2
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/libspectrum.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%