aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-geepee32
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-26 23:54:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-26 23:54:19 +0000
commitcad561d693be20272861725c7bef63628eecdfbd (patch)
tree579bfb3b6268a88581815e8b39a38977eba3c981 /emulators/linux-geepee32
parent34e9c562a2d51e51b86811e30c4f40dabdfa2d5d (diff)
downloadports-cad561d693be20272861725c7bef63628eecdfbd.tar.gz
ports-cad561d693be20272861725c7bef63628eecdfbd.zip
Add linux-geepee32, a linux binary version of GP32 emulator. GP32 is
a handheld used mainly in Korea. PR: ports/57685 Submitted by: No Name <arundel@gmx.net>
Notes
Notes: svn path=/head/; revision=96657
Diffstat (limited to 'emulators/linux-geepee32')
-rw-r--r--emulators/linux-geepee32/Makefile45
-rw-r--r--emulators/linux-geepee32/distinfo1
-rw-r--r--emulators/linux-geepee32/files/geepee32.sh6
-rw-r--r--emulators/linux-geepee32/pkg-descr9
-rw-r--r--emulators/linux-geepee32/pkg-plist5
5 files changed, 66 insertions, 0 deletions
diff --git a/emulators/linux-geepee32/Makefile b/emulators/linux-geepee32/Makefile
new file mode 100644
index 000000000000..80553ddc0ac3
--- /dev/null
+++ b/emulators/linux-geepee32/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: geepee32
+# Date Created: 05 October 2003
+# Whom: <arundel@gmx.net>
+#
+# $FreeBSD$
+
+PORTNAME= geepee32
+PORTVERSION= 30
+CATEGORIES= emulators linux
+MASTER_SITES= http://users.skynet.be/firefly/gp32/project/geepee32/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}_linux_sdl_${PORTVERSION}
+
+MAINTAINER= arundel@gmx.net
+COMMENT= The only GP32 emulator for x86 archs
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_XLIB= yes
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+
+TARGET_DIR= ${PREFIX}/geepee32
+
+STRIP=
+PROG_FILES= ${WRKDIR}/geepee32
+DATA_FILES= ${FILESDIR}/geepee32.sh
+
+do-build:
+
+do-install:
+ ${INSTALL} -d -m 777 ${TARGET_DIR} && \
+ ${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR} && \
+ ${INSTALL_SCRIPT} ${DATA_FILES} ${TARGET_DIR}
+
+post-install:
+ ${TOUCH} ${TARGET_DIR}/iic.bin && \
+ ${LN} -s ${TARGET_DIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Please don't mail us with requests for ROM dump."
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
diff --git a/emulators/linux-geepee32/distinfo b/emulators/linux-geepee32/distinfo
new file mode 100644
index 000000000000..fe4296dcfbf9
--- /dev/null
+++ b/emulators/linux-geepee32/distinfo
@@ -0,0 +1 @@
+MD5 (geepee32_linux_sdl_30.zip) = 205959874ee2355265b119ff008a0ca7
diff --git a/emulators/linux-geepee32/files/geepee32.sh b/emulators/linux-geepee32/files/geepee32.sh
new file mode 100644
index 000000000000..ec3ffc1fafff
--- /dev/null
+++ b/emulators/linux-geepee32/files/geepee32.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+# Needed to make symlinks/shortcuts work.
+# Wrap geepee32 binary
+cd "/usr/local/geepee32//"
+./geepee32 $*
+exit $?
diff --git a/emulators/linux-geepee32/pkg-descr b/emulators/linux-geepee32/pkg-descr
new file mode 100644
index 000000000000..98253c46202c
--- /dev/null
+++ b/emulators/linux-geepee32/pkg-descr
@@ -0,0 +1,9 @@
+What is it ?
+GeePee32 is a GP32 emulator that emulates the Korean GP32 handheld
+(http://www.gp32.com).
+
+Firmware:
+The emulator needs a GP32 firmware dump in order to work. I do not
+have permission from Gamepark Inc. to distrubute this file :(
+
+WWW: http://users.skynet.be/firefly/gp32/geepee32/
diff --git a/emulators/linux-geepee32/pkg-plist b/emulators/linux-geepee32/pkg-plist
new file mode 100644
index 000000000000..9cc1ed427d31
--- /dev/null
+++ b/emulators/linux-geepee32/pkg-plist
@@ -0,0 +1,5 @@
+geepee32/geepee32
+geepee32/geepee32.sh
+geepee32/iic.bin
+bin/geepee32
+@dirrm geepee32