aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-xjoypad/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-05-28 12:58:56 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-05-28 12:58:56 +0000
commitf2873e98ea159800284360de0c217614361c1906 (patch)
tree9e539727d8f69714281cfc382e76208102c562b3 /emulators/linux-xjoypad/Makefile
parent2ed32ea5d59a87d3942ca679fa23f4a57080d4f8 (diff)
downloadports-f2873e98ea159800284360de0c217614361c1906.tar.gz
ports-f2873e98ea159800284360de0c217614361c1906.zip
New Port: emulators/xjoypad
xjoypad allows an USB joypad (probably a USB Joystick, too) to be used with games on linux (probably other unix-like operating systems too). This is done by mapping the joypad events to X keyboard events which are sent to the window currently having the focus. Therefore only keyboard-controlled games are currently supported by xjoypad. xjoypad was written to add joypad support to the playstation emulator epsxe. PR: ports/95990 Submitted by: Timothy Beyer <beyert@cs.ucr.edu>
Notes
Notes: svn path=/head/; revision=213808
Diffstat (limited to 'emulators/linux-xjoypad/Makefile')
-rw-r--r--emulators/linux-xjoypad/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/emulators/linux-xjoypad/Makefile b/emulators/linux-xjoypad/Makefile
new file mode 100644
index 000000000000..08431cc8f01f
--- /dev/null
+++ b/emulators/linux-xjoypad/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: linux-xjoypad
+# Date created: 17 Apr 2006
+# Whom: Timothy Beyer <beyert@cs.ucr.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xjoypad
+PORTVERSION= 1
+PORTREVISION= 1
+CATEGORIES= emulators linux
+MASTER_SITES= http://members.chello.at/erich.kitzmueller/ammoq/down/
+PKGNAMEPREFIX= linux-
+DISTNAME= xjoypad
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Joy-Device to X mapping (lets you play Linux games with a joypad)
+
+BUILD_DEPENDS= ${X11BASE}/lib/libX11.a:${PORTSDIR}/x11/libX11
+RUN_DEPENDS= /boot/modules/linux_js.ko:${PORTSDIR}/devel/linux-js
+
+USE_XORG= x11
+WRKSRC= ${WRKDIR}/xjoypad/
+USE_LINUX= yes
+USE_X_PREFIX= yes
+USE_ZIP= yes
+
+FILES= xjoypad.c sendevent.c
+CFLAGS+= -I ${PREFIX}/include
+LIB_X11= ${PREFIX}/lib/libX11.a
+LIB_XAU= ${PREFIX}/lib/libXau.a
+LIB_XDMCP= ${PREFIX}/lib/libXdmcp.a
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -o xjoypad ${FILES} -lcompat -lm ${LIB_X11} ${LIB_XAU} ${LIB_XDMCP})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xjoypad ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.endif
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>