aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-8
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
commit64cf27c85d89298041b8c8dc2fd090181e6d10d8 (patch)
tree11668b893f94453b0262a155d53e6eac8dd4a6f5 /emulators/linux_base-8
parent440d8863c8d496b982754e2a71867892213a902b (diff)
downloadports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.tar.gz
ports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.zip
Say hello to the linux mega patch, it consolidates our linux bits a
little bit and allows to proceed to a more recent linux_base from a stable (read as: the major bugs should be ironed out or identified and most linux ports build just fine) source. It also allows to ship 4.11 with a working linuxolator (the EOLed linux_base is marked forbidden because of a security hole). This is a major update, please read UPDATING (and CHANGES if you develop linux ports). Changes: - change the default linux_base from v7 to v8 - add a newer freetype to linux_base-8 for nicer fonts display [1] - don't let cpio use hardlinks in the linux_base-8 port to quiet some warnings in some cases [2] - fix a cut&past error in the linux_base-8 pkg-install script [3] - convert the binary knob "USE_LINUX" to a version specifier, e.g. USE_LINUX=<value> specifies a dependency upon emulators/linux_base-<value>, exceptions are a value of "7" (which does what you want and adds a dependency to linux_base) and any value without a corresponding port in PORTSDIR/emulators/linux_base-<value> (which adds a dependency to the default linux_base) - don't implicitly add USE_LINUX with the USE_LINUX_PREFIX knob, this allows us to use the USE_LINUX_PREFIX knob for linux_base and paves the way for splitting up future linux base ports into individual pieces - remove RESTRICTED from some GPL licensed ports, even when we only distribute binaries, we get them from official linux sites, so anyone can grab them there if he needs to - add a dependency upon the linux X11 bits where necessary (based upon guesswork) - don't use USE_X_PREFIX in some linux ports since it adds a dependency to the FreeBSD X11 libs, as a workaround use PREFIX?= (the clean solution would be to remove the implicit USE_XLIB from USE_X_PREFIX) - bump the portrevision of the linux ports ("better safe than sorry" algorithm) - pass maintainership of the important linux infrastructure to a mailinglist, hijack freebsd-emulation@ for this purpose (if somebody doesn't like this: tell us your bikeshed color at freebsd-emulation@, my color would be "linuxolator@" in case someone cares...) - add a pkg-install script for linux-fontconfig, but don't use it; everything should work without it (the FreeBSD fc-cache program should do all the work), but in case we need it we just need to decomment the pkg-install part in the Makefile - fix some dependencies - fix some bugs - add some static plists - unbreak the ports with dependecies to more than one linux_base This also fixes some ports which are marked BROKEN because of dependencies to v7 and v8 of linux_base at the same time. Known bugs: - the linux-mesa and linux-devtools ports install libGL*.so symlinks - some "minor" plist bugs (e.g. ld.so.{conf,cache} are modified by the linux X11 port, so linx_Base-8 moans at deinstall time) Future work (interested souls should coordinate with freebsd-emulation@): - add some kind of USE_LINUX_X11 knob to streamline the X11 dependencies, or modify the behavior of USE_XLIB in the USE_LINUX case AFAIK trevor has some patches. - make USE_XLIB and USE_X_PREFIX orthogonal to be able to get rid of the PREFIX?= workaround in some linux ports Should be discussed/coordinated on/with x11@. - move the RPM bits from x11-toolkits/linux-gtk/Makefile to PORTSDIR/Mk/ - update to a more recent linux base PR: 69997, 70539 (and maybe others) Discussed with/on: java@, x11@, trevor, portmgr Tested by: mezz, portmgr, pointyhat RPM hunted down by: Joseph Gelinas <scirocco@tasam.com> [1] Requested by: portmgr [2] Submitted by: kris [3] Approved by: portmgr
Notes
Notes: svn path=/head/; revision=125613
Diffstat (limited to 'emulators/linux_base-8')
-rw-r--r--emulators/linux_base-8/Makefile12
-rw-r--r--emulators/linux_base-8/distinfo.i386101
-rw-r--r--emulators/linux_base-8/pkg-install2
3 files changed, 57 insertions, 58 deletions
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index 78b63856a9b7..03fec8706fda 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -11,7 +11,8 @@ PORTVERSION= 8.0
PORTREVISION= 4
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX} \
- ${MASTER_SITE_REDHAT_LINUX:S/$/:new/}
+ ${MASTER_SITE_REDHAT_LINUX:S/$/:new/} \
+ ftp://mirror.switch.ch/mirror/ximian/mono/redhat-80-i386/:ft
MASTER_SITE_SUBDIR= \
${PORTVERSION}/${LANG}/os/${ARCH}/RedHat/RPMS \
updates/${PORTVERSION}/${LANG}/os/${ARCH}/:new
@@ -46,17 +47,16 @@ DISTFILES= redhat-release-8.0-8.noarch.rpm \
sh-utils-2.0.12-3.${ARCH}.rpm \
rpm-4.1-1.06.${ARCH}.rpm \
libgcc-3.2-7.${ARCH}.rpm \
- freetype-2.1.2-7.${ARCH}.rpm \
+ freetype-2.1.5-0.ximian.5.1.${ARCH}.rpm:ft \
zlib-1.1.4-8.8x.${ARCH}.rpm:new
-MAINTAINER= trevor@FreeBSD.org
+MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Base set of packages needed in Linux mode (only for i386)
EXTRACT_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
CONFLICTS= linux_base-6* linux_base-7* linux_base-deb* linux_base-gen* \
linux_base-rh* linux_base-suse*
-RESTRICTED= "binaries under GNU GPL without accompanying source"
ONLY_FOR_ARCHS= i386 amd64
DIST_SUBDIR= rpm/${ARCH}/${PORTVERSION}
PREFIX= ${LINUXBASE}
@@ -120,7 +120,7 @@ do-extract:
# Also, set the ELF fallback brand to Linux, so that we don't have to do
# anything special to run staticly linked binaries.
@/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${LINUX_ELF}
- @for R in ${DISTFILES:S/:new//}; do \
+ @for R in ${DISTFILES:S/:new//:S/:ft//}; do \
${ECHO} $$R; \
${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
@@ -153,7 +153,7 @@ pre-install:
&& ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
do-install:
- cd ${WRKSRC} && ${FIND} * | ${CPIO} -dlmp ${PREFIX}
+ cd ${WRKSRC} && ${FIND} * | ${CPIO} -dmp ${PREFIX}
${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
post-install:
diff --git a/emulators/linux_base-8/distinfo.i386 b/emulators/linux_base-8/distinfo.i386
index e1eecaff526c..d27c0a61b44c 100644
--- a/emulators/linux_base-8/distinfo.i386
+++ b/emulators/linux_base-8/distinfo.i386
@@ -1,67 +1,66 @@
-$FreeBSD$
+MD5 (rpm/i386/8.0/redhat-release-8.0-8.noarch.rpm) = 7cbf42500f3f91c7df1e1495b5f1ee1d
+SIZE (rpm/i386/8.0/redhat-release-8.0-8.noarch.rpm) = 391224
+MD5 (rpm/i386/8.0/glibc-common-2.3.2-4.80.8.i386.rpm) = 62019c1ecff44880be70871a9b52c4bc
+SIZE (rpm/i386/8.0/glibc-common-2.3.2-4.80.8.i386.rpm) = 12526068
+MD5 (rpm/i386/8.0/glibc-2.3.2-4.80.8.i386.rpm) = 8058c50430bca5ee527c3521b8cd5019
+SIZE (rpm/i386/8.0/glibc-2.3.2-4.80.8.i386.rpm) = 3121676
+MD5 (rpm/i386/8.0/setup-2.5.20-1.noarch.rpm) = 94168e9cd5d2c6601167d55e50e70bc0
+SIZE (rpm/i386/8.0/setup-2.5.20-1.noarch.rpm) = 27220
+MD5 (rpm/i386/8.0/filesystem-2.1.6-5.noarch.rpm) = f9f4c4e31668216e5cd98c05c3e4751f
+SIZE (rpm/i386/8.0/filesystem-2.1.6-5.noarch.rpm) = 12340
MD5 (rpm/i386/8.0/basesystem-8.0-1.noarch.rpm) = d66629eeffdc61de69395be8c43f4f7d
-MD5 (rpm/i386/8.0/bash-2.05b-5.i386.rpm) = ffea80578086373dda7d7e98ec42b294
-MD5 (rpm/i386/8.0/bzip2-1.0.2-5.i386.rpm) = 05674cb719aef022396581808669105d
+SIZE (rpm/i386/8.0/basesystem-8.0-1.noarch.rpm) = 2565
+MD5 (rpm/i386/8.0/libattr-2.0.8-3.i386.rpm) = 6e96282afe6ebaf2caf2d0022f5e7063
+SIZE (rpm/i386/8.0/libattr-2.0.8-3.i386.rpm) = 16741
+MD5 (rpm/i386/8.0/libacl-2.0.11-2.i386.rpm) = 4c925ae8eb502c2102e7fcee40e78b3e
+SIZE (rpm/i386/8.0/libacl-2.0.11-2.i386.rpm) = 69938
+MD5 (rpm/i386/8.0/libelf-0.8.2-2.i386.rpm) = 7a4ea791d46ca45f9e398a9732216c17
+SIZE (rpm/i386/8.0/libelf-0.8.2-2.i386.rpm) = 41069
MD5 (rpm/i386/8.0/bzip2-libs-1.0.2-5.i386.rpm) = a96d125105d1eb56c0b71bc699b84288
+SIZE (rpm/i386/8.0/bzip2-libs-1.0.2-5.i386.rpm) = 34311
+MD5 (rpm/i386/8.0/termcap-11.0.1-13.noarch.rpm) = 80354e467c784ad660edcd9ec9eb0148
+SIZE (rpm/i386/8.0/termcap-11.0.1-13.noarch.rpm) = 241495
MD5 (rpm/i386/8.0/compat-db-3.3.11-2.i386.rpm) = c8ec0b5bce196a8f6dcc2b559d5fd625
-MD5 (rpm/i386/8.0/compat-libstdc++-7.3-2.96.110.i386.rpm) = 298aaa504398f2b7298f805e4f751afe
+SIZE (rpm/i386/8.0/compat-db-3.3.11-2.i386.rpm) = 2830894
MD5 (rpm/i386/8.0/db4-4.0.14-14.i386.rpm) = 2b31e1ac5ccc23f0dbd37e299ed91661
-MD5 (rpm/i386/8.0/filesystem-2.1.6-5.noarch.rpm) = f9f4c4e31668216e5cd98c05c3e4751f
-MD5 (rpm/i386/8.0/fileutils-4.1.9-11.i386.rpm) = 7d6f449488f8e7360c74101c20e4052c
-MD5 (rpm/i386/8.0/freetype-2.1.2-7.i386.rpm) = 1d11846f80741cf629908fff77565c1d
+SIZE (rpm/i386/8.0/db4-4.0.14-14.i386.rpm) = 687874
MD5 (rpm/i386/8.0/gdbm-1.8.0-18.i386.rpm) = 247aa33363cdf4ac0c01a17893221ac7
+SIZE (rpm/i386/8.0/gdbm-1.8.0-18.i386.rpm) = 27594
MD5 (rpm/i386/8.0/glib-1.2.10-8.i386.rpm) = cad221120dd2aa32dbbf274f694e982b
-MD5 (rpm/i386/8.0/glibc-2.3.2-4.80.8.i386.rpm) = 8058c50430bca5ee527c3521b8cd5019
-MD5 (rpm/i386/8.0/glibc-common-2.3.2-4.80.8.i386.rpm) = 62019c1ecff44880be70871a9b52c4bc
-MD5 (rpm/i386/8.0/grep-2.5.1-4.i386.rpm) = d47cb3261cca975b1b177acec30d1b88
-MD5 (rpm/i386/8.0/info-4.2-5.i386.rpm) = d273ca4e7d607f0df77179e6493211fb
-MD5 (rpm/i386/8.0/libacl-2.0.11-2.i386.rpm) = 4c925ae8eb502c2102e7fcee40e78b3e
-MD5 (rpm/i386/8.0/libattr-2.0.8-3.i386.rpm) = 6e96282afe6ebaf2caf2d0022f5e7063
-MD5 (rpm/i386/8.0/libelf-0.8.2-2.i386.rpm) = 7a4ea791d46ca45f9e398a9732216c17
-MD5 (rpm/i386/8.0/libgcc-3.2-7.i386.rpm) = db9ca2ea377a30e7a7ab0c95fb538b00
-MD5 (rpm/i386/8.0/libstdc++-3.2-7.i386.rpm) = 1593270df028b4225818f4cb08cb0b40
+SIZE (rpm/i386/8.0/glib-1.2.10-8.i386.rpm) = 138265
MD5 (rpm/i386/8.0/libtermcap-2.0.8-31.i386.rpm) = 64426510f27078a3f35a3a02ee4da7fc
-MD5 (rpm/i386/8.0/ncurses-5.2-28.i386.rpm) = 1240c14ba8fe20b5e9cc8c3591f0a533
-MD5 (rpm/i386/8.0/popt-1.7-1.06.i386.rpm) = 158c59ec88320586ce0100b2eec140ab
-MD5 (rpm/i386/8.0/readline-4.3-3.i386.rpm) = 6a41eba752dee08222b99cce58552fea
-MD5 (rpm/i386/8.0/redhat-release-8.0-8.noarch.rpm) = 7cbf42500f3f91c7df1e1495b5f1ee1d
-MD5 (rpm/i386/8.0/rpm-4.1-1.06.i386.rpm) = fc0f9967e7dd7b4bf3f4e1e25d5047aa
-MD5 (rpm/i386/8.0/setserial-2.17-9.i386.rpm) = 132160b9a4718d86eb14b86f780de3a5
-MD5 (rpm/i386/8.0/setup-2.5.20-1.noarch.rpm) = 94168e9cd5d2c6601167d55e50e70bc0
-MD5 (rpm/i386/8.0/sh-utils-2.0.12-3.i386.rpm) = 1b9d53f5a86d2dcb1ed7ce2647274476
-MD5 (rpm/i386/8.0/slang-1.4.5-11.i386.rpm) = eb551fe40c244f750c089d6d450cd0e7
-MD5 (rpm/i386/8.0/termcap-11.0.1-13.noarch.rpm) = 80354e467c784ad660edcd9ec9eb0148
-MD5 (rpm/i386/8.0/zlib-1.1.4-8.8x.i386.rpm) = fb1db2a01b5366cb40f98fda4507024e
-SIZE (rpm/i386/8.0/basesystem-8.0-1.noarch.rpm) = 2565
+SIZE (rpm/i386/8.0/libtermcap-2.0.8-31.i386.rpm) = 11472
+MD5 (rpm/i386/8.0/bash-2.05b-5.i386.rpm) = ffea80578086373dda7d7e98ec42b294
SIZE (rpm/i386/8.0/bash-2.05b-5.i386.rpm) = 746649
+MD5 (rpm/i386/8.0/bzip2-1.0.2-5.i386.rpm) = 05674cb719aef022396581808669105d
SIZE (rpm/i386/8.0/bzip2-1.0.2-5.i386.rpm) = 45007
-SIZE (rpm/i386/8.0/bzip2-libs-1.0.2-5.i386.rpm) = 34311
-SIZE (rpm/i386/8.0/compat-db-3.3.11-2.i386.rpm) = 2830894
+MD5 (rpm/i386/8.0/compat-libstdc++-7.3-2.96.110.i386.rpm) = 298aaa504398f2b7298f805e4f751afe
SIZE (rpm/i386/8.0/compat-libstdc++-7.3-2.96.110.i386.rpm) = 1051183
-SIZE (rpm/i386/8.0/db4-4.0.14-14.i386.rpm) = 687874
-SIZE (rpm/i386/8.0/filesystem-2.1.6-5.noarch.rpm) = 12340
-SIZE (rpm/i386/8.0/fileutils-4.1.9-11.i386.rpm) = 990084
-SIZE (rpm/i386/8.0/freetype-2.1.2-7.i386.rpm) = 587226
-SIZE (rpm/i386/8.0/gdbm-1.8.0-18.i386.rpm) = 27594
-SIZE (rpm/i386/8.0/glib-1.2.10-8.i386.rpm) = 138265
-SIZE (rpm/i386/8.0/glibc-2.3.2-4.80.8.i386.rpm) = 3121676
-SIZE (rpm/i386/8.0/glibc-common-2.3.2-4.80.8.i386.rpm) = 12526068
-SIZE (rpm/i386/8.0/grep-2.5.1-4.i386.rpm) = 187800
-SIZE (rpm/i386/8.0/info-4.2-5.i386.rpm) = 166638
-SIZE (rpm/i386/8.0/libacl-2.0.11-2.i386.rpm) = 69938
-SIZE (rpm/i386/8.0/libattr-2.0.8-3.i386.rpm) = 16741
-SIZE (rpm/i386/8.0/libelf-0.8.2-2.i386.rpm) = 41069
-SIZE (rpm/i386/8.0/libgcc-3.2-7.i386.rpm) = 111856
-SIZE (rpm/i386/8.0/libstdc++-3.2-7.i386.rpm) = 1478392
-SIZE (rpm/i386/8.0/libtermcap-2.0.8-31.i386.rpm) = 11472
+MD5 (rpm/i386/8.0/ncurses-5.2-28.i386.rpm) = 1240c14ba8fe20b5e9cc8c3591f0a533
SIZE (rpm/i386/8.0/ncurses-5.2-28.i386.rpm) = 852255
+MD5 (rpm/i386/8.0/info-4.2-5.i386.rpm) = d273ca4e7d607f0df77179e6493211fb
+SIZE (rpm/i386/8.0/info-4.2-5.i386.rpm) = 166638
+MD5 (rpm/i386/8.0/grep-2.5.1-4.i386.rpm) = d47cb3261cca975b1b177acec30d1b88
+SIZE (rpm/i386/8.0/grep-2.5.1-4.i386.rpm) = 187800
+MD5 (rpm/i386/8.0/fileutils-4.1.9-11.i386.rpm) = 7d6f449488f8e7360c74101c20e4052c
+SIZE (rpm/i386/8.0/fileutils-4.1.9-11.i386.rpm) = 990084
+MD5 (rpm/i386/8.0/popt-1.7-1.06.i386.rpm) = 158c59ec88320586ce0100b2eec140ab
SIZE (rpm/i386/8.0/popt-1.7-1.06.i386.rpm) = 69622
+MD5 (rpm/i386/8.0/readline-4.3-3.i386.rpm) = 6a41eba752dee08222b99cce58552fea
SIZE (rpm/i386/8.0/readline-4.3-3.i386.rpm) = 193685
-SIZE (rpm/i386/8.0/redhat-release-8.0-8.noarch.rpm) = 391224
-SIZE (rpm/i386/8.0/rpm-4.1-1.06.i386.rpm) = 2220042
+MD5 (rpm/i386/8.0/setserial-2.17-9.i386.rpm) = 132160b9a4718d86eb14b86f780de3a5
SIZE (rpm/i386/8.0/setserial-2.17-9.i386.rpm) = 21432
-SIZE (rpm/i386/8.0/setup-2.5.20-1.noarch.rpm) = 27220
-SIZE (rpm/i386/8.0/sh-utils-2.0.12-3.i386.rpm) = 250662
+MD5 (rpm/i386/8.0/libstdc++-3.2-7.i386.rpm) = 1593270df028b4225818f4cb08cb0b40
+SIZE (rpm/i386/8.0/libstdc++-3.2-7.i386.rpm) = 1478392
+MD5 (rpm/i386/8.0/slang-1.4.5-11.i386.rpm) = eb551fe40c244f750c089d6d450cd0e7
SIZE (rpm/i386/8.0/slang-1.4.5-11.i386.rpm) = 196297
-SIZE (rpm/i386/8.0/termcap-11.0.1-13.noarch.rpm) = 241495
+MD5 (rpm/i386/8.0/sh-utils-2.0.12-3.i386.rpm) = 1b9d53f5a86d2dcb1ed7ce2647274476
+SIZE (rpm/i386/8.0/sh-utils-2.0.12-3.i386.rpm) = 250662
+MD5 (rpm/i386/8.0/rpm-4.1-1.06.i386.rpm) = fc0f9967e7dd7b4bf3f4e1e25d5047aa
+SIZE (rpm/i386/8.0/rpm-4.1-1.06.i386.rpm) = 2220042
+MD5 (rpm/i386/8.0/libgcc-3.2-7.i386.rpm) = db9ca2ea377a30e7a7ab0c95fb538b00
+SIZE (rpm/i386/8.0/libgcc-3.2-7.i386.rpm) = 111856
+MD5 (rpm/i386/8.0/freetype-2.1.5-0.ximian.5.1.i386.rpm) = bf0bb06fcc300b0087ef5d602ecde088
+SIZE (rpm/i386/8.0/freetype-2.1.5-0.ximian.5.1.i386.rpm) = 593618
+MD5 (rpm/i386/8.0/zlib-1.1.4-8.8x.i386.rpm) = fb1db2a01b5366cb40f98fda4507024e
SIZE (rpm/i386/8.0/zlib-1.1.4-8.8x.i386.rpm) = 36749
diff --git a/emulators/linux_base-8/pkg-install b/emulators/linux_base-8/pkg-install
index b4d717c72915..5870edf05835 100644
--- a/emulators/linux_base-8/pkg-install
+++ b/emulators/linux_base-8/pkg-install
@@ -26,7 +26,7 @@ POST-INSTALL)
echo 'Re-mounting linprocfs...'
mount linprocfs
fi
- if [ -n "`grep -w ^linprocfs /etc/fstab`" ]; then
+ if [ -n "`grep -w ^linproc /etc/fstab`" ]; then
echo 'Re-mounting linproc...'
mount linproc
fi