aboutsummaryrefslogtreecommitdiff
path: root/emulators/loemu
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-03-27 00:19:34 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-03-27 00:19:34 +0000
commit1cea14ecf9d0b55d0d36ad33440aef27e77bc0a6 (patch)
treec13fe1049dcaf292d802be874c85514e8572a411 /emulators/loemu
parent54a0ce75ab5e94bf8c0a605eafe87544e7737dd1 (diff)
downloadports-1cea14ecf9d0b55d0d36ad33440aef27e77bc0a6.tar.gz
ports-1cea14ecf9d0b55d0d36ad33440aef27e77bc0a6.zip
- Remove the detection of some python dependencies from setup.py. It could break
installation of loemu on all FreeBSD versions. Reported by: kris
Notes
Notes: svn path=/head/; revision=188431
Diffstat (limited to 'emulators/loemu')
-rw-r--r--emulators/loemu/Makefile2
-rw-r--r--emulators/loemu/files/patch-setup.py36
2 files changed, 35 insertions, 3 deletions
diff --git a/emulators/loemu/Makefile b/emulators/loemu/Makefile
index a328c0689bf7..123f18cc6649 100644
--- a/emulators/loemu/Makefile
+++ b/emulators/loemu/Makefile
@@ -46,5 +46,7 @@ post-patch:
's|/share/games/|/share/|g' -e \
's|/usr/bin/python|${PYTHON_CMD}|g' "{}" \;
.endfor
+ @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|g' \
+ ${WRKSRC}/setup.py
.include <bsd.port.post.mk>
diff --git a/emulators/loemu/files/patch-setup.py b/emulators/loemu/files/patch-setup.py
index 95fbc938aaf5..3ffb2c347c2b 100644
--- a/emulators/loemu/files/patch-setup.py
+++ b/emulators/loemu/files/patch-setup.py
@@ -1,6 +1,36 @@
---- setup.py.orig Tue Feb 27 14:25:52 2007
-+++ setup.py Tue Feb 27 14:26:23 2007
-@@ -18,14 +18,14 @@
+--- setup.py Sat Mar 17 12:55:11 2007
++++ setup.py Mon Mar 26 19:02:17 2007
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!%%PYTHON_CMD%%
+ from distutils.core import setup
+ from glob import glob
+ import sys
+@@ -6,23 +6,6 @@
+ if sys.hexversion < 0x020400f0:
+ sys.stderr.write("python version failed: current version = %s.%s, needed version >= 2.4\n" % (sys.version_info[0],sys.version_info[1]))
+ sys.exit(1)
+-try:
+- import libxml2
+-except ImportError:
+- sys.stderr.write("dependencies failed: python libxml2\n")
+- sys.exit(1)
+-try:
+- import libxslt
+-except ImportError:
+- sys.stderr.write("dependencies failed: python libxslt1\n")
+- sys.exit(1)
+-try:
+- import gtk.glade
+-except ImportError:
+- sys.stderr.write("dependencies failed: python glade\n")
+- sys.exit(1)
+-
+-
+
+ setup(name='loemu',
+ version='0.1.1',
+@@ -40,14 +23,14 @@
* The generation of subsets of the gamelist is very fast.
""",
license='GNU GPL',