aboutsummaryrefslogtreecommitdiff
path: root/emulators/mame
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-12-16 01:34:39 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-12-16 01:34:39 +0000
commita8aa67e112121f115ab398ead79a7c90a29aeec1 (patch)
treeae92dfadfdc072a619e480596a22c011c460fb79 /emulators/mame
parent53d4447fcc6a99d3999ef5ba457c32d9c6add1f8 (diff)
downloadports-a8aa67e112121f115ab398ead79a7c90a29aeec1.tar.gz
ports-a8aa67e112121f115ab398ead79a7c90a29aeec1.zip
- Use GCC 4.2 in FreeBSD 5.x since base system one fails (internal compiler
error), and using 3.4 from ports requires hacks to confuse bsd.gcc.mk. Reported by: pointyhat (via pav)
Notes
Notes: svn path=/head/; revision=203820
Diffstat (limited to 'emulators/mame')
-rw-r--r--emulators/mame/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index e533322fe0ee..d6a571494c1d 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -43,4 +43,13 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# In FreeBSD 5.x fails to build due to an internal compiler error. Using the
+# version 3.4 from ports which probably fixes this error requires a hack to
+# get around bsd.gcc.mk handling, so use a higher version than in base system.
+.if ${OSVERSION} < 600000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>