aboutsummaryrefslogtreecommitdiff
path: root/emulators/mame
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-08-01 17:22:55 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-08-01 17:22:55 +0000
commit95b3903d4c84912281fa33301cd74e2f71f32f82 (patch)
tree43a1e9340bfc20c7a5219cc769f9a0de3fc8a4eb /emulators/mame
parent7b50a91ba0c5652a2f710e6e2fbf2d4a728a3ffd (diff)
downloadports-95b3903d4c84912281fa33301cd74e2f71f32f82.tar.gz
ports-95b3903d4c84912281fa33301cd74e2f71f32f82.zip
Update to 0.139
PR: ports/149105 Submitted by: Emmanuel Vadot (maintainer)
Notes
Notes: svn path=/head/; revision=258590
Diffstat (limited to 'emulators/mame')
-rw-r--r--emulators/mame/Makefile4
-rw-r--r--emulators/mame/distinfo6
-rw-r--r--emulators/mame/files/mame.ini1
-rw-r--r--emulators/mame/files/patch-debugcpu.c13
-rw-r--r--emulators/mame/files/patch-makefile12
-rw-r--r--emulators/mame/files/sdl.mak.patch13
6 files changed, 36 insertions, 13 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 3684cc28274d..4ba7ba9bb4a1 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mame
-PORTVERSION= 0.138
+PORTVERSION= 0.139
CATEGORIES= emulators
MASTER_SITES= http://www.aarongiles.com/mirror/releases/ \
ftp://ftp.arcadebsd.org/pub/ArcadeBSD/ports/distfiles/
@@ -27,7 +27,7 @@ USE_GCC= 4.2+
MAKEFILE= makefile
ONLY_FOR_ARCHS= i386 amd64
SUB_FILES= pkg-message
-USE_DOS2UNIX= makefile sdl.mak
+USE_DOS2UNIX= makefile sdl.mak debugcpu.c
OPTIONS= DEBUG "Build mame debugger" off
diff --git a/emulators/mame/distinfo b/emulators/mame/distinfo
index a37994602aa4..c4ae27c6ff2d 100644
--- a/emulators/mame/distinfo
+++ b/emulators/mame/distinfo
@@ -1,3 +1,3 @@
-MD5 (mame0138s.zip) = c0932c5456af79ad83ab0a2dd2219b2e
-SHA256 (mame0138s.zip) = a80ee0b6d7c20743e35274d39129f313fb8756cfcb995c1cf95d5a81bdfabc2d
-SIZE (mame0138s.zip) = 16446378
+MD5 (mame0139s.zip) = e9f81e86b786e0131eb6fb59e6bfe189
+SHA256 (mame0139s.zip) = e9dc268530b9a2b6fe17330af96dc5680dadba1b5e444bf7ef8fa1f15de7f3d6
+SIZE (mame0139s.zip) = 16706970
diff --git a/emulators/mame/files/mame.ini b/emulators/mame/files/mame.ini
index 77be00e03be3..62bb8f8d8f9d 100644
--- a/emulators/mame/files/mame.ini
+++ b/emulators/mame/files/mame.ini
@@ -4,6 +4,7 @@
# CORE CONFIGURATION OPTIONS
#
readconfig 1
+writeconfig 0
#
# CORE SEARCH PATH OPTIONS
diff --git a/emulators/mame/files/patch-debugcpu.c b/emulators/mame/files/patch-debugcpu.c
new file mode 100644
index 000000000000..5cb69d9216c4
--- /dev/null
+++ b/emulators/mame/files/patch-debugcpu.c
@@ -0,0 +1,13 @@
+--- src/emu/debug/debugcpu.c.orig 2010-07-30 10:55:52.000000000 +0200
++++ src/emu/debug/debugcpu.c 2010-07-30 10:56:13.000000000 +0200
+@@ -49,7 +49,9 @@
+ #include "debugint/debugint.h"
+ #include "uiinput.h"
+ #include <ctype.h>
+-
++#ifdef __FreeBSD__
++#undef tolower
++#endif
+
+
+ /***************************************************************************
diff --git a/emulators/mame/files/patch-makefile b/emulators/mame/files/patch-makefile
index 7a7295f81335..5c722bda0d74 100644
--- a/emulators/mame/files/patch-makefile
+++ b/emulators/mame/files/patch-makefile
@@ -1,6 +1,6 @@
---- makefile.orig 2010-05-18 09:19:49.000000000 +0200
-+++ makefile 2010-05-18 09:21:03.000000000 +0200
-@@ -281,8 +281,8 @@
+--- makefile.orig 2010-07-30 10:42:41.000000000 +0200
++++ makefile 2010-07-30 10:43:26.000000000 +0200
+@@ -295,8 +295,8 @@
# compiler, linker and utilities
AR = @ar
@@ -10,12 +10,12 @@
+LD:= @$(CXX)
MD = -mkdir$(EXE)
RM = @rm -f
-
-@@ -329,7 +329,7 @@
+ OBJDUMP = @objdump
+@@ -344,7 +344,7 @@
endif
# fullname is prefix+name+suffix+suffix64+suffixdebug
--FULLNAME = $(PREFIX)$(PREFIXSDL)$(NAME)$(SUFFIX)$(SUFFIX64)$(SUFFIXDEBUG)$(SUFFIXGPROF)
+-FULLNAME = $(PREFIX)$(PREFIXSDL)$(NAME)$(SUFFIX)$(SUFFIX64)$(SUFFIXDEBUG)$(SUFFIXPROFILE)
+FULLNAME = $(NAME)
# add an EXE suffix to get the final emulator name
diff --git a/emulators/mame/files/sdl.mak.patch b/emulators/mame/files/sdl.mak.patch
index 0518b8181697..4ebbccccf877 100644
--- a/emulators/mame/files/sdl.mak.patch
+++ b/emulators/mame/files/sdl.mak.patch
@@ -1,5 +1,5 @@
---- src/osd/sdl/sdl.mak.orig 2010-03-24 00:15:07.000000000 +0100
-+++ src/osd/sdl/sdl.mak 2010-03-24 00:17:26.000000000 +0100
+--- src/osd/sdl/sdl.mak.orig 2010-02-14 04:47:30.000000000 +0100
++++ src/osd/sdl/sdl.mak 2010-07-30 12:05:33.000000000 +0200
@@ -139,7 +139,7 @@
ifeq ($(TARGETOS),freebsd)
BASE_TARGETOS = unix
@@ -9,6 +9,15 @@
# /usr/local/include is not considered a system include directory
# on FreeBSD. GL.h resides there and throws warnings
CCOMFLAGS += -isystem /usr/local/include
+@@ -205,7 +205,7 @@
+ ifndef GTK_INSTALL_ROOT
+ NO_DEBUGGER = 1
+ else
+-DEBUGOBJS = $(SDLOBJ)/debugwin.o $(SDLOBJ)/dview.o $(SDLOBJ)/debug-sup.o $(SDLOBJ)/debug-intf.o
++DEBUGOBJS = $(SDLOBJ)/debugwin.o
+ LIBS += -lgtk-win32-2.0 -lgdk-win32-2.0 -lgmodule-2.0 -lglib-2.0 -lgobject-2.0 \
+ -lpango-1.0 -latk-1.0 -lgdk_pixbuf-2.0
+ CCOMFLAGS += -mms-bitfields \
@@ -304,7 +304,7 @@
ifeq ($(BASE_TARGETOS),unix)