aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64-rice/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:03:32 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:03:32 +0000
commitedee770d1d7f642af2be9af8b40a12f71b5e5a37 (patch)
treecf8a62986553a9eb2417b17cddd7c80ad6d8c0bc /emulators/mupen64-rice/Makefile
parente77eb1a8bd2969918921bc54e7df55133366d458 (diff)
downloadports-edee770d1d7f642af2be9af8b40a12f71b5e5a37.tar.gz
ports-edee770d1d7f642af2be9af8b40a12f71b5e5a37.zip
Rice Daedalus graphics plugin for Mupen64
- Mupen64 is a highly portable Nintendo 64 emulator. It has been developed on/for Linux originally but has already been ported successfully to other operating systems. The program can easily be ported to all operating systems supported by the SDL library. In its current state, the emulator is highly compatible and uses a plugin system. With the correct plugins ("correct" can be computer dependent), it can achieve nearly perfect graphics and sound in many games. WWW: http://mupen64.emulation64.com/ PR: 71895 Submitted by: Travis Poppe
Notes
Notes: svn path=/head/; revision=118789
Diffstat (limited to 'emulators/mupen64-rice/Makefile')
-rw-r--r--emulators/mupen64-rice/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/emulators/mupen64-rice/Makefile b/emulators/mupen64-rice/Makefile
new file mode 100644
index 000000000000..7a9119a068bc
--- /dev/null
+++ b/emulators/mupen64-rice/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: mupen64-rice
+# Date created: 11.Aug 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 5.2.0
+CATEGORIES+= emulators
+MASTER_SITES= http://mupen64.emulation64.com/files/0.4/
+PKGNAMESUFFIX= -rice
+DISTNAME= riceplugin
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= Rice Daedalus graphics plugin for Mupen64
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GNOME= gtk12
+USE_GCC= 3.4
+ONLY_FOR_ARCHS= i386
+
+PLUGIN_NAME= ricedaedalus
+PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
+PLIST_FILES+= share/mupen64/plugins/RiceDaedalus5.1.0.ini
+PLIST_DIRS= share/mupen64/plugins
+PLIST_DIRS+= share/mupen64
+
+FIXME2= glh_genext.h
+
+do-configure:
+.for i in ${FIXME2}
+ ${REINPLACE_CMD} -e 's|SDL/SDL.h|SDL.h|' ${WRKSRC}/${i}
+.endfor
+ ${REINPLACE_CMD} -e 's|`gtk-config --libs`||' ${WRKSRC}/Makefile
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mupen64/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
+ ${PREFIX}/share/mupen64/plugins/
+ ${INSTALL_DATA} ${WRKSRC}/RiceDaedalus5.1.0.ini \
+ ${PREFIX}/share/mupen64/plugins/
+
+.include <bsd.port.pre.mk>
+
+CFLAGS+= `${SDL_CONFIG} --cflags`
+CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
+CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
+CFLAGS+= -DX86 -mcpu=athlon -msse -mmmx
+LDFLAGS+= `${GTK_CONFIG} --libs` \
+ -lGL -lGLU -L${X11BASE}/lib `${SDL_CONFIG} --libs` -lc
+
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CXX}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>