aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64-rice
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:03:32 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:03:32 +0000
commitedee770d1d7f642af2be9af8b40a12f71b5e5a37 (patch)
treecf8a62986553a9eb2417b17cddd7c80ad6d8c0bc /emulators/mupen64-rice
parente77eb1a8bd2969918921bc54e7df55133366d458 (diff)
downloadports-edee770d1d7f642af2be9af8b40a12f71b5e5a37.tar.gz
ports-edee770d1d7f642af2be9af8b40a12f71b5e5a37.zip
Rice Daedalus graphics plugin for Mupen64
- Mupen64 is a highly portable Nintendo 64 emulator. It has been developed on/for Linux originally but has already been ported successfully to other operating systems. The program can easily be ported to all operating systems supported by the SDL library. In its current state, the emulator is highly compatible and uses a plugin system. With the correct plugins ("correct" can be computer dependent), it can achieve nearly perfect graphics and sound in many games. WWW: http://mupen64.emulation64.com/ PR: 71895 Submitted by: Travis Poppe
Notes
Notes: svn path=/head/; revision=118789
Diffstat (limited to 'emulators/mupen64-rice')
-rw-r--r--emulators/mupen64-rice/Makefile61
-rw-r--r--emulators/mupen64-rice/distinfo2
-rw-r--r--emulators/mupen64-rice/files/patch-DecodedMux.cpp11
-rw-r--r--emulators/mupen64-rice/files/patch-Makefile18
-rw-r--r--emulators/mupen64-rice/files/patch-OGLCombinerTNT2.cpp35
-rw-r--r--emulators/mupen64-rice/files/patch-OGLExtCombiner.cpp35
-rw-r--r--emulators/mupen64-rice/files/patch-unique.h10
-rw-r--r--emulators/mupen64-rice/pkg-descr15
-rw-r--r--emulators/mupen64-rice/pkg-message9
9 files changed, 196 insertions, 0 deletions
diff --git a/emulators/mupen64-rice/Makefile b/emulators/mupen64-rice/Makefile
new file mode 100644
index 000000000000..7a9119a068bc
--- /dev/null
+++ b/emulators/mupen64-rice/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: mupen64-rice
+# Date created: 11.Aug 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 5.2.0
+CATEGORIES+= emulators
+MASTER_SITES= http://mupen64.emulation64.com/files/0.4/
+PKGNAMESUFFIX= -rice
+DISTNAME= riceplugin
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= Rice Daedalus graphics plugin for Mupen64
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GNOME= gtk12
+USE_GCC= 3.4
+ONLY_FOR_ARCHS= i386
+
+PLUGIN_NAME= ricedaedalus
+PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
+PLIST_FILES+= share/mupen64/plugins/RiceDaedalus5.1.0.ini
+PLIST_DIRS= share/mupen64/plugins
+PLIST_DIRS+= share/mupen64
+
+FIXME2= glh_genext.h
+
+do-configure:
+.for i in ${FIXME2}
+ ${REINPLACE_CMD} -e 's|SDL/SDL.h|SDL.h|' ${WRKSRC}/${i}
+.endfor
+ ${REINPLACE_CMD} -e 's|`gtk-config --libs`||' ${WRKSRC}/Makefile
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mupen64/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
+ ${PREFIX}/share/mupen64/plugins/
+ ${INSTALL_DATA} ${WRKSRC}/RiceDaedalus5.1.0.ini \
+ ${PREFIX}/share/mupen64/plugins/
+
+.include <bsd.port.pre.mk>
+
+CFLAGS+= `${SDL_CONFIG} --cflags`
+CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
+CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
+CFLAGS+= -DX86 -mcpu=athlon -msse -mmmx
+LDFLAGS+= `${GTK_CONFIG} --libs` \
+ -lGL -lGLU -L${X11BASE}/lib `${SDL_CONFIG} --libs` -lc
+
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CXX}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mupen64-rice/distinfo b/emulators/mupen64-rice/distinfo
new file mode 100644
index 000000000000..b4b5b05d7124
--- /dev/null
+++ b/emulators/mupen64-rice/distinfo
@@ -0,0 +1,2 @@
+MD5 (riceplugin.tar.bz2) = f6f42d31cee3fce0ea92176f42ef73ba
+SIZE (riceplugin.tar.bz2) = 287672
diff --git a/emulators/mupen64-rice/files/patch-DecodedMux.cpp b/emulators/mupen64-rice/files/patch-DecodedMux.cpp
new file mode 100644
index 000000000000..4dca5ebd1b04
--- /dev/null
+++ b/emulators/mupen64-rice/files/patch-DecodedMux.cpp
@@ -0,0 +1,11 @@
+--- DecodedMux.cpp.orig Thu Aug 28 22:39:21 2003
++++ DecodedMux.cpp Fri Aug 13 21:51:55 2004
+@@ -760,7 +760,7 @@
+ ShadeConstMergeMapType MergeShadeWithConstantsMaps[] =
+ {
+ 0, SHADE_DO_NOTHING,
+- 0x0007000600070006, SHADE_MOD_ENV, // SHADE * ENV
++ 0x0007000600070006LL, SHADE_MOD_ENV, // SHADE * ENV
+ };
+
+ // 0x05070501, 0x00070006 //(1 - PRIM) * ENV + PRIM
diff --git a/emulators/mupen64-rice/files/patch-Makefile b/emulators/mupen64-rice/files/patch-Makefile
new file mode 100644
index 000000000000..1dda732c7116
--- /dev/null
+++ b/emulators/mupen64-rice/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Sat Jul 3 22:23:08 2004
++++ Makefile Thu Aug 12 16:37:42 2004
+@@ -1,10 +1,10 @@
+-CC = gcc
++#CC = gcc
+ #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -g -mmmx -msse
+-CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
+-CXX = g++
++#CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
++#CXX = g++
+ CPPFLAGS = $(CFLAGS)
+-LD = g++
+-LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
++#LD = g++
++#LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
+
+ OBJECTS = DaedalusGraphics.o \
+ DaedalusRenderBase.o \
diff --git a/emulators/mupen64-rice/files/patch-OGLCombinerTNT2.cpp b/emulators/mupen64-rice/files/patch-OGLCombinerTNT2.cpp
new file mode 100644
index 000000000000..558ff069199c
--- /dev/null
+++ b/emulators/mupen64-rice/files/patch-OGLCombinerTNT2.cpp
@@ -0,0 +1,35 @@
+--- OGLCombinerTNT2.cpp.orig Fri Aug 29 15:50:40 2003
++++ OGLCombinerTNT2.cpp Fri Aug 13 21:54:26 2004
+@@ -120,6 +120,7 @@
+
+ GLenum COGLColorCombinerTNT2::RGBArgsMap[] =
+ {
++#ifndef __FreeBSD__
+ {GL_ZERO, }, //MUX_0
+ {GL_ZERO, }, //MUX_1
+ {GL_PREVIOUS_EXT, }, //MUX_COMBINED,
+@@ -136,6 +137,24 @@
+ {GL_CONSTANT_EXT, }, //MUX_ENV_ALPHA,
+ {GL_CONSTANT_EXT, }, //MUX_LODFRAC,
+ {GL_CONSTANT_EXT, }, //MUX_PRIMLODFRAC,
++#else
++ GL_ZERO, //MUX_0
++ GL_ZERO, //MUX_1
++ GL_PREVIOUS_EXT, //MUX_COMBINED,
++ GL_TEXTURE0_ARB, //MUX_TEXEL0,
++ GL_TEXTURE1_ARB, //MUX_TEXEL1,
++ GL_CONSTANT_EXT, //MUX_PRIM,
++ GL_PRIMARY_COLOR_EXT, //MUX_SHADE,
++ GL_CONSTANT_EXT, //MUX_ENV,
++ GL_PREVIOUS_EXT, //MUX_COMBALPHA,
++ GL_TEXTURE0_ARB, //MUX_T0_ALPHA,
++ GL_TEXTURE1_ARB, //MUX_T1_ALPHA,
++ GL_CONSTANT_EXT, //MUX_PRIM_ALPHA,
++ GL_PRIMARY_COLOR_EXT, //MUX_SHADE_ALPHA,
++ GL_CONSTANT_EXT, //MUX_ENV_ALPHA,
++ GL_CONSTANT_EXT, //MUX_LODFRAC,
++ GL_CONSTANT_EXT, //MUX_PRIMLODFRAC,
++#endif
+ };
+
+
diff --git a/emulators/mupen64-rice/files/patch-OGLExtCombiner.cpp b/emulators/mupen64-rice/files/patch-OGLExtCombiner.cpp
new file mode 100644
index 000000000000..6ac8a5a08a7d
--- /dev/null
+++ b/emulators/mupen64-rice/files/patch-OGLExtCombiner.cpp
@@ -0,0 +1,35 @@
+--- OGLExtCombiner.cpp.orig Thu Aug 28 23:31:44 2003
++++ OGLExtCombiner.cpp Fri Aug 13 21:55:55 2004
+@@ -474,6 +474,7 @@
+
+ GLenum COGLExtColorCombiner::RGBArgsMap[] =
+ {
++#ifndef __FreeBSD__
+ {GL_PRIMARY_COLOR_ARB, }, //MUX_0
+ {GL_PRIMARY_COLOR_ARB, }, //MUX_1
+ {GL_PREVIOUS_ARB, }, //MUX_COMBINED,
+@@ -490,6 +491,24 @@
+ {GL_CONSTANT_ARB, }, //MUX_ENV_ALPHA,
+ {GL_CONSTANT_ARB, }, //MUX_LODFRAC,
+ {GL_CONSTANT_ARB, }, //MUX_PRIMLODFRAC,
++#else
++ GL_PRIMARY_COLOR_ARB, //MUX_0
++ GL_PRIMARY_COLOR_ARB, //MUX_1
++ GL_PREVIOUS_ARB, //MUX_COMBINED,
++ GL_TEXTURE0_ARB, //MUX_TEXEL0,
++ GL_TEXTURE1_ARB, //MUX_TEXEL1,
++ GL_CONSTANT_ARB, //MUX_PRIM,
++ GL_PRIMARY_COLOR_ARB, //MUX_SHADE,
++ GL_CONSTANT_ARB, //MUX_ENV,
++ GL_PREVIOUS_ARB, //MUX_COMBALPHA,
++ GL_TEXTURE0_ARB, //MUX_T0_ALPHA,
++ GL_TEXTURE1_ARB, //MUX_T1_ALPHA,
++ GL_CONSTANT_ARB, //MUX_PRIM_ALPHA,
++ GL_PRIMARY_COLOR_ARB, //MUX_SHADE_ALPHA,
++ GL_CONSTANT_ARB, //MUX_ENV_ALPHA,
++ GL_CONSTANT_ARB, //MUX_LODFRAC,
++ GL_CONSTANT_ARB, //MUX_PRIMLODFRAC,
++#endif
+ };
+
+
diff --git a/emulators/mupen64-rice/files/patch-unique.h b/emulators/mupen64-rice/files/patch-unique.h
new file mode 100644
index 000000000000..208681ff9e2a
--- /dev/null
+++ b/emulators/mupen64-rice/files/patch-unique.h
@@ -0,0 +1,10 @@
+--- unique.h.orig Tue Aug 26 00:25:58 2003
++++ unique.h Fri Aug 13 21:51:55 2004
+@@ -18,6 +18,7 @@
+
+ */
+
++#include <assert.h>
+ #ifndef __UNIQUE_H__
+ #define __UNIQUE_H__
+
diff --git a/emulators/mupen64-rice/pkg-descr b/emulators/mupen64-rice/pkg-descr
new file mode 100644
index 000000000000..dcfa80a43d5e
--- /dev/null
+++ b/emulators/mupen64-rice/pkg-descr
@@ -0,0 +1,15 @@
+Rice Daedalus graphics plugin for Mupen64
+-
+Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
+on/for Linux originally but has already been ported successfully to other
+operating systems. The program can easily be ported to all operating systems
+supported by the SDL library.
+
+In its current state, the emulator is highly compatible and uses a plugin
+system. With the correct plugins ("correct" can be computer dependent), it
+can achieve nearly perfect graphics and sound in many games.
+
+WWW: http://mupen64.emulation64.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/mupen64-rice/pkg-message b/emulators/mupen64-rice/pkg-message
new file mode 100644
index 000000000000..d53470396a22
--- /dev/null
+++ b/emulators/mupen64-rice/pkg-message
@@ -0,0 +1,9 @@
+-------------------------------------------------------------------------------
+If you have installed/upgraded any new plugins or are upgrading from a previous
+version of Mupen64, please note that in order for these changes to take effect,
+you -must- backup and then remove ~/.mupen64 first. After you have removed the
+directory, run 'mupen64' to re-create it. Then, manually copy back your save
+files/other data you need from the backup if necessary.
+
+Enjoy!
+-------------------------------------------------------------------------------