aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64-rice
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /emulators/mupen64-rice
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'emulators/mupen64-rice')
-rw-r--r--emulators/mupen64-rice/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/emulators/mupen64-rice/Makefile b/emulators/mupen64-rice/Makefile
index 1b144d704536..0db52eed3d67 100644
--- a/emulators/mupen64-rice/Makefile
+++ b/emulators/mupen64-rice/Makefile
@@ -54,7 +54,7 @@ CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
CFLAGS+= -DX86 -mcpu=athlon -msse -mmmx
LDFLAGS+= `${GTK_CONFIG} --libs` \
- -lGL -lGLU -L${X11BASE}/lib `${SDL_CONFIG} --libs` -lc
+ -lGL -lGLU -L${LOCALBASE}/lib `${SDL_CONFIG} --libs` -lc
MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CXX}"