aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64-sound
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-09 03:50:04 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-09 03:50:04 +0000
commitfb3f49d7410298270f9b4502eaa98c90d65764d1 (patch)
tree686d538f4897b13ab0b43c0ebe54a4d18a483291 /emulators/mupen64-sound
parentb49b2025fe5663123cbd177b2da0c600cdba27a6 (diff)
downloadports-fb3f49d7410298270f9b4502eaa98c90d65764d1.tar.gz
ports-fb3f49d7410298270f9b4502eaa98c90d65764d1.zip
- Update to 0.5
- Remove a lot of obsolete patch files - Clean up all emulators/mupen64* ports - Add new way to build mupen64 emulator and all plugins - Pass maintainership to me Approved by: tlp (maintainer via irc)
Notes
Notes: svn path=/head/; revision=201133
Diffstat (limited to 'emulators/mupen64-sound')
-rw-r--r--emulators/mupen64-sound/Makefile37
-rw-r--r--emulators/mupen64-sound/distinfo3
-rw-r--r--emulators/mupen64-sound/files/patch-Makefile14
-rw-r--r--emulators/mupen64-sound/files/patch-mupen64_audio_main.c11
-rw-r--r--emulators/mupen64-sound/pkg-descr16
-rw-r--r--emulators/mupen64-sound/pkg-message9
6 files changed, 15 insertions, 75 deletions
diff --git a/emulators/mupen64-sound/Makefile b/emulators/mupen64-sound/Makefile
index 1b2ee6fe9aa2..a6db9aa56845 100644
--- a/emulators/mupen64-sound/Makefile
+++ b/emulators/mupen64-sound/Makefile
@@ -5,45 +5,16 @@
# $FreeBSD$
#
-PORTNAME= mupen64
-PORTVERSION= 0.4
-PORTREVISION= 3
-CATEGORIES+= emulators
-MASTER_SITES= http://mupen64.emulation64.com/files/${PORTVERSION}/
PKGNAMESUFFIX= -sound
-DISTNAME= mupen64_sound
-MAINTAINER?= tlp@LiquidX.org
COMMENT= Sound plugin for Mupen64
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_GNOME= gtk12
-USE_GCC= 3.4
-ONLY_FOR_ARCHS= i386
+FIXFILES= #
PLUGIN_NAME= mupen64_audio
-PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
-PLIST_DIRS= share/mupen64/plugins share/mupen64
-post-patch:
- @${REINPLACE_CMD} -e 's|linux/soundcard.h|sys/soundcard.h|' ${WRKSRC}/main.c
+MASTERDIR= ${.CURDIR}/../mupen64-base
-do-install:
- @${MKDIR} ${PREFIX}/share/mupen64/plugins
- ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
- ${PREFIX}/share/mupen64/plugins/
+OPTIONS= #
-.include <bsd.port.pre.mk>
-
-CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
-CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
-CFLAGS+= -DX86 -mcpu=athlon
-LDFLAGS+= -shared -Wl,-Bsymbolic
-
-MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CC}"
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64-sound/distinfo b/emulators/mupen64-sound/distinfo
deleted file mode 100644
index b1a5b7e9a9fb..000000000000
--- a/emulators/mupen64-sound/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (mupen64_sound.tar.bz2) = 88dfa0045794db7f1fc100b4c7b23125
-SHA256 (mupen64_sound.tar.bz2) = df53df36a416dad22db87325dae8dc14174f5b7ef6a7e8680b2ff855eb31581a
-SIZE (mupen64_sound.tar.bz2) = 5932
diff --git a/emulators/mupen64-sound/files/patch-Makefile b/emulators/mupen64-sound/files/patch-Makefile
deleted file mode 100644
index e723a4e55f5e..000000000000
--- a/emulators/mupen64-sound/files/patch-Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.orig Sun Jul 4 11:43:39 2004
-+++ Makefile Thu Aug 12 16:09:11 2004
-@@ -1,7 +1,7 @@
--CC = gcc
--CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall
--LD = gcc
--LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread
-+#CC = gcc
-+#CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall
-+#LD = gcc
-+#LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread
-
- OBJECTS = main.o
-
diff --git a/emulators/mupen64-sound/files/patch-mupen64_audio_main.c b/emulators/mupen64-sound/files/patch-mupen64_audio_main.c
new file mode 100644
index 000000000000..4c83c30b7024
--- /dev/null
+++ b/emulators/mupen64-sound/files/patch-mupen64_audio_main.c
@@ -0,0 +1,11 @@
+--- mupen64_audio/main.c 2007-10-08 01:41:12.000000000 -0500
++++ mupen64_audio/main.c 2007-10-08 01:41:23.000000000 -0500
+@@ -6,7 +6,7 @@
+ #include <stdlib.h>
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
+-#include <linux/soundcard.h>
++#include <sys/soundcard.h>
+ #include <unistd.h>
+ #include <pthread.h>
+ #include <sys/time.h>
diff --git a/emulators/mupen64-sound/pkg-descr b/emulators/mupen64-sound/pkg-descr
deleted file mode 100644
index 75e5a47238c0..000000000000
--- a/emulators/mupen64-sound/pkg-descr
+++ /dev/null
@@ -1,16 +0,0 @@
-Sound plugin for Mupen64
-Tip: Use mupen64-sdlaudio (JttL's SDL plugin) instead!
--
-Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
-on/for Linux originally but has already been ported successfully to other
-operating systems. The program can easily be ported to all operating systems
-supported by the SDL library.
-
-In its current state, the emulator is highly compatible and uses a plugin
-system. With the correct plugins ("correct" can be computer dependent), it
-can achieve nearly perfect graphics and sound in many games.
-
-WWW: http://mupen64.emulation64.com/
-
-- Travis Poppe
-tlp@liquidx.org
diff --git a/emulators/mupen64-sound/pkg-message b/emulators/mupen64-sound/pkg-message
deleted file mode 100644
index d53470396a22..000000000000
--- a/emulators/mupen64-sound/pkg-message
+++ /dev/null
@@ -1,9 +0,0 @@
--------------------------------------------------------------------------------
-If you have installed/upgraded any new plugins or are upgrading from a previous
-version of Mupen64, please note that in order for these changes to take effect,
-you -must- backup and then remove ~/.mupen64 first. After you have removed the
-directory, run 'mupen64' to re-create it. Then, manually copy back your save
-files/other data you need from the backup if necessary.
-
-Enjoy!
--------------------------------------------------------------------------------