aboutsummaryrefslogtreecommitdiff
path: root/emulators/pearpc
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-12-22 12:07:37 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-12-22 12:07:37 +0000
commit1243cee332a41a40d2699d2b68cd145db394a5f4 (patch)
tree0239c2751a339de38e845ec19c5b3958b3adf41a /emulators/pearpc
parent11156b99f686dd7c73e8fed0e2a3382d3bbeda5d (diff)
downloadports-1243cee332a41a40d2699d2b68cd145db394a5f4.tar.gz
ports-1243cee332a41a40d2699d2b68cd145db394a5f4.zip
Update to 0.4.
PR: 90791 (based on) Submitted by: Vasil Dimov <vd@datamax.bg>
Notes
Notes: svn path=/head/; revision=151834
Diffstat (limited to 'emulators/pearpc')
-rw-r--r--emulators/pearpc/Makefile4
-rw-r--r--emulators/pearpc/distinfo5
-rw-r--r--emulators/pearpc/files/patch-gcc3441
3 files changed, 5 insertions, 45 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index a661c8328d82..f54905b43ed9 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pearpc
-PORTVERSION= 0.3.1
+PORTVERSION= 0.4
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,7 +17,7 @@ COMMENT= PowerPC emulator
USE_XLIB= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= ppc.1
diff --git a/emulators/pearpc/distinfo b/emulators/pearpc/distinfo
index e084f807a182..3c104244e214 100644
--- a/emulators/pearpc/distinfo
+++ b/emulators/pearpc/distinfo
@@ -1,2 +1,3 @@
-MD5 (pearpc-0.3.1.tar.gz) = d7ac0566f6ab884029e374ac68842932
-SIZE (pearpc-0.3.1.tar.gz) = 834258
+MD5 (pearpc-0.4.tar.gz) = c0eaeb588da2d6cd0ccfd62ea426e35f
+SHA256 (pearpc-0.4.tar.gz) = cf9501dc95b418dc9632e57c75d59e78ec5204db0ed6b41abced2cea30021cce
+SIZE (pearpc-0.4.tar.gz) = 910621
diff --git a/emulators/pearpc/files/patch-gcc34 b/emulators/pearpc/files/patch-gcc34
deleted file mode 100644
index c09b6393ab39..000000000000
--- a/emulators/pearpc/files/patch-gcc34
+++ /dev/null
@@ -1,41 +0,0 @@
---- src/cpu/cpu_jitc_x86/ppc_cpu.h.orig Tue Oct 5 15:48:01 2004
-+++ src/cpu/cpu_jitc_x86/ppc_cpu.h Tue Oct 5 17:03:40 2004
-@@ -112,7 +112,8 @@
- uint32 current_code_base;
- } PACKED;
-
--enum PPC_Register {
-+
-+/*enum PPC_Register {
- PPC_REG_NO = 0,
- PPC_GPR0 = offsetof(PPC_CPU_State, gpr),
- PPC_FPR1 = offsetof(PPC_CPU_State, fpr),
-@@ -132,7 +133,27 @@
- PPC_PVR = offsetof(PPC_CPU_State, pvr),
- PPC_HID0 = offsetof(PPC_CPU_State, hid),
- PPC_HID1 = offsetof(PPC_CPU_State, hid)+sizeof (uint32),
--};
-+};*/
-+#define PPC_Register size_t
-+#define PPC_REG_NO 0
-+#define PPC_GPR0 offsetof(PPC_CPU_State, gpr)
-+#define PPC_FPR1 offsetof(PPC_CPU_State, fpr)
-+#define PPC_CR offsetof(PPC_CPU_State, cr)
-+#define PPC_FPSCR offsetof(PPC_CPU_State, fpscr)
-+#define PPC_XER offsetof(PPC_CPU_State, xer)
-+#define PPC_LR offsetof(PPC_CPU_State, lr)
-+#define PPC_CTR offsetof(PPC_CPU_State, ctr)
-+#define PPC_MSR offsetof(PPC_CPU_State, msr)
-+#define PPC_SRR0 offsetof(PPC_CPU_State, srr)
-+#define PPC_SRR1 offsetof(PPC_CPU_State, srr)+sizeof (uint32)
-+#define PPC_DSISR offsetof(PPC_CPU_State, dsisr)
-+#define PPC_DAR offsetof(PPC_CPU_State, dar)
-+#define PPC_DEC offsetof(PPC_CPU_State, dec)
-+#define PPC_SDR1 offsetof(PPC_CPU_State, sdr1)
-+#define PPC_EAR offsetof(PPC_CPU_State, ear)
-+#define PPC_PVR offsetof(PPC_CPU_State, pvr)
-+#define PPC_HID0 offsetof(PPC_CPU_State, hid)
-+#define PPC_HID1 offsetof(PPC_CPU_State, hid)+sizeof (uint32)
-
- enum PPC_CRx {
- PPC_CR0=0,