aboutsummaryrefslogtreecommitdiff
path: root/emulators/pearpc
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-04-16 14:10:33 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-04-16 14:10:33 +0000
commit638d2d94c3a79d2683cf18b9abcaa3738f5c82a2 (patch)
treedae0636823d8b98c1e246d5c1017ef408543d55f /emulators/pearpc
parent1c64e698a238be032110c81e245c239b0e82d521 (diff)
downloadports-638d2d94c3a79d2683cf18b9abcaa3738f5c82a2.tar.gz
ports-638d2d94c3a79d2683cf18b9abcaa3738f5c82a2.zip
- Fix build on -CURRENT
- Pet portlint Reported by: pointyhat via kris
Notes
Notes: svn path=/head/; revision=159702
Diffstat (limited to 'emulators/pearpc')
-rw-r--r--emulators/pearpc/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 512c51e5ac72..e2ae8774befa 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= novel@FreeBSD.org
COMMENT= PowerPC emulator
USE_XLIB= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -58,7 +57,7 @@ CONFIGURE_ARGS+= --disable-debug
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
-BROKEN= "Internal compiler error on ia64"
+BROKEN= Internal compiler error on ia64
.endif
# jitc_x86 is avaible only on x86
@@ -76,7 +75,7 @@ CONFIGURE_ARGS+= --enable-cpu=generic
.if ${OSVERSION} < 503001
#USE_GCC= 3.4
#CFLAGS+= -DFREEBSD_MB_SUPPORT
-BROKEN= "Missing truncf()"
+BROKEN= Missing truncf()
.endif
pre-everything::
@@ -89,6 +88,11 @@ pre-everything::
post-extract:
@${REINPLACE_CMD} -e 's|-g -O2||;s|-O2||' ${WRKSRC}/configure
+pre-configure:
+.if ${OSVERSION} > 700000
+ @${REINPLACE_CMD} -e 's|clock_settime\ ()|foobar()|' ${WRKSRC}/configure
+.endif
+
post-configure:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/Makefile