aboutsummaryrefslogtreecommitdiff
path: root/emulators/pearpc
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-10-29 03:44:42 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-10-29 03:44:42 +0000
commit06f57ae75da3cb1b63f665ca8f3817aeac3fe324 (patch)
tree4ddb2a3e1719bf143675f3d4bdfaa6a992147a9d /emulators/pearpc
parent3265911541ce82e93ea6bcd7d53d7e7f408fd02a (diff)
downloadports-06f57ae75da3cb1b63f665ca8f3817aeac3fe324.tar.gz
ports-06f57ae75da3cb1b63f665ca8f3817aeac3fe324.zip
- Do not allow making an optimized build unless WITH_OPTIMIZED_CFLAGS
is not defined - Add WITH_DEBUG knob (disabled by default)
Notes
Notes: svn path=/head/; revision=146634
Diffstat (limited to 'emulators/pearpc')
-rw-r--r--emulators/pearpc/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index aeb9446e9ae0..13886a8619fe 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -28,7 +28,8 @@ PLIST_DIRS= %%DATADIR%%
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math
.else
-CONFIGURE_ARGS+= --disable-fpo
+CONFIGURE_ARGS+= --disable-fpo \
+ --disable-release
.endif
# GTK and QT ui are broken in this version
@@ -49,6 +50,12 @@ USE_SDL= sdl
CONFIGURE_ARGS+= --enable-ui=x11
.endif
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.else
+CONFIGURE_ARGS+= --disable-debug
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"