aboutsummaryrefslogtreecommitdiff
path: root/emulators/pipelight
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2014-12-15 17:00:22 +0000
committerKris Moore <kmoore@FreeBSD.org>2014-12-15 17:00:22 +0000
commit2f78781bb555a5635b6fbc2ea6bda5d8af6802aa (patch)
tree98cadba8dbb54df6f8eedbf31bb7e78559e7f18a /emulators/pipelight
parent241235babd4d6391c232dec284ae664326ca2479 (diff)
downloadports-2f78781bb555a5635b6fbc2ea6bda5d8af6802aa.tar.gz
ports-2f78781bb555a5635b6fbc2ea6bda5d8af6802aa.zip
- Fix a bug in pipelight-mkufs script
- Bump PORTREV PR: 195963 Submitted by: f0andrey@gmail.com
Notes
Notes: svn path=/head/; revision=374755
Diffstat (limited to 'emulators/pipelight')
-rw-r--r--emulators/pipelight/Makefile2
-rw-r--r--emulators/pipelight/files/pipelight-mkufs.in5
2 files changed, 5 insertions, 2 deletions
diff --git a/emulators/pipelight/Makefile b/emulators/pipelight/Makefile
index f686ee6d262a..e99a9df4afff 100644
--- a/emulators/pipelight/Makefile
+++ b/emulators/pipelight/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pipelight
DISTVERSION= 0.2.7.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= emulators
MASTER_SITES= https://bitbucket.org/mmueller2012/pipelight/get/ \
http://repos.fds-team.de/pluginloader/v${DISTVERSION}/:plg
diff --git a/emulators/pipelight/files/pipelight-mkufs.in b/emulators/pipelight/files/pipelight-mkufs.in
index 3a0c1d6cf120..24ee77d99526 100644
--- a/emulators/pipelight/files/pipelight-mkufs.in
+++ b/emulators/pipelight/files/pipelight-mkufs.in
@@ -85,8 +85,11 @@ if [ $? -ne 0 ] ; then
exit 1
fi
+# Get user group
+usergroup=`groups $username | cut -d " " -f 1`
+
# Chown the directory
-chown $username:$username ${userhome}/.wine-pipelight
+chown $username:$usergroup ${userhome}/.wine-pipelight
# Save to fstab
echo "/dev/zvol/$zpool/$username-pipelight ${userhome}/.wine-pipelight ufs rw,late 0 0" >> /etc/fstab